Author Topic: Glibc 2.3.x On The Zaurus C Series  (Read 1896 times)

omro

  • Hero Member
  • *****
  • Posts: 796
    • View Profile
    • http://
Glibc 2.3.x On The Zaurus C Series
« on: August 10, 2005, 11:27:49 am »
Hi guys,

I thought it best to set up this thread to bring attention to this specific problem.  While it is related to the OpenOffice thread (please read this if you can), it is a separate issue and fixing this might be beneficial for pdaXrom in general for other application compatibility issues. Also someone may have fixed this for themselves, who hasn't been following the OpenOffice thread, and wasn't aware that this was an issue.

A stumbling block that is preventing the install and running of OpenOffice is that there seems to be a problem successfully compiling glibc 2.3.x to run on the C series Zaurus and I was wondering if anyone had had any success with compiling this? Any pointers would seriously be appreciated!

Could any errors/notes relating to this be posted here.

Thanks in advance for any assistance!
« Last Edit: August 10, 2005, 11:45:14 am by omro »
Zaurus C-1000

maxg

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Glibc 2.3.x On The Zaurus C Series
« Reply #1 on: August 10, 2005, 12:20:16 pm »
glibc 2.3.5 compiles, but you have to pass --disable-fp to configure or you'll get a LOT of errors. Don't forget to add --enable-add-ons or you'll have a nicely corrupted thread library. There is also a couple of change to make in linuxthreads. However, this version makes pdaX generally unstable, and a lot of programs will segfaults or ask to be relinked, since some symbols changed in 2.3 (you'll have noticed it if you tried to compile openoffice). I think we should better compile OO with glibc 2.2 than trying to update pdaX to 2.3, or we'll have to recompile a lot of packages.
All my reports and testing were made (if no other mention given) on SL-C1000

omro

  • Hero Member
  • *****
  • Posts: 796
    • View Profile
    • http://
Glibc 2.3.x On The Zaurus C Series
« Reply #2 on: August 11, 2005, 05:32:54 am »
As a bit of a linux newbie, I would have thought that updating the glibc from 2.2 to 2.3 would have been a good thing for pdaXrom. I'm guessing not. No?
Zaurus C-1000

sirob

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • http://blog.earpassion.net/
Glibc 2.3.x On The Zaurus C Series
« Reply #3 on: August 11, 2005, 06:02:42 am »
Quote
As a bit of a linux newbie, I would have thought that updating the glibc from 2.2 to 2.3 would have been a good thing for pdaXrom. I'm guessing not. No?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=91460\"][{POST_SNAPBACK}][/a][/div]

That would raise a bit of compatibility issues.

omro

  • Hero Member
  • *****
  • Posts: 796
    • View Profile
    • http://
Glibc 2.3.x On The Zaurus C Series
« Reply #4 on: August 11, 2005, 06:10:23 am »
So how easy is it to recompile openoffice to the glibc 2.2.x?
Zaurus C-1000