Author Topic: Help! Broken Xfce4!  (Read 1884 times)

silencer51

  • Full Member
  • ***
  • Posts: 172
    • View Profile
    • http://tchalikias.blogspot.com
Help! Broken Xfce4!
« on: January 26, 2006, 10:46:52 pm »
I had XFCE4 installed with every plugin working perfectly ok, and I must have done something (i remember installing thunar just before the shit hit the fan) because whenever I try to start xfce4 I get the desktop with the taskbar only.

To be more precise: I tried removing xfce4 and all its config files completely, installing it to a different medium etc. but the problem is this - I can start it after a clean install, but whenever I try to add the XFCE Panel menu to the panel the entire panel dissapears and I am left with no option but to ctrl-alt-backspace out of x :-(

I did notice one error message when back in the console:


(xfce4-panel:5687): libxfce4util-CRITICAL **: xfce_desktop_entry_new: assertion `g_file_test (priv->file, G_FILE_TEST_EXISTS)' failed

When this error appears, the panel vanishes and can't be brought back... I'm really worried 'cause XFCE4 is in my opinion, the best WM for the Z right now. It's fast and pretty and very very usable - and I had everything setup perfectly only to flush it down the toilet... This sucks! :-(

Can anybody help?
Zaurus SL-5500 with:
128MB CF Card                                    
128MB SD Card
Symbol WiFi CF Card (working, sorta... overheats and shuts down!)
OZ 3.5.4 & GPE

Zaurus SL-C3100 with:
pdaXrom 1.1.0beta3 & XFCE4, /dev/hda1 256MB swap, /dev/hda2 512MB ext3, /dev/hda3 3328MB FAT32 for stuff
D-Link DCF-660 WiFi CF Card
1GB SD Card
128MB SD Card
128MB CF Card (for flashing)
USB Host Cable

& a Sony VAIO PCG-C1XD Picturebook with accessories...

[img]http://img58.imageshack.us/img58/7319/usbar21mw.gif\" border=\"0\" class=\"linked-sig-image\" /]

karlto

  • Sr. Member
  • ****
  • Posts: 343
    • View Profile
    • http://
Help! Broken Xfce4!
« Reply #1 on: January 26, 2006, 10:53:50 pm »
Quote
I had XFCE4 installed with every plugin working perfectly ok, and I must have done something (i remember installing thunar just before the shit hit the fan) because whenever I try to start xfce4 I get the desktop with the taskbar only.

To be more precise: I tried removing xfce4 and all its config files completely, installing it to a different medium etc. but the problem is this - I can start it after a clean install, but whenever I try to add the XFCE Panel menu to the panel the entire panel dissapears and I am left with no option but to ctrl-alt-backspace out of x :-(

I did notice one error message when back in the console:


(xfce4-panel:5687): libxfce4util-CRITICAL **: xfce_desktop_entry_new: assertion `g_file_test (priv->file, G_FILE_TEST_EXISTS)' failed

When this error appears, the panel vanishes and can't be brought back... I'm really worried 'cause XFCE4 is in my opinion, the best WM for the Z right now. It's fast and pretty and very very usable - and I had everything setup perfectly only to flush it down the toilet... This sucks! :-(

Can anybody help?
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]


See this thread:

[a href=\"https://www.oesf.org/forums/index.php?showtopic=14031&hl=xfce4&st=15]Xfce4 fine tuning[/url]

It seems to take some fiddling with and you have to quickly add the menu then close the panel utility - it took me a few gos, but once you get it there it stays there (just leave it alone).

I think I only added the basic menu too, not the panel menu as I couldn't get past this hiccup either...

Maybe Chero has found a fix by now?
SL6000-L, RC12

silencer51

  • Full Member
  • ***
  • Posts: 172
    • View Profile
    • http://tchalikias.blogspot.com
Help! Broken Xfce4!
« Reply #2 on: January 26, 2006, 11:03:05 pm »
I still can't do it... I have tried every way of adding the menu to the panel yet it always dies... When I bring it back up the menu is not there... :-(

How come this happens now, and it didn't when I first installed XFCE4? I suspect there's something wrong with libxfce4util... There is no other rational explanation, it working fine one minute, and then, after installing a couple of packages - thunar included - BAM! no more xfce for me... :-(
Zaurus SL-5500 with:
128MB CF Card                                    
128MB SD Card
Symbol WiFi CF Card (working, sorta... overheats and shuts down!)
OZ 3.5.4 & GPE

Zaurus SL-C3100 with:
pdaXrom 1.1.0beta3 & XFCE4, /dev/hda1 256MB swap, /dev/hda2 512MB ext3, /dev/hda3 3328MB FAT32 for stuff
D-Link DCF-660 WiFi CF Card
1GB SD Card
128MB SD Card
128MB CF Card (for flashing)
USB Host Cable

& a Sony VAIO PCG-C1XD Picturebook with accessories...

[img]http://img58.imageshack.us/img58/7319/usbar21mw.gif\" border=\"0\" class=\"linked-sig-image\" /]

silencer51

  • Full Member
  • ***
  • Posts: 172
    • View Profile
    • http://tchalikias.blogspot.com
Help! Broken Xfce4!
« Reply #3 on: January 26, 2006, 11:12:13 pm »
I keep trying... Nothing. I also don't get the desktop menu when right-clicking. I just noticed that there is another related error message, this appears when loading xfce  (right before I get to the desktop):

(xfdesktop:6255): libxfce4util-CRITICAL **: xfce_desktop_entry_new: assertion `g_file_test (priv->file, G_FILE_TEST_EXISTS)' failed

Any ideas?
Zaurus SL-5500 with:
128MB CF Card                                    
128MB SD Card
Symbol WiFi CF Card (working, sorta... overheats and shuts down!)
OZ 3.5.4 & GPE

Zaurus SL-C3100 with:
pdaXrom 1.1.0beta3 & XFCE4, /dev/hda1 256MB swap, /dev/hda2 512MB ext3, /dev/hda3 3328MB FAT32 for stuff
D-Link DCF-660 WiFi CF Card
1GB SD Card
128MB SD Card
128MB CF Card (for flashing)
USB Host Cable

& a Sony VAIO PCG-C1XD Picturebook with accessories...

[img]http://img58.imageshack.us/img58/7319/usbar21mw.gif\" border=\"0\" class=\"linked-sig-image\" /]

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
Help! Broken Xfce4!
« Reply #4 on: January 27, 2006, 02:16:30 am »
Hi,

Some of the core xfce4 libs don't like to be installed on a different medium. I avoid problems by installing the base system (= xfce4_4.2.2_armv5tel.ipk) to /.

If you don't have the drop-down menu, the desktop likely crashed (this is bad). Probably one of your libs is broken (this happened to me on SD and HD, never on /).

- Remove .config and .cache
- ipkg remove xfce4
- Try reinstalling to /

Then, before fiddling, launch an aterm.

When you try to add the menu to the panel, and the panel disappaers, try bringing it back with the aterm (# xfce4-panel &).

The "crashing panel" is an xfce related bug, it has been solved in 4.2.3.2, but I haven't found the time to recompile it.

Chero.
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.

silencer51

  • Full Member
  • ***
  • Posts: 172
    • View Profile
    • http://tchalikias.blogspot.com
Help! Broken Xfce4!
« Reply #5 on: January 27, 2006, 04:40:39 am »
Thanks for your help guys, I finally have xfce4 up and running again. I had to remove some packages from / to free up some space (I had about 4mb left) and I did a clean installation of xfce4 on /. It now works like a charm, the error messages (G_FILE_EXISTS etc.) remain but at least now everything works like before. What I don't understand is how could it work perfectly ok the first time I installed it on the MD and suddenly it stopped working...
Zaurus SL-5500 with:
128MB CF Card                                    
128MB SD Card
Symbol WiFi CF Card (working, sorta... overheats and shuts down!)
OZ 3.5.4 & GPE

Zaurus SL-C3100 with:
pdaXrom 1.1.0beta3 & XFCE4, /dev/hda1 256MB swap, /dev/hda2 512MB ext3, /dev/hda3 3328MB FAT32 for stuff
D-Link DCF-660 WiFi CF Card
1GB SD Card
128MB SD Card
128MB CF Card (for flashing)
USB Host Cable

& a Sony VAIO PCG-C1XD Picturebook with accessories...

[img]http://img58.imageshack.us/img58/7319/usbar21mw.gif\" border=\"0\" class=\"linked-sig-image\" /]