Author Topic: Sl-c3200 Full Hd “openbsd Hallelujah”  (Read 9391 times)

hus

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
    • http://www.huslab.com
Sl-c3200 Full Hd “openbsd Hallelujah”
« Reply #15 on: July 29, 2006, 05:58:28 am »
Quote
cacko mounts /dev/mtdblock2 to / according to fstab. I cd /etc/pcmcia and did a 'more config'. I looked over everything that had ide mentioned and everything was already edited? There was nothing in the form ide-cs. I have attached the config file to this post. Let me know if you see anything wrong.

 [ Invalid Attachment ]
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

wait!! you are using cacko? not the full HD install (tiny-rom) and files provided by Andy (iamasmith) in his guide?

if you want to use cacko and OpenBSD better to follow the official install guide here [a href=\"ftp://ftp.openbsd.org/pub/OpenBSD/3.9/zaurus/INSTALL.zaurus]zaurus.INSTALL[/url]

basiclly install the ipk provided to install OpenBSD.

What i have mentioned it in this topic is the installation for FULL HD using small cutom rom been submeted by Andy here https://www.oesf.org/forums/index.php?showtopic=17213
using the file he provides and simple edit i have explain it in this post.

try to go back to iamasmith (Andy) guide and see what you have missed.
SL-C3200
GP2X-F100 (MKII)

mathemajikian

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
    • http://exit3.i-55.com/~xikon/openbsdzaurus.html
Sl-c3200 Full Hd “openbsd Hallelujah”
« Reply #16 on: July 29, 2006, 06:11:08 am »
yes, I'm using cacko now since the full HD install of obsd failed using the initrd file provided by andy and the two files provided in your post. I want to perform full HD install but after I installed obsd via obsd and rebooted the boot loader could not find /bsd or /obsd and just dropped to shell. I'm going to try again. The only difference is that the hdd1,hdd2,hdd3 partitions are not corrupt but I dont think this is the issue since they are deleted during the install.

Quote
Quote
cacko mounts /dev/mtdblock2 to / according to fstab. I cd /etc/pcmcia and did a 'more config'. I looked over everything that had ide mentioned and everything was already edited? There was nothing in the form ide-cs. I have attached the config file to this post. Let me know if you see anything wrong.

 [ Invalid Attachment ]
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

wait!! you are using cacko? not the full HD install (tiny-rom) and files provided by Andy (iamasmith) in his guide?

if you want to use cacko and OpenBSD better to follow the official install guide here [a href=\"ftp://ftp.openbsd.org/pub/OpenBSD/3.9/zaurus/INSTALL.zaurus]zaurus.INSTALL[/url]

basiclly install the ipk provided to install OpenBSD.

What i have mentioned it in this topic is the installation for FULL HD using small cutom rom been submeted by Andy here https://www.oesf.org/forums/index.php?showtopic=17213
using the file he provides and simple edit i have explain it in this post.

try to go back to iamasmith (Andy) guide and see what you have missed.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=136820\"][{POST_SNAPBACK}][/a][/div]
« Last Edit: August 31, 2006, 05:36:19 pm by mathemajikian »

mathemajikian

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
    • http://exit3.i-55.com/~xikon/openbsdzaurus.html
Sl-c3200 Full Hd “openbsd Hallelujah”
« Reply #17 on: July 29, 2006, 09:07:49 am »
Got it installed!! Thanks for all the help! Works like a champ. I think I messed up the first time by selecting a mount point for partition a and not changing the config files correctly. I dont know. I'm off to build fluxbox! THANKS!!!!!!!!!!!!!!!!!
« Last Edit: August 31, 2006, 05:36:29 pm by mathemajikian »

hus

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
    • http://www.huslab.com
Sl-c3200 Full Hd “openbsd Hallelujah”
« Reply #18 on: July 29, 2006, 09:11:28 am »
Quote
Got it installed!! Thanks for all the help! Works like a champ. I think I messed up the first time by selecting a mount point for partition a and not changing the config files correctly. I dont know. I'm off to build fluxbox! THANKS!!!!!!!!!!!!!!!!!
[div align=\"right\"][a href=\"index.php?act=findpost&pid=136834\"][{POST_SNAPBACK}][/a][/div]

Congrats! and welcome to FREE world :> (Keep it secret don't tell anyone it's free OS)
SL-C3200
GP2X-F100 (MKII)

hus

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
    • http://www.huslab.com
Sl-c3200 Full Hd “openbsd Hallelujah”
« Reply #19 on: July 29, 2006, 09:41:13 am »
Before i forgot! here is some tunning tips and starting xdm at startup, i'll drop them here and if you wonder what they do try to search the forum and google ( the guys who posted them they provide a lot of explanation specially Andy posts here regard fine tunning OpenBSD

***** NOTE: it's just to give an idea it may not reflect to what do u have in your config files, i just collect it from this forum and internet to boot to gui and gain little speed ******

Code: [Select]
vi /etc/sysctl.conf

vm.swapencrypt.enable=0
kern.stackgap_random=0

machdep.kbdreset=1
machdep.apmwarn=5
machdep.maxspeed=520

net.inet.tcp.recvspace=65536
net.inet.tcp.sendspace=65536

starting apmd, xdm and hotplugd
Code: [Select]
vi /etc/rc.conf

apmd_flags=""
hotplugd_flags=""
xdm_flags=""

adding softdep & noatime **depend on ur configuration not exactly the same**

Code: [Select]
vi /etc/fstab

/dev/wd0a / ffs rw,softdep,noatime 1 1
/dev/wd0b none swap sw 0 0

Turnning off ttyC0 and 1 to use xdm

Code: [Select]
vi /etc/ttys

ttyC0 "/usr/libexec/getty Pc" vt220 off secure
ttyC1 "/usr/libexec/getty Pc" vt220 off secure

finally the malloc thing in the console
Code: [Select]
ln -s 'azjgpHR' /etc/malloc.conf
AS I SAID B4 to have an idea you may search for more info
i'm not sure if that will give problems, but for me it looks ok (i only have a suspend problem) and it boots to xdm
SL-C3200
GP2X-F100 (MKII)