Author Topic: Pdaxrom On Sl-5500 For Dummies  (Read 11023 times)

miskinis

  • Sr. Member
  • ****
  • Posts: 334
    • View Profile
    • http://
Pdaxrom On Sl-5500 For Dummies
« Reply #15 on: August 16, 2006, 05:38:46 pm »
Hi,

Just an FYI - The feed.tar.gz located at:

http://mail.pdaxrom.org/download/1.1.0beta...rus-5000D-5500/

Seems to be OK, at least as far as tar is concerned!  Thanks to whoever fixed it!

John
_John Miskinis_

miskinis

  • Sr. Member
  • ****
  • Posts: 334
    • View Profile
    • http://
Pdaxrom On Sl-5500 For Dummies
« Reply #16 on: August 26, 2006, 04:31:36 am »
Hi,

FYI - I was planning on setting up my 5500 again with pdaXrom beta1, now that I
was able to download a complete (uncorrupted) feed.tar.gz.

There is a major bug, where holding down the right arrow or the menu key
will suspend the Z.  I figured I'd mention it, even though I know the 5500 support
is fading...
_John Miskinis_

rogerdugans

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • http://www.rogerdugans.com
Pdaxrom On Sl-5500 For Dummies
« Reply #17 on: August 27, 2006, 10:02:03 am »
Just as a note- I have pdaxrom working mostly on an sl5000.
Using a 1gb cf card and 256mb sd card.

Most things work so far, and its nice to have much more control of the OS than in the other roms I have tried....

But even though I can get networking set up and functioning just fine, including running through a gateway to route packets, I can NOT get packages to install and run.

NO package feed is working for me, even when I have checked the EXACT url on another machine. It connects but then just times out after about 30 seconds.
One of my guesses on this point is the port used is still blocked- anyone know the EXACT port in use by ipkg?

One of the things I tried is to install locally, and this works in PART-
applications say they install, and I get icons.
But they don't work. Not sure why, but my leading guess is space.....

Another guess I am working on is space- trying moving stuff from the onboard to one of my cards.
So far I have screwed up twice by moving stuff...wrong, in some fashion.

So I am still working on it.
« Last Edit: August 27, 2006, 11:24:18 am by rogerdugans »
Linux user: Gentoo is on my gaming rigs, Mepis on my servers.
Overclocking computers is mandatory: running @stock speed is NOT an option.
Watercooling is GOOD.

karlto

  • Sr. Member
  • ****
  • Posts: 343
    • View Profile
    • http://
Pdaxrom On Sl-5500 For Dummies
« Reply #18 on: August 27, 2006, 04:08:01 pm »
Quote
NO package feed is working for me, even when I have checked the EXACT url on another machine. It connects but then just times out after about 30 seconds.
One of my guesses on this point is the port used is still blocked- anyone know the EXACT port in use by ipkg?
If it connects it's very unlikely that the port is blocked. There are some networking issues floating around that cause the connection to hang, particularly as soon as you start saturating it (e.g. downloading). Discussion around here somewhere, not sure if anything was ever resolved. Also issues with 2.6.14 kernel if you have this on your desktop/router machine. Try changing the mtu to a lower value and see if it helps.

Also I see in the other thread that you are having problems with apps being set for landscape mode (I have the same issues on an SL6000). The solution to this is generally a better window manager which forces the correct sizes - not sure if this is a possibility on a 5500...
SL6000-L, RC12

miskinis

  • Sr. Member
  • ****
  • Posts: 334
    • View Profile
    • http://
Pdaxrom On Sl-5500 For Dummies
« Reply #19 on: September 04, 2006, 07:58:52 pm »
Whew, I spent a few hours setting up my 5500 with beta1 today.  I was able to get
WIFI access working, but I had to switch window managers using openbox to
circumvent the "truncate windows to fit screen" behavior of the matchbox WM.
This was preventing me from using the "network configuration" tool namely
network.py, as the wireless options were being truncated.

Below is a crude set of notes I took, and I promise to cleanup the post later, and/or
add more detail for those who may not understand some of the steps, key bindings,
how to use vi (I am a *real* novice but I see emacs is not in the feed).

I was getting a little frustrated, and I bet it shows, but I'll clean up the post later.
Please provide feedback if there is anything you feel should be added or clarified.
It was cronological, so the "mistakes" I made were noted.  It's best to read ahead to
avoid the stumbling and save some frustration.

<BEGIN CRUDE NOTES>

flashing my black 5500 with pdaxrom_1_1_0_beta1

will use 128MB SD for swap space and packages installs
will use 128MB CF flash to hold packages to be installed (.ipk files from feed.tar.gz)

Creating the 32MB swap file on SD (I used my desktop machine as it is faster)

# cd /mnt/card

# dd if=/dev/zero of=swapfile1 bs=1 count=32M
33554432+0 records in
33554432+0 records out

# mkswap swapfile1

login (root no pwd)
passwd (to set a password on the root account)

# swapon /mnt/card/swapfile1 (to enable use of the swap file)

startx (first time run, need to calibrate touchscreen)

matchbox wm appears
8 folders show
only 2 apps available, aterm in Other, dillo2 in Internet
816KB free on /

all installs use "ipkg -d sd install WHATEVER.ipk" to install onto sd card
ignore error about the cacko-unstable feed, and suggestion to run ipkg update
(which of course can't be done without a network)
(later when I install an editor I know well, I will change ipkg.conf so -d sd will be the default)

installed wireless_26
installed dhcpcd

seems there is no wlan string found in filelist

seems lanconfig package has network.py and wireless configuration

something crashing when "cardctl suspend 0" executed with wifi card in
can't scroll back in non-X11 console to see what crashes
system hangs on cardctl eject 0
RESET

installed lanconfig
network.py needs python

installed python

network.py needs gtk module (pygtk)
(from packages file, deps are:)

lanconfig has Depends: pygtk, python-core, python-codecs, python-re, python-dbus, python-fcntl, python-io, python-math, python-stringold, python-xml

geez, copy all the darn python-* packages to the cf card

install python-gtk

DARN, it's called pygtk, unmount cf, eject cf, inject cf into desktop, copy pygtk.ipk to cf, eject cf, inject cf, try again

install pygtk
install python-core
install python-codecs
install python-re
install python-dbus
install python-fcntl
install python-io
install python-math
install python-stringold
install python-xml

DARN, network.py fails trying to open network.cfg

search the filelist
found in matchbox-pdaxrom_1.0.14_armv5tel.ipk package
unmount cf, eject cf, inject cf into desktop, copy matchbox-pdaxrom_1.0.14_armv5tel.ipk to cf, eject cf, inject cf, try again

install matchbox-pdaxrom

YAY, network.py runs, lets try to configure WIFI access

NOPE, DARN, screen is truncated
need to change window manager to one that does not clip X11 windows

install openbox

try to run openbox (realizing that it will complain about another WM running)
just want to see if it runs...  NOPE
checking dependencies in packages file...
it needs libxml and startup-notification

put them on the CF card, (details ommited)

install startup-notification
install libxml

change .xinitrc to use openbox,
copy original .xinitrc to .xinitrc.orig first
note - .xinitrc is a symlink to /usr/bin/matchbox-session

OH NO, NO EMACS! (luckily I know just enough vi to do trivial things)
remember vi does not work correctly under X11, return to console...

OH NO, NO EXIT BUTTON TO CLOSE WM!

use CTRL-ALT-BACKSPACE to quit X11 (calendar contacts and backspace)

use vi to create a new .xinitrc with just openbox RETURN
NOTE cancel button is the ESCAPE key
chmod +x the .xinitrc file

startx

hmm, X11 herringbone pattern...  AH, control with click shows menus
but menus only have a few entries
trying obconf
OK, now xterm is in Applications menu, I don't think it was before!

xterm runs, nice and large and 80 column like on a desktop machine, but of
course need to use ALT and drag stylus to see parts of windows that do not fit

NOTE -
 ALT is that "person" contacts? round button 2nd from left above cancel button
 CONTROL is the "calendar" button round button on left above cancel button

trying network.py, works great now, need to drag it around using ALT and the stylus

remove cf, insert cf WIFI

create a new profile suitable named after my ESSID, specify essid and wep

YES, ping x.org works!

Whew, enough for now, I need to rest!
« Last Edit: September 04, 2006, 08:03:24 pm by miskinis »
_John Miskinis_

_dark_

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://
Pdaxrom On Sl-5500 For Dummies
« Reply #20 on: June 03, 2007, 10:42:57 am »
sorry, cause i dig it from grave, but do you have any progress ?
i need help to set openbox for collie, could you explain this step by step!
my progress :
install openbox
install startup-notification
install libxml

next step how to change window manager from matchbox to openbox?
is this correct?

in root create .xinitrc file
vi /.xinitrc
in .xinitrc create only:
openbox

exit vi

chmod +x .xinitrc file

Thanx
Zauurs CL1000, 2Gb SD Transcend 150x
cacko ROM
Zaurus SL5500, 2Gb SD Transcend 150x, 512CF Lexmark+ 4Gb CF Sandisk Ultra II
kompany rom
WIFI clie PEGA-WL100
D-link DCF-650BT

miskinis

  • Sr. Member
  • ****
  • Posts: 334
    • View Profile
    • http://
Pdaxrom On Sl-5500 For Dummies
« Reply #21 on: June 03, 2007, 08:38:55 pm »
Quote
sorry, cause i dig it from grave, but do you have any progress ?
i need help to set openbox for collie, could you explain this step by step!
my progress :
install openbox
install startup-notification
install libxml

next step how to change window manager from matchbox to openbox?
is this correct?

in root create .xinitrc file
vi /.xinitrc
in .xinitrc create only:
openbox

exit vi

chmod +x .xinitrc file

Thanx
[div align=\"right\"][a href=\"index.php?act=findpost&pid=162474\"][{POST_SNAPBACK}][/a][/div]

Well, I just checked my 5500 (long time since I did) and yes, creating a one
line .xinitrc with just "openbox" in it (may need the newline) works.
I'm not sure why you are putting a "/" before the filename though when you open it in vi.
(Unless of course you have changed the default home dir of root to / instead of /home/root)

Man, it's really a lot of work to setup a decent pdaXrom on a 5500.  In fact I just opened
up vi to look at the .xinitrc, (under X) and I could not get out of it.  If I executed ESC
(cancel button) then :q! I would get a message that file is unsaved and quit! overrides it.
Well, I don't use vi too often, never liked it, but for the life of me I could not figure out
how to exit vi without writing the file (I had inadvertently added characters to the file
due to my lack of vi knowledge as well as the failure of it to update the screen properly
under X)

Anyway, good luck if you pursue this...
_John Miskinis_

telemetric_au

  • Sr. Member
  • ****
  • Posts: 327
    • View Profile
    • http://www.tyrannozaurus.com/feed/contribs/telemetric/index.htm
Pdaxrom On Sl-5500 For Dummies
« Reply #22 on: June 03, 2007, 09:34:13 pm »
you can just "ctrl+z' with , holding far left "calander" button on slide and press z, or x or c ...

it was looking for q! rather than q to exist discarding changes... but i think the function key can get a bit whacky at times and not work to provide the ! ...

https://www.oesf.org/forums/index.php?showtopic=23649
« Last Edit: June 03, 2007, 09:49:01 pm by telemetric_au »
Collie w/ pdaxrom & Puppy OS w/ cross-sdk
Hawking HCF686TX 10/100, Ambicom 802.11b (WL1100C-CF), Xircom 56K Global CF
Kingston CF Elite Pro & SD 1Gb & 128mb for flashing
$2 screen protector, collie.pdaxrom.feed : my collie pdaxrom site

ScottYelich

  • Hero Member
  • *****
  • Posts: 992
    • View Profile
    • http://www.zaurususergroup.com/modules.php?opmodload&namephpWiki&filei
Pdaxrom On Sl-5500 For Dummies
« Reply #23 on: June 10, 2007, 03:48:49 pm »
will this work on a 5600?

Scott

telemetric_au

  • Sr. Member
  • ****
  • Posts: 327
    • View Profile
    • http://www.tyrannozaurus.com/feed/contribs/telemetric/index.htm
Pdaxrom On Sl-5500 For Dummies
« Reply #24 on: June 12, 2007, 04:44:23 am »
unfortuantalely im dont think it currently does...

http://www.pdaxrom.org/?q=downloads#comment-789
Collie w/ pdaxrom & Puppy OS w/ cross-sdk
Hawking HCF686TX 10/100, Ambicom 802.11b (WL1100C-CF), Xircom 56K Global CF
Kingston CF Elite Pro & SD 1Gb & 128mb for flashing
$2 screen protector, collie.pdaxrom.feed : my collie pdaxrom site