Author Topic: Usb And Osx On Oz 3.5.4  (Read 1657 times)

panyo

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
    • http://
Usb And Osx On Oz 3.5.4
« on: March 24, 2006, 03:45:57 am »
I cannot get USB networking or storage  mode to work with my Collie
on Macintoshes. I have flashed OZ 3.4.5 with GPE. I am using a USB to Zarus cable
that has worked for networking with earlier versions. Plugging in to the USB port
on my Mac provides power, but has no othter apparent effect now. Switching between
Ethernet mode and storage mode in the settings pannel makes no difference.
Earlier, before I uninstalled experimental ext2fs support, I was
getting an error about not conforming to a USB standard from dmesg.  
Plugging in to the USB port on a lab Mac produces the following output in
dmesg:
Code: [Select]
USB caused wake event (OHCI)
FireWire (OHCI) Apple ID 52 built-in: handleSelfIDInt
- received quads == 0. issuing bus reset
UniNEnet::monitorLinkStatus - Link is up at 100 Mbps -
Full Duplex
smbfs_smb_qfsattr: (fyi) share 'NTFS', attr 0x700ff,
maxfilename 255
smbfs_smb_qfsattr: (fyi) share 'NTFS', attr 0x700ff,
maxfilename 255
smbfs_aclsflunksniff: smbfs_smb_tmpopen error 13
smbfs_smb_qfsattr: (fyi) share 'NTFS', attr 0x700ff,
maxfilename 255
System Sleep
System Wake
Wake event 0020
USB caused wake event (OHCI)
FireWire (OHCI) Apple ID 52 built-in: handleSelfIDInt
- received quads == 0. issuing bus reset
UniNEnet::monitorLinkStatus - Link is up at 100 Mbps -
Full Duplex
smbfs_smb_qfsattr: (fyi) share 'NTFS', attr 0x700ff,
maxfilename 255
USBF:   38333.733       OHCI driver:
OHCIRootHubResetEnableChange bit not sticking.
Retrying.
SL5500  OZ3.5.2 (Opie), Dvorak built in keyboard
Spectrum24 Ethernet
SanDisk 256 ext2 (AR0401RF China) SD
Lexar 256 VFAT (P/N 2260, Rev. A), Transcend 128 ext2 CF
Pismo, Cube, 8600, Gentoo PowerPC, YellowDog

panyo

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
    • http://
Usb And Osx On Oz 3.5.4
« Reply #1 on: April 23, 2006, 06:48:13 pm »
Here is an update on progress I have made connecting to a Macintosh.
I was able to connect to my SL 5500 by installing the following driver:
http://www.lucid-cake.net/osx_zaurus_usb/index_en.html

However, I am not able to connect from the Zarus back to the mac, let
alone to the internet.

I did succeed in connecting to my gentoo machine following the
Generic USB
how-to on this site.
« Last Edit: April 23, 2006, 06:49:11 pm by panyo »
SL5500  OZ3.5.2 (Opie), Dvorak built in keyboard
Spectrum24 Ethernet
SanDisk 256 ext2 (AR0401RF China) SD
Lexar 256 VFAT (P/N 2260, Rev. A), Transcend 128 ext2 CF
Pismo, Cube, 8600, Gentoo PowerPC, YellowDog

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Usb And Osx On Oz 3.5.4
« Reply #2 on: April 24, 2006, 05:20:19 am »
Quote
However, I am not able to connect from the Zarus back to the mac, let
alone to the internet.

If you can connect from the Mac to the Zaurus, but not the other way, check your firewall settings.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva