Author Topic: X11 crash  (Read 903 times)

tcoulon

  • Newbie
  • *
  • Posts: 40
    • View Profile
    • http://www.decoulon.ch
X11 crash
« on: February 24, 2004, 04:48:21 pm »
Hello,

My Z crashed badly. It started with the icons in the \"panel\" changing to \"!\" when I selected them. I had to reboot the Z by removing the battery - then I found out my SD card was corrupted (this I solved by e2fsck-ing form my main machine).

Now the Z boots with the following message:
/usr/bin/sshd: error while loading shared library: libz.so.1: cannot load shared object file: No file or directory

and I get a prompt, where I can log in.

Startx gives other \"error loading shared libraries\" errors.

I assume file corruption. Is there a way to repair that? Well, there seems to be a new ROM about to be released so that may be a good moment to flash new....

Thierry

LordDavon

  • Full Member
  • ***
  • Posts: 161
    • View Profile
    • http://
X11 crash
« Reply #1 on: February 24, 2004, 05:31:58 pm »
Reflash will correct that.

LD

weili1977

  • Newbie
  • *
  • Posts: 30
    • View Profile
X11 crash
« Reply #2 on: February 24, 2004, 06:59:21 pm »
What SD card are you using? I use a Sandisk one and it kept crashing my 860.
Sharp SL-C860 with Cacko X11 ROM
Netgear MA701 WiFi CF Card
Lexar 256MB SD Card
PNY 256MB CF Card

offroadgeek

  • Administrator
  • Hero Member
  • *****
  • Posts: 1419
    • View Profile
    • https://www.oesf.org
X11 crash
« Reply #3 on: February 24, 2004, 07:07:41 pm »
I also used a SanDisk SD card with my 760 on the x11 rom, and it would become corrupt everytime the battery went <5%.  I also tested and had the same problem with a panasonic SD card.  I wonder if this was fixed in the new rom?
Search the OESF Wiki
C1000 w/Cacko 1.23 beta (from Streamline) / 760 pdaxrom rc9 / 6000L (thanks Santa's elf!) / 5500 - OZ 3.3.5 / SIMpad SL4
1GB, 256mb SanDisk CF / 2x 1GB, 512mb, 256mb, 128mb SanDisk SD
Ambicom WL100C-CF wifi / Socket 56k CF modem / AmbiCom BT2000-CF (x2)
Pocketop keyboard, Piel Frama case (1000 & 5500), PDAir case (760 & 1000)
sip:536093@fwd.pulver.com
| OESF | ELSI | Zaurus User Group | ZaurusThemes |

tcoulon

  • Newbie
  • *
  • Posts: 40
    • View Profile
    • http://www.decoulon.ch
X11 crash
« Reply #4 on: February 24, 2004, 07:14:05 pm »
Yep, it\'s a Sandisk. The problem is that I need the CF slot for my network card -and the problem seems to extend beyond the sd card as I keep having problems even after I\'ve fsck-ed it.
I don\'t seem to find a way to check the main part of the system - seems to be jffs2.
Reflashing will probably be the solution.