Author Topic: Beta 4 Still Doesn't Flash, C3000 Unsuported  (Read 1484 times)

realm

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
    • http://
Beta 4 Still Doesn't Flash, C3000 Unsuported
« on: September 14, 2006, 11:59:26 am »
This was on a C3000, which explains why it didn't work

I followed the instructions
Quote
First installation - new bootloader, for SL-C1000/C3100/C3200

1) Good idea make NAND backup before

2) Download this archive:
pdaXrom-1.1.0beta4-Kathrin-u-boot-akita-current.zip
Download new u-boot: u-boot.bin.bz2 (ADDED)
3) Format CF or SD card (MMC unworking for me) with FAT16
4) Extract files to card. Remove old u-boot extracted from zip archive. Unbzip2 new u-boot and copy to card. There must be updater.pro, u-boot.bin, emergenc.img
5) Download pdaXrom system:
pdaXrom-1.1.0beta4-Kathrin-akita-current.zip
6) Extract files to this or another CF or SD card, there must be: rootfs.img kernel.img autoboot.sh
7) Run diagnostic menu (D+M) and run NAND Flash Erase from Extra Menu. (ADDED)
8) Turn OFF your zaurus. Unplug power adapter, eject battery.
9) Insert SD or CF card with extarcted files (if you insert both CF and SD, updating fails)
10) Press and hold "C" and "D" keys and plug power adapter (battery must be ejected!).
11) Green LED must light on for ~20 sec.
12) If both LEDs flashing, that mean bad CF or SD, or non FAT16.
13) When Green LED off, unplug power adaptor.

Bootup emergency system
1) Insert SD or CF card with pdaXrom
2) Press and hold ON button and plug power cable
3) Wait for 10 sec and leave ON button
4) Screen on and emergency system will booting
5) After booting, it will detect SD or CF card and run autoboot.sh script
7) After flashing, it will reboot and pdaXrom will booting - time for battery insert:)

These steps when as they should
Quote
First installation - new bootloader, for SL-C1000/C3100/C3200

1) Good idea make NAND backup before

2) Download this archive:
pdaXrom-1.1.0beta4-Kathrin-u-boot-akita-current.zip
Download new u-boot: u-boot.bin.bz2 (ADDED)
3) Format CF or SD card (MMC unworking for me) with FAT16
4) Extract files to card. Remove old u-boot extracted from zip archive. Unbzip2 new u-boot and copy to card. There must be updater.pro, u-boot.bin, emergenc.img
5) Download pdaXrom system:
pdaXrom-1.1.0beta4-Kathrin-akita-current.zip
6) Extract files to this or another CF or SD card, there must be: rootfs.img kernel.img autoboot.sh
7) Run diagnostic menu (D+M) and run NAND Flash Erase from Extra Menu. (ADDED)
8) Turn OFF your zaurus. Unplug power adapter, eject battery.
9) Insert SD or CF card with extarcted files (if you insert both CF and SD, updating fails)
10) Press and hold "C" and "D" keys and plug power adapter (battery must be ejected!).
11) Green LED must light on for ~20 sec.
12) If both LEDs flashing, that mean bad CF or SD, or non FAT16.
13) When Green LED off, unplug power adaptor.

But then when i hold the on/off button, plug the power in and wait for 10 sec, then let go nothing happens. I've been looking forward to be able to start testing beta4 wih the 2.6 kernel instead of using beta1, but i've done this procedure 5+ times over the last month and it doesn't work. is there some undocumented procedure that needs done between here to make the flash of the os work?

I've tried all the files on the same cf card, sd card, different sd/cf cards, only required files, and both bootloader and os files on the same card. nothing works.

Any assistance to get a 2.6 kernel, and the new release of pdaxrom would be appriciated.

For more clarification on the flashing of uboot. Both green and orange light are on for about 20 sec then they turn off, as the instructions said they should, and i formatted my sd card with mkfs.msdos -F 16 /dev/sda1 (usb sd adapter)

I also used the folowing updated beta4, in hopes that would help, it didn't.
Quote
pdaXrom 1.1.0beta 4 - bugfixes and feed
Submitted by Sash on Wed, 2006-05-17 05:01. SL-C1000/C3100 | Zaurus native

Download:
http://mail.pdaxrom.org/download/1.1.0beta...ita-current.zip

Feed: here

Extract files (rootfs.img kernel.img autoboot.sh) to card and reboot your Z with emergency system.

News:
Added - Sound initial preferences
« Last Edit: September 24, 2006, 05:51:34 pm by realm »
SL-C860   r197
SL-C3000 Angstrom with e17 /1 Gig SD/Senao Wifi/CF Bluetooth/CF GPS

Darth_Sith

  • Full Member
  • ***
  • Posts: 128
    • View Profile
Beta 4 Still Doesn't Flash, C3000 Unsuported
« Reply #1 on: September 14, 2006, 12:20:34 pm »
I have your same problem...
I've tried many times with many sd and cf...
Nothing.
Bootloader doesn't want to install (but the procedure delete the old)...

SL-C1000 + cacko 1.23F + sd4GB + CFBT + CFWiFi
HTC Polaris

willgan

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • http://
Beta 4 Still Doesn't Flash, C3000 Unsuported
« Reply #2 on: September 15, 2006, 06:47:15 am »
i got the same problem last time..  when i try to go to emergency boot.. using the beta 4...
Now i use my own compiled version... i hold the 'OK' button when i boot to go into emergency boot..
My Current Z...

Zaurus C1000 - Pdaxii13
Using Pdaxrom-builder (SVN) for building packages

realm

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
    • http://
Beta 4 Still Doesn't Flash, C3000 Unsuported
« Reply #3 on: September 15, 2006, 11:53:54 am »
Think you could post yours here?


Quote
i got the same problem last time..  when i try to go to emergency boot.. using the beta 4...
Now i use my own compiled version... i hold the 'OK' button when i boot to go into emergency boot..
[div align=\"right\"][a href=\"index.php?act=findpost&pid=141471\"][{POST_SNAPBACK}][/a][/div]
SL-C860   r197
SL-C3000 Angstrom with e17 /1 Gig SD/Senao Wifi/CF Bluetooth/CF GPS