Author Topic: Zbackup For Pdaxii13  (Read 6836 times)

VirtusRex

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Zbackup For Pdaxii13
« Reply #15 on: March 08, 2007, 06:35:53 am »
Quote
try this one
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155734\"][{POST_SNAPBACK}][/a][/div]

Ok, tried your new zbackup package, but now I'm getting the previous error msg:

your model SL-C1000 is not supported with zbackup.

VirtusRex

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Zbackup For Pdaxii13
« Reply #16 on: March 08, 2007, 06:38:26 am »
Quote
Quote
try this one
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155734\"][{POST_SNAPBACK}][/a][/div]

Ok, tried your new zbackup package, but now I'm getting the previous error msg:

your model SL-C1000 is not supported with zbackup.

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155750\"][{POST_SNAPBACK}][/a][/div]

i presume you restored a NAND backup and forgot to delete zbackup before installing the package...
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

VirtusRex

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Zbackup For Pdaxii13
« Reply #17 on: March 08, 2007, 07:46:39 am »
Quote
Quote
Quote
try this one
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155734\"][{POST_SNAPBACK}][/a][/div]

Ok, tried your new zbackup package, but now I'm getting the previous error msg:

your model SL-C1000 is not supported with zbackup.

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155750\"][{POST_SNAPBACK}][/a][/div]

i presume you restored a NAND backup and forgot to delete zbackup before installing the package...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155751\"][{POST_SNAPBACK}][/a][/div]

Hey Meanie,

Had a bit of a problem. I used an old Nand backup I had, but it's corrupt. Anyway, I reinstalled pdxaii13 and ran zbackup again. This time when I used zbackup it ran fine. Also, the backup initrd.bin installed with no problems.

So far it looks good. I'm going to install some apps on my sd-card and see how zbackup handles that.

Thanks,

VirtusRex

VirtusRex

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Zbackup For Pdaxii13
« Reply #18 on: March 08, 2007, 10:54:45 am »
Quote
Quote
Quote
Quote
try this one
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155734\"][{POST_SNAPBACK}][/a][/div]

Ok, tried your new zbackup package, but now I'm getting the previous error msg:

your model SL-C1000 is not supported with zbackup.

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155750\"][{POST_SNAPBACK}][/a][/div]

i presume you restored a NAND backup and forgot to delete zbackup before installing the package...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155751\"][{POST_SNAPBACK}][/a][/div]

Hey Meanie,

Had a bit of a problem. I used an old Nand backup I had, but it's corrupt. Anyway, I reinstalled pdxaii13 and ran zbackup again. This time when I used zbackup it ran fine. Also, the backup initrd.bin installed with no problems.

So far it looks good. I'm going to install some apps on my sd-card and see how zbackup handles that.

Thanks,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155752\"][{POST_SNAPBACK}][/a][/div]

Ok, I tried another test but this time I install some stuff. First off I re-image to pdaxii13 for akita, then I install rox file manager. I ran zbackup and created an initrd.bin on my /mnt/card. Using the backed up initrd.bin file, I reinstall my backup os. The install went fine, but there was no rox file manager, which I installed on /mnt/user.

Is it possible that zbackup is not picking up the /mnt/user directory?

VirtusRex

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Zbackup For Pdaxii13
« Reply #19 on: March 08, 2007, 11:05:10 am »
Quote
Quote
Quote
Quote
Quote
try this one
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155734\"][{POST_SNAPBACK}][/a][/div]

Ok, tried your new zbackup package, but now I'm getting the previous error msg:

your model SL-C1000 is not supported with zbackup.

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155750\"][{POST_SNAPBACK}][/a][/div]

i presume you restored a NAND backup and forgot to delete zbackup before installing the package...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155751\"][{POST_SNAPBACK}][/a][/div]

Hey Meanie,

Had a bit of a problem. I used an old Nand backup I had, but it's corrupt. Anyway, I reinstalled pdxaii13 and ran zbackup again. This time when I used zbackup it ran fine. Also, the backup initrd.bin installed with no problems.

So far it looks good. I'm going to install some apps on my sd-card and see how zbackup handles that.

Thanks,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155752\"][{POST_SNAPBACK}][/a][/div]

Ok, I tried another test but this time I install some stuff. First off I re-image to pdaxii13 for akita, then I install rox file manager. I ran zbackup and created an initrd.bin on my /mnt/card. Using the backed up initrd.bin file, I reinstall my backup os. The install went fine, but there was no rox file manager, which I installed on /mnt/user.

Is it possible that zbackup is not picking up the /mnt/user directory?

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155767\"][{POST_SNAPBACK}][/a][/div]

anything under /mnt is ignored, only /bin /home /root /etc/lib /sbin /usr are backed up... but this can be easily fixed... what other directory needs to be backed up?
« Last Edit: March 08, 2007, 11:08:23 am by Meanie »
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Zbackup For Pdaxii13
« Reply #20 on: March 08, 2007, 11:30:48 am »
here's another updated zbackup which backs up /mnt/user as well
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

VirtusRex

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Zbackup For Pdaxii13
« Reply #21 on: March 08, 2007, 01:09:08 pm »
Quote
Quote
Quote
Quote
Quote
Quote
try this one
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155734\"][{POST_SNAPBACK}][/a][/div]

Ok, tried your new zbackup package, but now I'm getting the previous error msg:

your model SL-C1000 is not supported with zbackup.

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155750\"][{POST_SNAPBACK}][/a][/div]

i presume you restored a NAND backup and forgot to delete zbackup before installing the package...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155751\"][{POST_SNAPBACK}][/a][/div]

Hey Meanie,

Had a bit of a problem. I used an old Nand backup I had, but it's corrupt. Anyway, I reinstalled pdxaii13 and ran zbackup again. This time when I used zbackup it ran fine. Also, the backup initrd.bin installed with no problems.

So far it looks good. I'm going to install some apps on my sd-card and see how zbackup handles that.

Thanks,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155752\"][{POST_SNAPBACK}][/a][/div]

Ok, I tried another test but this time I install some stuff. First off I re-image to pdaxii13 for akita, then I install rox file manager. I ran zbackup and created an initrd.bin on my /mnt/card. Using the backed up initrd.bin file, I reinstall my backup os. The install went fine, but there was no rox file manager, which I installed on /mnt/user.

Is it possible that zbackup is not picking up the /mnt/user directory?

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155767\"][{POST_SNAPBACK}][/a][/div]

anything under /mnt is ignored, only /bin /home /root /etc/lib /sbin /usr are backed up... but this can be easily fixed... what other directory needs to be backed up?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155768\"][{POST_SNAPBACK}][/a][/div]


I was thinking, maybe you could add a feature to your zbackup program that would allow you to select custom directories to back as well.

For example, I usually setup my zaurus as follow.

Install primary applications (Gaim, Kismet, Mozilla, etc) on /mnt/user directory, then big stuff like firefox, gpsdrive, etc I usually install on my 2 gb sd-card under /mnt/card2.

Maybe you could add a command to zbackup like the following:

zbackup /mnt/usr, /mnt/card2

This would allow the option to add extra directories.

plcg

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
    • http://
Zbackup For Pdaxii13
« Reply #22 on: March 09, 2007, 01:11:17 am »
Hi Meanie,

Is there any chance you make a C7x0/C8x0 version of zbackup ?
My C760 seems to have a NAND failure so I can't do a NAND restore anymore  

Thanks
plcg
C760 & Pdaxrom 1.1.0beta1 / Transcend 512 MB CF
C1000 & Cacko 1.23 full / PQI 1 GB SD/ Hitachi 2GB microdrive
Linksys WCF12 CF WiFi Card

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Zbackup For Pdaxii13
« Reply #23 on: March 09, 2007, 06:44:11 am »
Quote
Quote
Quote
Quote
Quote
Quote
Quote
try this one
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155734\"][{POST_SNAPBACK}][/a][/div]

Ok, tried your new zbackup package, but now I'm getting the previous error msg:

your model SL-C1000 is not supported with zbackup.

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155750\"][{POST_SNAPBACK}][/a][/div]

i presume you restored a NAND backup and forgot to delete zbackup before installing the package...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155751\"][{POST_SNAPBACK}][/a][/div]

Hey Meanie,

Had a bit of a problem. I used an old Nand backup I had, but it's corrupt. Anyway, I reinstalled pdxaii13 and ran zbackup again. This time when I used zbackup it ran fine. Also, the backup initrd.bin installed with no problems.

So far it looks good. I'm going to install some apps on my sd-card and see how zbackup handles that.

Thanks,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155752\"][{POST_SNAPBACK}][/a][/div]

Ok, I tried another test but this time I install some stuff. First off I re-image to pdaxii13 for akita, then I install rox file manager. I ran zbackup and created an initrd.bin on my /mnt/card. Using the backed up initrd.bin file, I reinstall my backup os. The install went fine, but there was no rox file manager, which I installed on /mnt/user.

Is it possible that zbackup is not picking up the /mnt/user directory?

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155767\"][{POST_SNAPBACK}][/a][/div]

anything under /mnt is ignored, only /bin /home /root /etc/lib /sbin /usr are backed up... but this can be easily fixed... what other directory needs to be backed up?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155768\"][{POST_SNAPBACK}][/a][/div]


I was thinking, maybe you could add a feature to your zbackup program that would allow you to select custom directories to back as well.

For example, I usually setup my zaurus as follow.

Install primary applications (Gaim, Kismet, Mozilla, etc) on /mnt/user directory, then big stuff like firefox, gpsdrive, etc I usually install on my 2 gb sd-card under /mnt/card2.

Maybe you could add a command to zbackup like the following:

zbackup /mnt/usr, /mnt/card2

This would allow the option to add extra directories.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155777\"][{POST_SNAPBACK}][/a][/div]

no, what you are asking for is a fully fledged backup applicaton. zbackup is not such an app. its simply a system snapshot tool which allows you to restore the snapshotted system. if you add the contents of the sd card to the image, how are you going to reflash your z? it wont all fit on your nand...

a separate backup tool is required for backing up your data and apps that are on exstra storage like, sf, cf, internal md, etc..  such a tool has not been foud yet, neither in pdaXii13 nor pdaXrom...
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Zbackup For Pdaxii13
« Reply #24 on: March 09, 2007, 06:48:34 am »
Quote
Hi Meanie,

Is there any chance you make a C7x0/C8x0 version of zbackup ?
My C760 seems to have a NAND failure so I can't do a NAND restore anymore  

Thanks
plcg
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155810\"][{POST_SNAPBACK}][/a][/div]

you can always try the new zbackup on the c760 to generate a initrd.bin file but make sure you can make a nand backup and restore before doing that. maybe ask someone else to try it. it should work in theory but needs testing and since i dont have those models, i cannot do it. the generated initrd.bin, once tested and working, can then be used a pdaXii13 flash image for other owners of such devices... c7x0/c8x0 owners can make their own custom pdaXii13 install images...
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

VirtusRex

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Zbackup For Pdaxii13
« Reply #25 on: March 09, 2007, 10:47:39 am »
Ok, this time I install Gaim and Rox onto /mnt/user directory. Using zbackup_0.14_armv5tel.ipk, I created a backup intird.bin file. I then proceed to reinstall the os with the backup initrd.bin.

Results are buggy. Install went fine with no errors, but when X started up it defaulted back to matchbox. Plus, there was no sign of rox or gaim in the /mnt/user directory.
My /dev/root or / is almost completely used up. It had something like 4 megs free before applying the back, now it has just over a 1 meg free.

Just in case I’ll list the steps I take when running a back, that way we can remove any possibilities of user.

Backup Procedure

Step 1. Installing pdaxii13
1.   Use pdaxii13  initrd.bin tools.tar updater.sh - to the root of your SD/MMC card.
2.   Make sure the Zaurus isn't plugged into AC power.
3.   Remove battery for at least 5 seconds.
4.   Replace battery (replace battery cover, lock cover), plug in AC power.
5.   Press and hold the "OK" button on the keyboard.
6.   Turn the power on, you should see the Japanese service menu.
7.   Select option 4 (flash/update).
8.   You then have four options (1. USB, 2. CF, 3. SD, 4. Back)
9.   Choose either option 2 or 3, depending on which media you put the files on.
10.   After a while a menu pops up, select "3 NAND Flash utils" -> "1 Resize root partition", enter 50 - 50 MB for root partition on SL-C760/C860/C1000/C3100 or 30 for SL-C700/750.
11.   After a while it is repartioned and will reboot, after that complete steps 2-10 again and wait for the menu again.
12.   Now select "1 Install new ROM" and wait.
13.   Press Yes for question about format user partition and wait when it will reboot
14.   At login type "root" - without the quotes - then hit enter
15.   Type "startx" - without quotes - then hit enter
16.   Wait while the gui starts up
Step 2. Backup pdaxii13

1.   Install Gaim and rox onto /mnt/user directory.
2.   Install zbackup_0.14_armv5tel.ipk onto /.
3.   Exit to command prompt, run zbackup.
4.   Using backup initrd.bin, repeat Step 1. Installing pdaxii13


That’s basically what I’ve been doing.

Hope this helps,

VirtusRex

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Zbackup For Pdaxii13
« Reply #26 on: March 10, 2007, 05:40:39 am »
Quote
Ok, this time I install Gaim and Rox onto /mnt/user directory. Using zbackup_0.14_armv5tel.ipk, I created a backup intird.bin file. I then proceed to reinstall the os with the backup initrd.bin.

Results are buggy. Install went fine with no errors, but when X started up it defaulted back to matchbox. Plus, there was no sign of rox or gaim in the /mnt/user directory.
My /dev/root or / is almost completely used up. It had something like 4 megs free before applying the back, now it has just over a 1 meg free.

Just in case I’ll list the steps I take when running a back, that way we can remove any possibilities of user.

Backup Procedure

Step 1. Installing pdaxii13
1.   Use pdaxii13  initrd.bin tools.tar updater.sh - to the root of your SD/MMC card.
2.   Make sure the Zaurus isn't plugged into AC power.
3.   Remove battery for at least 5 seconds.
4.   Replace battery (replace battery cover, lock cover), plug in AC power.
5.   Press and hold the "OK" button on the keyboard.
6.   Turn the power on, you should see the Japanese service menu.
7.   Select option 4 (flash/update).
8.   You then have four options (1. USB, 2. CF, 3. SD, 4. Back)
9.   Choose either option 2 or 3, depending on which media you put the files on.
10.   After a while a menu pops up, select "3 NAND Flash utils" -> "1 Resize root partition", enter 50 - 50 MB for root partition on SL-C760/C860/C1000/C3100 or 30 for SL-C700/750.
11.   After a while it is repartioned and will reboot, after that complete steps 2-10 again and wait for the menu again.
12.   Now select "1 Install new ROM" and wait.
13.   Press Yes for question about format user partition and wait when it will reboot
14.   At login type "root" - without the quotes - then hit enter
15.   Type "startx" - without quotes - then hit enter
16.   Wait while the gui starts up
Step 2. Backup pdaxii13

1.   Install Gaim and rox onto /mnt/user directory.
2.   Install zbackup_0.14_armv5tel.ipk onto /.
3.   Exit to command prompt, run zbackup.
4.   Using backup initrd.bin, repeat Step 1. Installing pdaxii13


That’s basically what I’ve been doing.

Hope this helps,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155844\"][{POST_SNAPBACK}][/a][/div]

what does

Code: [Select]
df -hand
Code: [Select]
mountshow?

where does /mnt/user actually point to?
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

VirtusRex

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Zbackup For Pdaxii13
« Reply #27 on: March 10, 2007, 11:36:03 am »
Quote
Quote
Ok, this time I install Gaim and Rox onto /mnt/user directory. Using zbackup_0.14_armv5tel.ipk, I created a backup intird.bin file. I then proceed to reinstall the os with the backup initrd.bin.

Results are buggy. Install went fine with no errors, but when X started up it defaulted back to matchbox. Plus, there was no sign of rox or gaim in the /mnt/user directory.
My /dev/root or / is almost completely used up. It had something like 4 megs free before applying the back, now it has just over a 1 meg free.

Just in case I’ll list the steps I take when running a back, that way we can remove any possibilities of user.

Backup Procedure

Step 1. Installing pdaxii13
1.   Use pdaxii13  initrd.bin tools.tar updater.sh - to the root of your SD/MMC card.
2.   Make sure the Zaurus isn't plugged into AC power.
3.   Remove battery for at least 5 seconds.
4.   Replace battery (replace battery cover, lock cover), plug in AC power.
5.   Press and hold the "OK" button on the keyboard.
6.   Turn the power on, you should see the Japanese service menu.
7.   Select option 4 (flash/update).
8.   You then have four options (1. USB, 2. CF, 3. SD, 4. Back)
9.   Choose either option 2 or 3, depending on which media you put the files on.
10.   After a while a menu pops up, select "3 NAND Flash utils" -> "1 Resize root partition", enter 50 - 50 MB for root partition on SL-C760/C860/C1000/C3100 or 30 for SL-C700/750.
11.   After a while it is repartioned and will reboot, after that complete steps 2-10 again and wait for the menu again.
12.   Now select "1 Install new ROM" and wait.
13.   Press Yes for question about format user partition and wait when it will reboot
14.   At login type "root" - without the quotes - then hit enter
15.   Type "startx" - without quotes - then hit enter
16.   Wait while the gui starts up
Step 2. Backup pdaxii13

1.   Install Gaim and rox onto /mnt/user directory.
2.   Install zbackup_0.14_armv5tel.ipk onto /.
3.   Exit to command prompt, run zbackup.
4.   Using backup initrd.bin, repeat Step 1. Installing pdaxii13


That’s basically what I’ve been doing.

Hope this helps,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155844\"][{POST_SNAPBACK}][/a][/div]

what does

Code: [Select]
df -hand
Code: [Select]
mountshow?

where does /mnt/user actually point to?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155888\"][{POST_SNAPBACK}][/a][/div]

here you go.

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Zbackup For Pdaxii13
« Reply #28 on: March 10, 2007, 05:57:16 pm »
Quote
Quote
Quote
Ok, this time I install Gaim and Rox onto /mnt/user directory. Using zbackup_0.14_armv5tel.ipk, I created a backup intird.bin file. I then proceed to reinstall the os with the backup initrd.bin.

Results are buggy. Install went fine with no errors, but when X started up it defaulted back to matchbox. Plus, there was no sign of rox or gaim in the /mnt/user directory.
My /dev/root or / is almost completely used up. It had something like 4 megs free before applying the back, now it has just over a 1 meg free.

Just in case I’ll list the steps I take when running a back, that way we can remove any possibilities of user.

Backup Procedure

Step 1. Installing pdaxii13
1.   Use pdaxii13  initrd.bin tools.tar updater.sh - to the root of your SD/MMC card.
2.   Make sure the Zaurus isn't plugged into AC power.
3.   Remove battery for at least 5 seconds.
4.   Replace battery (replace battery cover, lock cover), plug in AC power.
5.   Press and hold the "OK" button on the keyboard.
6.   Turn the power on, you should see the Japanese service menu.
7.   Select option 4 (flash/update).
8.   You then have four options (1. USB, 2. CF, 3. SD, 4. Back)
9.   Choose either option 2 or 3, depending on which media you put the files on.
10.   After a while a menu pops up, select "3 NAND Flash utils" -> "1 Resize root partition", enter 50 - 50 MB for root partition on SL-C760/C860/C1000/C3100 or 30 for SL-C700/750.
11.   After a while it is repartioned and will reboot, after that complete steps 2-10 again and wait for the menu again.
12.   Now select "1 Install new ROM" and wait.
13.   Press Yes for question about format user partition and wait when it will reboot
14.   At login type "root" - without the quotes - then hit enter
15.   Type "startx" - without quotes - then hit enter
16.   Wait while the gui starts up
Step 2. Backup pdaxii13

1.   Install Gaim and rox onto /mnt/user directory.
2.   Install zbackup_0.14_armv5tel.ipk onto /.
3.   Exit to command prompt, run zbackup.
4.   Using backup initrd.bin, repeat Step 1. Installing pdaxii13


That’s basically what I’ve been doing.

Hope this helps,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155844\"][{POST_SNAPBACK}][/a][/div]

what does

Code: [Select]
df -hand
Code: [Select]
mountshow?

where does /mnt/user actually point to?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155888\"][{POST_SNAPBACK}][/a][/div]

here you go.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155902\"][{POST_SNAPBACK}][/a][/div]

ok, i understand now.

the caveat is that the flash process extracts the contens of / (root partition) and formats /home which is /mnt/user partition.

so if you flash akita with root and home, ie two partitions, then only root is restored and /home is wiped out. therefore zbackup only works properly if you resize root to 128mb

also, use zbackup 0.13
« Last Edit: March 10, 2007, 06:01:37 pm by Meanie »
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

VirtusRex

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Zbackup For Pdaxii13
« Reply #29 on: March 11, 2007, 10:07:28 pm »
Quote
Quote
Quote
Quote
Ok, this time I install Gaim and Rox onto /mnt/user directory. Using zbackup_0.14_armv5tel.ipk, I created a backup intird.bin file. I then proceed to reinstall the os with the backup initrd.bin.

Results are buggy. Install went fine with no errors, but when X started up it defaulted back to matchbox. Plus, there was no sign of rox or gaim in the /mnt/user directory.
My /dev/root or / is almost completely used up. It had something like 4 megs free before applying the back, now it has just over a 1 meg free.

Just in case I’ll list the steps I take when running a back, that way we can remove any possibilities of user.

Backup Procedure

Step 1. Installing pdaxii13
1.   Use pdaxii13  initrd.bin tools.tar updater.sh - to the root of your SD/MMC card.
2.   Make sure the Zaurus isn't plugged into AC power.
3.   Remove battery for at least 5 seconds.
4.   Replace battery (replace battery cover, lock cover), plug in AC power.
5.   Press and hold the "OK" button on the keyboard.
6.   Turn the power on, you should see the Japanese service menu.
7.   Select option 4 (flash/update).
8.   You then have four options (1. USB, 2. CF, 3. SD, 4. Back)
9.   Choose either option 2 or 3, depending on which media you put the files on.
10.   After a while a menu pops up, select "3 NAND Flash utils" -> "1 Resize root partition", enter 50 - 50 MB for root partition on SL-C760/C860/C1000/C3100 or 30 for SL-C700/750.
11.   After a while it is repartioned and will reboot, after that complete steps 2-10 again and wait for the menu again.
12.   Now select "1 Install new ROM" and wait.
13.   Press Yes for question about format user partition and wait when it will reboot
14.   At login type "root" - without the quotes - then hit enter
15.   Type "startx" - without quotes - then hit enter
16.   Wait while the gui starts up
Step 2. Backup pdaxii13

1.   Install Gaim and rox onto /mnt/user directory.
2.   Install zbackup_0.14_armv5tel.ipk onto /.
3.   Exit to command prompt, run zbackup.
4.   Using backup initrd.bin, repeat Step 1. Installing pdaxii13


That’s basically what I’ve been doing.

Hope this helps,

VirtusRex
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155844\"][{POST_SNAPBACK}][/a][/div]

what does

Code: [Select]
df -hand
Code: [Select]
mountshow?

where does /mnt/user actually point to?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155888\"][{POST_SNAPBACK}][/a][/div]

here you go.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155902\"][{POST_SNAPBACK}][/a][/div]

ok, i understand now.

the caveat is that the flash process extracts the contens of / (root partition) and formats /home which is /mnt/user partition.

so if you flash akita with root and home, ie two partitions, then only root is restored and /home is wiped out. therefore zbackup only works properly if you resize root to 128mb

also, use zbackup 0.13
[div align=\"right\"][a href=\"index.php?act=findpost&pid=155928\"][{POST_SNAPBACK}][/a][/div]


Ok, I used zbackup 0.13 and create an initrd.bin back, then I did the following:

Backup Procedure Using zbackup 0.13

Step 1. Installing pdaxii13
1. Use backup initrd.bin, tools.tar, and updater.sh - to the root of your SD/MMC card.
2. Make sure the Zaurus isn't plugged into AC power.
3. Remove battery for at least 5 seconds.
4. Replace battery (replace battery cover, lock cover), plug in AC power.
5. Press and hold the "OK" button on the keyboard.
6. Turn the power on, you should see the Japanese service menu.
7. Select option 4 (flash/update).
8. You then have four options (1. USB, 2. CF, 3. SD, 4. Back)
9. Choose either option 2 or 3, depending on which media you put the files on.
10. After a while a menu pops up, select "3 NAND Flash utils" -> "1 Resize root partition", enter  121 which is the max amount (I assume this is what you mean when you said to resize root to 128mb)
11. After a while it is repartioned and will reboot, after that complete steps 2-10 again and wait for the menu again.
12. Now select "1 Install new ROM" and wait.
13. Press Yes for question about format user partition and wait when it will reboot

Everything installed ok, but I got the following error which prevented me from accessing root login.
bin/sh: error while loading shared libraries : libncurses.so.5: cannot open shared object file: No such file or directory.

VirtusRex