Author Topic: Old Kopi Wakeup Pbm Back?  (Read 2470 times)

CktRider

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« on: March 27, 2007, 02:17:46 am »
Last time kopi failed to wake the Z before an alarm, the modified apmsleep binary fixed the problem.  I'm trying pdaxii13 now, and my Z again doesn't wake.  I put in the fixed apmsleep binary with no success.  I tried apmsleep from the command line, but I was informed summarily that my kernel doesn't support rtc and I need to recompile.  I hope that's not the case!  I've searched the threads, but don't find anything else past Jan '06.  Is there a pdaXii13-specific fix, or am I just missing something?  TIA.

daniel3000

  • Hero Member
  • *****
  • Posts: 1003
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #1 on: March 27, 2007, 07:55:48 am »
Quote
Last time kopi failed to wake the Z before an alarm, the modified apmsleep binary fixed the problem.  I'm trying pdaxii13 now, and my Z again doesn't wake.  I put in the fixed apmsleep binary with no success.  I tried apmsleep from the command line, but I was informed summarily that my kernel doesn't support rtc and I need to recompile.  I hope that's not the case!  I've searched the threads, but don't find anything else past Jan '06.  Is there a pdaXii13-specific fix, or am I just missing something?  TIA.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157268\"][{POST_SNAPBACK}][/a][/div]

please make sure that atd is running.

daniel
SL-C3200 with weeXpc, based on pdaXrom 1.1.0beta3
HP 200LX with MS-DOS 5.0

CktRider

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #2 on: March 27, 2007, 10:42:46 am »
Quote
please make sure that atd is running.

daniel
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157275\"][{POST_SNAPBACK}][/a][/div]

Yes, atd has been running, per ps.  I restarted it and still have the problem.

I have a C1000 running the latest apm package, and I've eliminated the clock problems per other threads.  I'm using your controllable clock, Daniel--thank you for that good work, as well as all the work for many years among the HPLX community.

daniel3000

  • Hero Member
  • *****
  • Posts: 1003
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #3 on: March 27, 2007, 05:19:04 pm »
Quote
Quote
please make sure that atd is running.

daniel
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157275\"][{POST_SNAPBACK}][/a][/div]

Yes, atd has been running, per ps.  I restarted it and still have the problem.

I have a C1000 running the latest apm package, and I've eliminated the clock problems per other threads.  I'm using your controllable clock, Daniel--thank you for that good work, as well as all the work for many years among the HPLX community.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157290\"][{POST_SNAPBACK}][/a][/div]

so do I know you from the HPLX community?  

This forum is quite different, as here people don't usually post using their real names. That helped to make the HPLX mailing list such a familiar and cordial place, knowing some more about the people you talked to.

Well, if atd is running, you may follow the single steps of the kopi-apm init script and try to find out if one of the steps is broken...
THe script is in /etc/apm/scripts.d and must be linked into the suspend directory, so it is really executed on suspend. It does some calculations, using KO/PI's "next alarm" file and makes sure a resume is triggered shortly before the alarm comes up.
(I tell this all from memory, I don't have the exact script and file names handy now).

Somewhere in that chain may be an error.
Maybe only a missing link to the script?

daniel
« Last Edit: March 27, 2007, 05:20:48 pm by daniel3000 »
SL-C3200 with weeXpc, based on pdaXrom 1.1.0beta3
HP 200LX with MS-DOS 5.0

CktRider

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #4 on: March 27, 2007, 09:04:45 pm »
Quote
Quote
Quote
please make sure that atd is running.

daniel
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157275\"][{POST_SNAPBACK}][/a][/div]

Yes, atd has been running, per ps.  I restarted it and still have the problem.

I have a C1000 running the latest apm package, and I've eliminated the clock problems per other threads.  I'm using your controllable clock, Daniel--thank you for that good work, as well as all the work for many years among the HPLX community.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157290\"][{POST_SNAPBACK}][/a][/div]

so do I know you from the HPLX community?  

This forum is quite different, as here people don't usually post using their real names. That helped to make the HPLX mailing list such a familiar and cordial place, knowing some more about the people you talked to.

Well, if atd is running, you may follow the single steps of the kopi-apm init script and try to find out if one of the steps is broken...
THe script is in /etc/apm/scripts.d and must be linked into the suspend directory, so it is really executed on suspend. It does some calculations, using KO/PI's "next alarm" file and makes sure a resume is triggered shortly before the alarm comes up.
(I tell this all from memory, I don't have the exact script and file names handy now).

Somewhere in that chain may be an error.
Maybe only a missing link to the script?

daniel
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157321\"][{POST_SNAPBACK}][/a][/div]


No, Daniel, I was a diehard 200LX owner, but pretty much just a lurker among the web community.  I'm a longtime HP Corvallis employee, but I was on the IC side, not the handheld side.  Like you, with the passing of the LX products I've moved to the best replacement.  I still type on my Z!  I'll send you an email at your hermocom address for an offline contact.

Lo and behold, kopi-apm wasn't installed.  I've installed it, restarted X, rebooted/restarted X, run ipkg-link, and no luck!  I'll start investigating the scripts per your suggestion.

Thanks,

CktRider

daniel3000

  • Hero Member
  • *****
  • Posts: 1003
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #5 on: March 28, 2007, 07:57:03 am »
Quote
No, Daniel, I was a diehard 200LX owner, but pretty much just a lurker among the web community.  I'm a longtime HP Corvallis employee, but I was on the IC side, not the handheld side.  Like you, with the passing of the LX products I've moved to the best replacement.  I still type on my Z!  I'll send you an email at your hermocom address for an offline contact.

Lo and behold, kopi-apm wasn't installed.  I've installed it, restarted X, rebooted/restarted X, run ipkg-link, and no luck!  I'll start investigating the scripts per your suggestion.

Thanks,

CktRider
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157343\"][{POST_SNAPBACK}][/a][/div]

Hello CktRider,

kopi-apm and atd are the two packages required for that to work.
I think the most important thing is to check if the alarm file KO/PI writes is really written to where the script expects it.
On my Zaurus it works reliably, but I had problems once when it didn't work here, too.
I don't remember the exact reason, but I thin kit had to do with some file / directory linking so KO/PI wasn't able to write that alarm file properly.

Thanks for your email! It's always interesting to talk to HP Corvallis people. Do you know Everett Kaser, by chance?

daniel
SL-C3200 with weeXpc, based on pdaXrom 1.1.0beta3
HP 200LX with MS-DOS 5.0

CktRider

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #6 on: March 28, 2007, 11:44:26 pm »
No, sorry to say, the name is only vaguely familiar.  Probably from when they used to page people over the building public address system about fifteen years ago or more.

I have tried writing log files on scripts' suspend and resume functions.  The files are written on suspend, but not a thing is written to the log files when I resume.  After a ton of frustration, I'm going to reflash.  I don't know how many times I can get away with that, but I'll give it one more go.  That way I can see what the state of the system is at the outset.

Thanks for the help, Daniel!

CR

daniel3000

  • Hero Member
  • *****
  • Posts: 1003
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #7 on: March 29, 2007, 04:02:31 am »
Quote
No, sorry to say, the name is only vaguely familiar.  Probably from when they used to page people over the building public address system about fifteen years ago or more.

I have tried writing log files on scripts' suspend and resume functions.  The files are written on suspend, but not a thing is written to the log files when I resume.  After a ton of frustration, I'm going to reflash.  I don't know how many times I can get away with that, but I'll give it one more go.  That way I can see what the state of the system is at the outset.

Thanks for the help, Daniel!

CR
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157487\"][{POST_SNAPBACK}][/a][/div]

Is the kopi-apm script linked into the resume.d directory? If so, it must be executed on resume...
Did you modify the kopi-apm script in any way, so that the resume portion of it may not be triggered on resume via the parameter $1?

daniel
SL-C3200 with weeXpc, based on pdaXrom 1.1.0beta3
HP 200LX with MS-DOS 5.0

CktRider

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #8 on: March 29, 2007, 10:55:42 am »
Quote
Is the kopi-apm script linked into the resume.d directory? If so, it must be executed on resume...
Did you modify the kopi-apm script in any way, so that the resume portion of it may not be triggered on resume via the parameter $1?

daniel
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157495\"][{POST_SNAPBACK}][/a][/div]

Yes to the first question, and no to the second.  The great news is, that I just had success.  My Z came out of suspend and rang the alarm.  I'll document things for future reference.

Daniel, thanks very much for the help.  I'm glad to understand more about the suspend and resume process, and I'm sure others are also.

Best regards,

CktRider

CktRider

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://
Old Kopi Wakeup Pbm Back?
« Reply #9 on: April 03, 2007, 09:09:15 pm »
Well, it's been a wild ride since that last post.  What began as an apparent fix collapsed each time I tried the last thing to finish the fixes.  I used Meanie's very latest datentyme.py, applied the time fix routine at https://www.oesf.org/forums/index.php?showt...5618&hl=hwclock, including stopping and starting both atd and ntpd, ensured that apm was installed and running, checked for script functionality by logging to a file on resume and suspend, and did other things I've forgotten by now, but still found irregular execution of the scripts.d scripts, repeatedly incorrect time & date, system lockup after some suspends but not others, and still no Z wakeup by kopi.

Finally I have given up and reflashed to pdaXrom 1.1.0beta1 and applied the apmsleep fix, and everything is working just fine with kopi, kopi wakeup, clock and suspend again.  I've learned a few things in other areas that will enable me to live with beta1 for the moment.  Not a rant or a complaint about anybody's work--just a narrative.  Sometimes the excellent deeds others perform just aren't intended for you, eh?

CktRider