Author Topic: Problem With R189, Boot Failure  (Read 4618 times)

stoneworks

  • Newbie
  • *
  • Posts: 4
    • View Profile
Problem With R189, Boot Failure
« on: March 31, 2007, 08:32:59 am »
I followed instructions found in http://mail.pdaxrom.org, and succeeded building pdaXrom R189.
But I have troubles running it with my C1000.

The only differences I made for my own R189 ROM was removing all the games  with 'make menuconfig'.

And I've done ROM installation just like the way the documents describes.
(I've successfully installed and ran R121 before.)

Error log followes. (Thanks god, it was short enough for hand-typing..)
(Everything before this log looked normal to me.)

-------------START_OF_LOG---------------
Freeing init memory: 80KB
INIT: version 2.86 booting
/etc/rc.d/rc.sysinit: line 17: /sbin/udevstart: No such file or directory
Starting udev daemon: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Mounting Filesystem: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Mounting local FS: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Welcome to Zaurus pdaXrom!
Set loopback device: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Hostname: zaurus exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Module dependencies: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
FATAL: Error inserting pxaficp_ir (/lib/modules/2.6.16/kernel/drivers/net/irda/p
xaficp_ir.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_pcm_oss (/lib/modules/2.6.16/kernel/sound/core/oss/s
nd-pcm-oss.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_soc_wm8750 (/lib/modules/2.6.16/kernel/sound/so
c/codecs/snd-soc-wm8750.ko): Unknown symbol in module, or unknown paramete
r (see dmesg)
WARNING: Error inserting snd_soc_core (/lib/modules/2.6.16/kernel/sound/so
c/snd-soc-core.ko): Unknown symbol in module, or unknown parameter (see dme
sg)
WARNING: Error inserting snd_soc_pxa2xx (/lib/modules/2.6.16/kernel/sound/so
c/pxa/snd-soc-pxa2xx.ko): Unknown symbol in module, or unknown parameter
(see dmesg)
FATAL: Error inserting snd_soc_spitz (/lib/modules/2.6.16/kernel/sound/soc/pxa/
snd-soc-spitz.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Setup console font:                                                                         [   OK   ]
----------END OF LOG-------------

I hope this helps next pdaXrom build.

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #1 on: March 31, 2007, 09:04:18 am »
Quote
I followed instructions found in http://mail.pdaxrom.org, and succeeded building pdaXrom R189.
But I have troubles running it with my C1000.

The only differences I made for my own R189 ROM was removing all the games  with 'make menuconfig'.

And I've done ROM installation just like the way the documents describes.
(I've successfully installed and ran R121 before.)

Error log followes. (Thanks god, it was short enough for hand-typing..)
(Everything before this log looked normal to me.)

-------------START_OF_LOG---------------
Freeing init memory: 80KB
INIT: version 2.86 booting
/etc/rc.d/rc.sysinit: line 17: /sbin/udevstart: No such file or directory
Starting udev daemon: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Mounting Filesystem: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Mounting local FS: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Welcome to Zaurus pdaXrom!
Set loopback device: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Hostname: zaurus exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
Module dependencies: exec: No such file or directory
dup2: Bad file descriptor
exec: No such file or directory
                                                                                                      [FAILED]
FATAL: Error inserting pxaficp_ir (/lib/modules/2.6.16/kernel/drivers/net/irda/p
xaficp_ir.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_pcm_oss (/lib/modules/2.6.16/kernel/sound/core/oss/s
nd-pcm-oss.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_soc_wm8750 (/lib/modules/2.6.16/kernel/sound/so
c/codecs/snd-soc-wm8750.ko): Unknown symbol in module, or unknown paramete
r (see dmesg)
WARNING: Error inserting snd_soc_core (/lib/modules/2.6.16/kernel/sound/so
c/snd-soc-core.ko): Unknown symbol in module, or unknown parameter (see dme
sg)
WARNING: Error inserting snd_soc_pxa2xx (/lib/modules/2.6.16/kernel/sound/so
c/pxa/snd-soc-pxa2xx.ko): Unknown symbol in module, or unknown parameter
(see dmesg)
FATAL: Error inserting snd_soc_spitz (/lib/modules/2.6.16/kernel/sound/soc/pxa/
snd-soc-spitz.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Setup console font:                                                                         [   OK   ]
----------END OF LOG-------------

I hope this helps next pdaXrom build.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157647\"][{POST_SNAPBACK}][/a][/div]


that was an issue wtih that svn commit... We are currently at r196 :-) it was resolved in r190 :-)

Late
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

psycoman

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
    • http://www.tuxforum.com.br
Problem With R189, Boot Failure
« Reply #2 on: March 31, 2007, 10:03:06 am »
how i can downlod a nwe svn version ?

stoneworks

  • Newbie
  • *
  • Posts: 4
    • View Profile
Problem With R189, Boot Failure
« Reply #3 on: March 31, 2007, 11:34:50 am »
Quote
how i can downlod a nwe svn version ?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157656\"][{POST_SNAPBACK}][/a][/div]
I was gonna ask the same question  

willgan

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #4 on: April 01, 2007, 10:57:42 am »
count me in...
are the kernel still with 2.6.18 or 2.6.20?
My Current Z...

Zaurus C1000 - Pdaxii13
Using Pdaxrom-builder (SVN) for building packages

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #5 on: April 01, 2007, 10:58:16 am »
Quote
Quote
how i can downlod a nwe svn version ?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157656\"][{POST_SNAPBACK}][/a][/div]
I was gonna ask the same question  
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157663\"][{POST_SNAPBACK}][/a][/div]

well we are in the middle to constructing the new documentation on pdaxrom...

The svn has moved and all changes are being made there...

It will be on there soon

Late
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

xjqian

  • Sr. Member
  • ****
  • Posts: 497
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #6 on: April 01, 2007, 10:40:35 pm »
looking forward to a public svn, too.
My Blog | 6000L Tosa + sled | is: Angstrom | was: pdaXrom 1.1.0beta1 | was: stock 1.12 rom + no-ffpe fash kernel + X/Qt Debian |
CF GPS (FGPCFCD01) | USB "Prolific 2303" GPS (USB-UG-200) | Socket CF BT rev. H |  USB "Pegasus II" Ethernet (ADM8511) | PocketTop IR kbd | sip:527630@fwd.pulver.com
Todo: OESF wiki | stable VOIP app | usable GPS app |      Wishlist: VOIP + Bluetooth | GPS + Routing Calc

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #7 on: April 01, 2007, 11:03:13 pm »
Quote
looking forward to a public svn, too.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157770\"][{POST_SNAPBACK}][/a][/div]

Well the SVN has been public... the documentation is at pdaxrom.org..

It is just that we moved it over to a new location about 2 weeks and the documentation hasnt been updated...

Late
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Problem With R189, Boot Failure
« Reply #8 on: April 03, 2007, 05:03:34 am »
Quote
that was an issue wtih that svn commit... We are currently at r196 :-) it was resolved in r190 :-)

Late
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157652\"][{POST_SNAPBACK}][/a][/div]

Has the svn been fixed? I still got r189 when I check-out from svn. How can I get r196?

Also, how about the corgi rom of r196? Is it on the same level of usability as akita?
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #9 on: April 03, 2007, 09:03:33 am »
Quote
Quote
that was an issue wtih that svn commit... We are currently at r196 :-) it was resolved in r190 :-)

Late
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

Has the svn been fixed? I still got r189 when I check-out from svn. How can I get r196?

Also, how about the corgi rom of r196? Is it on the same level of usability as akita?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=157843\"][{POST_SNAPBACK}][/a][/div]

when I find sometime I will be updated the page....

[a href=\"https://pdaxrom.svn.sourceforge.net/svnroot/pdaxrom/trunk]https://pdaxrom.svn.sourceforge.net/svnroot/pdaxrom/trunk[/url]

Please delete your current one, and re checkout to the new repo.

Late
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Problem With R189, Boot Failure
« Reply #10 on: April 04, 2007, 09:46:39 pm »
Quote
when I find sometime I will be updated the page....

https://pdaxrom.svn.sourceforge.net/svnroot/pdaxrom/trunk

Please delete your current one, and re checkout to the new repo.

Late
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

It works. Thanks for the information.

Another issue: When I ran the build script I got an error saying that tk8.4.14-src.tar.gz can't be downloaded. I'm using [a href=\"http://mail.pdaxrom.org/src]http://mail.pdaxrom.org/src[/url] to get the source codes, as described in the documentation. Do I need to use othe source url or should I download the source codes by myself?
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #11 on: April 04, 2007, 10:12:50 pm »
Quote
Quote
when I find sometime I will be updated the page....

https://pdaxrom.svn.sourceforge.net/svnroot/pdaxrom/trunk

Please delete your current one, and re checkout to the new repo.

Late
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

It works. Thanks for the information.

Another issue: When I ran the build script I got an error saying that tk8.4.14-src.tar.gz can't be downloaded. I'm using [a href=\"http://mail.pdaxrom.org/src]http://mail.pdaxrom.org/src[/url] to get the source codes, as described in the documentation. Do I need to use othe source url or should I download the source codes by myself?
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]
Sorry

[a href=\"http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/src]http://distro.ibiblio.org/pub/linux/distri...ons/pdaxrom/src[/url]

Late
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

stoneworks

  • Newbie
  • *
  • Posts: 4
    • View Profile
Problem With R189, Boot Failure
« Reply #12 on: April 04, 2007, 11:00:51 pm »
Quote
Quote
Quote
when I find sometime I will be updated the page....

https://pdaxrom.svn.sourceforge.net/svnroot/pdaxrom/trunk

Please delete your current one, and re checkout to the new repo.

Late
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

It works. Thanks for the information.

Another issue: When I ran the build script I got an error saying that tk8.4.14-src.tar.gz can't be downloaded. I'm using [a href=\"http://mail.pdaxrom.org/src]http://mail.pdaxrom.org/src[/url] to get the source codes, as described in the documentation. Do I need to use othe source url or should I download the source codes by myself?
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]
Sorry

[a href=\"http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/src]http://distro.ibiblio.org/pub/linux/distri...ons/pdaxrom/src[/url]

Late
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158009\"][{POST_SNAPBACK}][/a][/div]

missing usbdconf-1.1.3.tar.bz2 on both URLs
I'm proceeding with usbdconf.make modified. (1.1.1)

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #13 on: April 05, 2007, 10:23:46 am »
Fixed, if you use 1.1.1 the usbconfig will not work...

Late
« Last Edit: April 05, 2007, 10:24:49 am by InSearchOf »
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Problem With R189, Boot Failure
« Reply #14 on: April 09, 2007, 03:42:40 am »
Quote
Sorry

http://distro.ibiblio.org/pub/linux/distri...ons/pdaxrom/src

Late
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158009\"][{POST_SNAPBACK}][/a][/div]

Thanks! I finally successfully built it. There was still a problem, though:
The sysfsutils-2.1.0.tar.gz failed to download from the source directory. The target folder was /home/root/my-akita-roms/src/index.html, which seemed to be wrong. I manually downloaded it and the build process succeeded.

BTW, if I want to rebuild it when the svn is updated, what command should I use? I tried "make clean" in the middle of the build process when I wanted to use the new configuration, but there was some error. (I didn't take a note of that.)
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)