Author Topic: Problem With R189, Boot Failure  (Read 4617 times)

pkwong

  • Newbie
  • *
  • Posts: 29
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #15 on: April 10, 2007, 12:27:41 pm »
that's great!
would you mind writing a short guide on building the latest version in svn?

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Problem With R189, Boot Failure
« Reply #16 on: April 10, 2007, 01:26:37 pm »
Quote
that's great!
would you mind writing a short guide on building the latest version in svn?
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

I just followed the guide here:

[a href=\"http://www.pdaxrom.org/?q=node/101]http://www.pdaxrom.org/?q=node/101[/url]

You only need to replace the svn server and source server with the values that InSearchOf mentioned in this thread:

svn checkout https://pdaxrom.svn.sourceforge.net/svnroot/pdaxrom/trunk

and

./configure akita-kernel-2.6-xtools ~/my-akita-rom http://distro.ibiblio.org/pub/linux/distri...ons/pdaxrom/src

Also you will need about 10GB free harddrive space for building the ROM.
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #17 on: April 10, 2007, 02:46:05 pm »
Quote
./configure akita-kernel-2.6-xtools ~/my-akita-rom http://distro.ibiblio.org/pub/linux/distri...ons/pdaxrom/src

Hmm, the ibiblio source archive seems to be missing today, I keep getting a 404 error. When I browse to http://distro.ibiblio.org/pub/linux/distributions/ I only see debian, slackware, suse, winlinux and fedora.

Code: [Select]
geekoid@geek-workstation:~/my-corgirom$ make virtual-xchain_install
-------------------------
target: gcc-3.4.6.tar.bz2
-------------------------

--13:31:49--  http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/src//gcc-3.4.6.tar.bz2
           => `/home/geekoid/my-corgirom/src/gcc-3.4.6.tar.bz2'
Resolving distro.ibiblio.org... 152.46.7.109
Connecting to distro.ibiblio.org|152.46.7.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
13:31:49 ERROR 404: Not Found.

make: *** [/home/geekoid/my-corgirom/src/gcc-3.4.6.tar.bz2] Error 1
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Problem With R189, Boot Failure
« Reply #18 on: April 11, 2007, 02:00:24 am »
Quote
Quote
./configure akita-kernel-2.6-xtools ~/my-akita-rom http://distro.ibiblio.org/pub/linux/distri...ons/pdaxrom/src

Hmm, the ibiblio source archive seems to be missing today, I keep getting a 404 error. When I browse to http://distro.ibiblio.org/pub/linux/distributions/ I only see debian, slackware, suse, winlinux and fedora.

Code: [Select]
geekoid@geek-workstation:~/my-corgirom$ make virtual-xchain_install
-------------------------
target: gcc-3.4.6.tar.bz2
-------------------------

--13:31:49--  http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/src//gcc-3.4.6.tar.bz2
           => `/home/geekoid/my-corgirom/src/gcc-3.4.6.tar.bz2'
Resolving distro.ibiblio.org... 152.46.7.109
Connecting to distro.ibiblio.org|152.46.7.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
13:31:49 ERROR 404: Not Found.

make: *** [/home/geekoid/my-corgirom/src/gcc-3.4.6.tar.bz2] Error 1
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158431\"][{POST_SNAPBACK}][/a][/div]

Yes, it's gone! Can anyone fix this?

BTW, the SVN is updated to 198 now. I'm glad to see it's being actively developed!
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

kellyharding

  • Jr. Member
  • **
  • Posts: 94
    • View Profile
    • http://www.geekgothgrrl.co.uk
Problem With R189, Boot Failure
« Reply #19 on: April 11, 2007, 02:28:59 am »
Quote
Yes, it's gone! Can anyone fix this?

BTW, the SVN is updated to 198 now. I'm glad to see it's being actively developed!
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158468\"][{POST_SNAPBACK}][/a][/div]

InSearchOf posted earlier that the host has had hardware problems.

Kelly
SL-C860: cacko 1.23(currently pdaxii3 to test)
1Gb SD, 2Gb CF, various 512Mb SD and CF cards, Socket LP wifi, Socket Rev F Bluetooth. 2Gb SD and 4Gb CF on order.
--------------------------------------------------------------------------
PC: Athlon64 3000+ with XP/SimplyMepis
Mac: G4 Quicksilver 733 with OS X.4.9
Laptop: iBook G4 (2005) 1.42Ghz, OS X 4.9
Server: Dual PIII/500 with Debian 'etch'

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #20 on: April 11, 2007, 02:37:55 pm »
wrc4:
While I wait for the hardware to be replaced, I'm curious if you did your build using the pdaXrom-builder Live cd or on your own linux box?

I tried building an earlier version but it didn't like having gcc-4.1 on the host. I know sashz at one time had a vm version, so I was hoping either for a build system that uses a more current complier or a vm version so I don't have to boot out of my normal linux install to build the pdaXrom image.

Cheers,
Jerry
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #21 on: April 11, 2007, 05:35:50 pm »
Interesting, I've got the pdaXrom iso running as a virtual machine with VirtualBox. Easy install works pretty well so far. Check it out http://www.virtualbox.org/wiki/Downloads

Cheers,
Jerry
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Problem With R189, Boot Failure
« Reply #22 on: April 11, 2007, 11:28:34 pm »
Quote
Interesting, I've got the pdaXrom iso running as a virtual machine with VirtualBox. Easy install works pretty well so far. Check it out http://www.virtualbox.org/wiki/Downloads

Cheers,
Jerry
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158537\"][{POST_SNAPBACK}][/a][/div]

That's right! I'm using the pdaX86 LiveCD on VMWare Workstation. The only problem is X doesn't startup. But you don't need X to build the rom.
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

willgan

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #23 on: April 12, 2007, 01:02:57 am »
I don't really use the vmware...

Just use chroot and do some minor tweak..

You need to extract the base files from the ISO file to chroot.
My Current Z...

Zaurus C1000 - Pdaxii13
Using Pdaxrom-builder (SVN) for building packages

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #24 on: April 12, 2007, 11:33:44 am »
Quote
I don't really use the vmware...

Just use chroot and do some minor tweak..

You need to extract the base files from the ISO file to chroot.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=158566\"][{POST_SNAPBACK}][/a][/div]
Yes, a more elegant solution than running vmware. I'll have to try that. I usually solve problems with the most complicated solution I can  

However, it is nice to find a GPL vm solution. I'm going to create a WinBlow$ vm with it. I may be able to finally lose the WinBlow$ partition on my PC. I rarely use it now as it is.

Cheers,

Jerry
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

willgan

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • http://
Problem With R189, Boot Failure
« Reply #25 on: April 18, 2007, 12:24:20 am »
Compiling under vm environment will be very slow.
It is possible to compile some application that require native arm environment using qemu-arm but i haven't tried it yet.
« Last Edit: April 18, 2007, 12:25:20 am by willgan »
My Current Z...

Zaurus C1000 - Pdaxii13
Using Pdaxrom-builder (SVN) for building packages