Author Topic: What Are The Needed Modules For Android?  (Read 10385 times)

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
What Are The Needed Modules For Android?
« on: March 06, 2008, 04:13:06 am »
I was going through the exciting material about Android, and somewhere I read that the binderdev cannot be built under kernel 2.6.24.
My 3200 is now running kernel-2.6.24-yonggun.
What can we do to make this working? Where can I get the source and how to proceed (just like compiling a kernel module or what)?
I haven't found relevant information yet. Pointers are greatly appreciated.
Thanks!
« Last Edit: March 06, 2008, 04:13:17 am by ZDevil »

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
What Are The Needed Modules For Android?
« Reply #1 on: March 06, 2008, 05:15:51 am »
Quote from: ZDevil
I was going through the exciting material about Android, and somewhere I read that the binderdev cannot be built under kernel 2.6.24.
My 3200 is now running kernel-2.6.24-yonggun.
What can we do to make this working? Where can I get the source and how to proceed (just like compiling a kernel module or what)?
I haven't found relevant information yet. Pointers are greatly appreciated.
Thanks!

apparently kernel needs google patch :
https://www.oesf.org/forum/index.php?showto...st&p=174640

but are there any for the 2.6.24 kernel ?
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

cortez

  • Sr. Member
  • ****
  • Posts: 375
    • View Profile
    • http://www.omegamoon.com
What Are The Needed Modules For Android?
« Reply #2 on: March 06, 2008, 09:54:06 am »
First, I don't know if the the kernel-2.6.24-yonggun specific patches are available. Second, if so, I don't know if the Google patches can be applied to the 2.6.24 kernel, since Android uses 2.6.23 currently in the emulator. I guess this could lead to problems, but maybe this could be worth trying. androidzaurus has reported that compiling the binderdev code as a kernel module (at least in 2.6.23) didn't work, so I didn't bother to try  

After I cleaned up the patches a bit I will upload them so everyone interested can use them. The patches are the result of a diff between a vanilla 2.6.23 and the Android 2.6.23 code. No code left out, so 100% is used. In addition to that, the panning functionality was added to the framebuffer code. I've added the patches to the Linux package in OpenEmbedded (locally), so it's actually quite easy to build a kernel (no fiddling with options and copying of files, just bitbake poky-image-minimal)

Oh, and by the way, if you want to go through all the trouble creating the patches yourself you need the Android kernel sources
[div align=\"center\"]== == == == == == == == == == == == == ==
www.omegamoon.com
Zaurus SL-C750 - Died in a dreadful coffee experiment, has a second life somewhere in the Czech Republic
Zaurus SL-C1000 - Multiboot Zubuntu, Debian, Fedora, Poky, Android and others
Zaurus SL-C3100 - Development device, currently Zubuntu 2.0
Zaurus SL-6000L - The fridge is running Zubuntu 1.0
Zaurus SL-C860 - Cacko, untouched since kindly donated, waiting for Zubuntu
== == == == == == == == == == == == == ==[/div]