Author Topic: default route missing  (Read 1861 times)

defunked

  • Newbie
  • *
  • Posts: 24
    • View Profile
default route missing
« on: July 27, 2018, 01:24:22 pm »
As I continue on my Sailfish/Gemini journey, I finally got LTE data working in the USA on the Verizon network.
With that now working, I discovered a new Sailfish bug:  When the device switched the network default route between LTE to WiFi, the default route disappears from the routing table,
as observed via shell executed netstat -r.  I need to reboot to get the network stack working again, or manually add a default route back in as su-devel:

route add default gw 192.168.11.1 wlan0

for example to get things working again with my inhouse WiFi.

Also, I can receive phone calls while registered on LTE, but after the call, Sailfish compains that no SIM is inserted until I reboot.

 I am still learning my way around this OS, so I don't think I can be much help yet.

defunked

  • Newbie
  • *
  • Posts: 24
    • View Profile
default route missing
« Reply #1 on: July 30, 2018, 04:44:33 pm »
Quote from: defunked
As I continue on my Sailfish/Gemini journey, I finally got LTE data working in the USA on the Verizon network.
With that now working, I discovered a new Sailfish bug:  When the device switched the network default route between LTE to WiFi, the default route disappears from the routing table,
as observed via shell executed netstat -r.  I need to reboot to get the network stack working again, or manually add a default route back in as su-devel:

route add default gw 192.168.11.1 wlan0

for example to get things working again with my inhouse WiFi.

Also, I can receive phone calls while registered on LTE, but after the call, Sailfish compains that no SIM is inserted until I reboot.

 I am still learning my way around this OS, so I don't think I can be much help yet.

More observations:  Default route is lost often when transitioning from cellular data to WiFi when I move into range of my home WiFi network.  The problem can be also fixed by turning airplane mode on and off again.

vader

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
default route missing
« Reply #2 on: July 31, 2018, 02:18:20 am »
Quote from: defunked
Quote from: defunked
As I continue on my Sailfish/Gemini journey, I finally got LTE data working in the USA on the Verizon network.
With that now working, I discovered a new Sailfish bug:  When the device switched the network default route between LTE to WiFi, the default route disappears from the routing table,
as observed via shell executed netstat -r.  I need to reboot to get the network stack working again, or manually add a default route back in as su-devel:

route add default gw 192.168.11.1 wlan0

for example to get things working again with my inhouse WiFi.

Also, I can receive phone calls while registered on LTE, but after the call, Sailfish compains that no SIM is inserted until I reboot.

 I am still learning my way around this OS, so I don't think I can be much help yet.

More observations:  Default route is lost often when transitioning from cellular data to WiFi when I move into range of my home WiFi network.  The problem can be also fixed by turning airplane mode on and off again.

I installed a patch to the utils section of setup which allows you to restart things like networking, or the home page. I can't recall which app it was, but it was from openrepos. This won't stop it happening, but you should be able to fix it by clicking the restart network button. I personally haven't seen this problem, so I can't say with complete confidence that it would work.......What happens if you just disable wifi, then reconnect?

defunked

  • Newbie
  • *
  • Posts: 24
    • View Profile
default route missing
« Reply #3 on: July 31, 2018, 11:25:54 am »
Quote from: vader
Quote from: defunked
Quote from: defunked
As I continue on my Sailfish/Gemini journey, I finally got LTE data working in the USA on the Verizon network.
With that now working, I discovered a new Sailfish bug:  When the device switched the network default route between LTE to WiFi, the default route disappears from the routing table,
as observed via shell executed netstat -r.  I need to reboot to get the network stack working again, or manually add a default route back in as su-devel:

route add default gw 192.168.11.1 wlan0

for example to get things working again with my inhouse WiFi.

Also, I can receive phone calls while registered on LTE, but after the call, Sailfish compains that no SIM is inserted until I reboot.

 I am still learning my way around this OS, so I don't think I can be much help yet.

More observations:  Default route is lost often when transitioning from cellular data to WiFi when I move into range of my home WiFi network.  The problem can be also fixed by turning airplane mode on and off again.

I installed a patch to the utils section of setup which allows you to restart things like networking, or the home page. I can't recall which app it was, but it was from openrepos. This won't stop it happening, but you should be able to fix it by clicking the restart network button. I personally haven't seen this problem, so I can't say with complete confidence that it would work.......What happens if you just disable wifi, then reconnect?

I discovered that switching airplane mode on and off again restores the default route.  Simply turning WiFi off/on does not fix the problem.  This seems to indicate a problem with the phone/cell hooks into the routing table.  As a side note, "netstat -r" hangs for about a minute when the bug has been triggered, then it finally returns a list with out the default route entry.  While not great, the airplane mode fix is not too difficult a work around.

dumas

  • Newbie
  • *
  • Posts: 2
    • View Profile
default route missing
« Reply #4 on: July 31, 2018, 11:35:08 am »
If networking is down, 'netstat -r' will hang for a minute trying to reverse-resolve the IP addresses to domain names.  'netstat -rn' should avoid that.

defunked

  • Newbie
  • *
  • Posts: 24
    • View Profile
default route missing
« Reply #5 on: July 31, 2018, 04:02:11 pm »
Quote from: dumas
If networking is down, 'netstat -r' will hang for a minute trying to reverse-resolve the IP addresses to domain names.  'netstat -rn' should avoid that.

Right!  In hind sight that should have been obvious.  Thanks.