Author Topic: Gemini broken after flashing  (Read 943 times)


  • Newbie
  • *
  • Posts: 4
    • View Profile
Gemini broken after flashing
« on: December 16, 2019, 05:44:07 pm »

I join your forum with bad news: My Gemini seems broken after I flashed the latest Android8.1 and Debian from the PlanetComputer website, following the guide (

Video of the strange display behavior

The scatter file was created with this tool

- 20GB for Android, 36.407GB for Linux)
- Boot 1: Rooted Android
- Recovery: Recovery
- Boot 2: Debian
- Boot 3: TWRP Recovery

I backed up the NVRAM section and successfully flashed all the files. The first boot went fine and started Android. After setting up Android I wanted to start Linux.

But when I then tried to reboot into Linux (by pressing the side button during boot) it shows the Planet Computers splash screen and then starts the strange wiping of the screen.

I've let that run for several tens of minutes without any changes.

I tried all three boot options, all now show the same behaviour. Even Android does not start anymore.

I've tried the "Download only", "Firmware Upgrade" and the "Format All+ Download" Options from the Download-page in the flash tool.

Flashing only the Android stock image shows the same behavior...

The debug UART port from the MediaTek SOC shows the following output:

The display starts the wiping after the log has reached the end. It seems like the booloader is okay, but starting the OS fails.

Gemini Support suggested flashing the stock image, and if that doesn't help, sending it in for service.

I had hoped to use the Gemini for 36C3 to not have to carry around a big laptop. So any help for fixing it without sending it to Planet Computers would be greatly appreciated!
« Last Edit: December 16, 2019, 05:44:45 pm by stdlogicvector »


  • Newbie
  • *
  • Posts: 20
    • View Profile
Gemini broken after flashing
« Reply #1 on: December 20, 2019, 09:06:19 am »
Sorry to hear your troubles.

Can I ask, is your Gemini WiFi only? If so, it needs the Android 7.x version, not 8.x.

I had to be careful as I very nearly downloaded the wrong one and it was only a hunch that made me double check....
Still holding faith in my Planet Gemini and Cosmo, in the memory of dear old Psion.