Author Topic: HDMI not working  (Read 197 times)

ezzo24

  • Newbie
  • *
  • Posts: 8
    • View Profile
HDMI not working
« on: August 05, 2020, 07:50:50 am »
I purchased a Gemini pda (and its usb cable) for its hdmi connectivity.
Tested on three TVs. Nothing works.
And now ?

 :o

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1073
    • View Profile
    • http://
Re: HDMI not working
« Reply #1 on: August 05, 2020, 10:10:50 am »
By "its USB cable" you mean its HDMI dongle? Have you activated the HDMI output in the settings? Under Screen -> Advanced -> HDMI - Open HDMI.

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!
#gemini-pda, #zaurus and #alarmz on Freenode: https://webchat.freenode.net/
#planetgemini on matrix: https://riot.im/app/#/room/#planetgemini:matrix.org
Gemini PDA on Telegram

ezzo24

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: HDMI not working
« Reply #2 on: August 05, 2020, 10:43:35 am »
The cable is sold in the site where i purchased the gemini, the output setting is set to open.
« Last Edit: August 05, 2020, 10:47:15 am by ezzo24 »

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1073
    • View Profile
    • http://
Re: HDMI not working
« Reply #3 on: August 06, 2020, 04:36:03 am »
Ok, I was asking about the HDMI cable since only Planet Computer's one works on the Gemini. This cable doesn't have any Planet or Gemini logo on it (only a "HDMI" one), but the box is clearly labelled with a Planet logo. I have tried the cable on my Gemini and the Android screen was shown on my 32" FullHD TV as soon as I have connected it, although the image was shown rotated. A couple of additional questions:
- are you using the right USB port? The left port doesn't work with the HDMI cable
- what version of Android are you running, 7 or 8.1? The latest 8.1 is known to have some issues with HDMI, while 7 should work without problems.

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!
#gemini-pda, #zaurus and #alarmz on Freenode: https://webchat.freenode.net/
#planetgemini on matrix: https://riot.im/app/#/room/#planetgemini:matrix.org
Gemini PDA on Telegram

ezzo24

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: HDMI not working
« Reply #4 on: August 06, 2020, 06:43:44 am »
Yes, the cable only says "hdmi" on one side and "HOC(copyright)" on the other, but the box is from Planet, in fact I purchased it together with the pda.
I use the correct door, the right one. It's strange, because once connected, nothing happens, nor soft, nor hard. "Hdmi port" is "open".
As soon as I turned it on, the pda asked me to update the system, so I have android 8.
I hope they resolve the matter. I have already sent a report to support.
Another thing: the connection to chromecast works, but i cannot view in the right orientation, it's always rotated 90° clockwise !

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1073
    • View Profile
    • http://
Re: HDMI not working
« Reply #5 on: August 08, 2020, 02:33:29 am »
My guess is that all the monitors/TVs you have tested might get confused by the unusual resolution of the rotated screen. We might be able to test this in this way: try to plug the HDMI cable while the Gemini is showing the lock screen, the screen should be shown correctly in landscape mode, as explained here: https://www.oesf.org/forum/index.php?topic=35791.msg295980#msg295980

For now the only solution seems to be to go back to Android 7, although it's a less than ideal solution. Another solution might be to try to find an app which manages to always force the display in landscape mode. There might be many apps which control the rotation, but only a few of them might work with the HDMI output too.

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!
#gemini-pda, #zaurus and #alarmz on Freenode: https://webchat.freenode.net/
#planetgemini on matrix: https://riot.im/app/#/room/#planetgemini:matrix.org
Gemini PDA on Telegram

ezzo24

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: HDMI not working
« Reply #6 on: August 08, 2020, 04:21:44 am »
Thanks, but this is very confusing. As written, the orientation issue occurs with chromecast, hdmi cable has no relationship with this. HDMI doesn't work anyway.

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1073
    • View Profile
    • http://
Re: HDMI not working
« Reply #7 on: August 08, 2020, 07:00:42 am »
I have the rotated image issue when using the HDMI cable, same as another user on the other thread. I'm surprised that my TV is able to display at all such a unusual resolution, hence my suspect that your issue might be caused by the resolution of the screen, rather than a problem with the cable. If we could check that the HDMI works when the Gemini is showing the lock screen, we could at least find out that the cable itself is working and that the issue is probably software-related.

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!
#gemini-pda, #zaurus and #alarmz on Freenode: https://webchat.freenode.net/
#planetgemini on matrix: https://riot.im/app/#/room/#planetgemini:matrix.org
Gemini PDA on Telegram

ezzo24

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: HDMI not working
« Reply #8 on: August 11, 2020, 06:21:16 am »
About the resolution: chromecast 3th generation works perfectly on my tv.
About the lock screen: i tried with and without, no difference, hdmi not recognized.
Very frustrating.
I'm considering resetting to old android system.

gemini_user_j

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
Re: HDMI not working
« Reply #9 on: September 01, 2020, 07:18:33 am »
My guess is that all the monitors/TVs you have tested might get confused by the unusual resolution of the rotated screen. We might be able to test this in this way: try to plug the HDMI cable while the Gemini is showing the lock screen, the screen should be shown correctly in landscape mode, as explained here: https://www.oesf.org/forum/index.php?topic=35791.msg295980#msg295980

For now the only solution seems to be to go back to Android 7, although it's a less than ideal solution. Another solution might be to try to find an app which manages to always force the display in landscape mode. There might be many apps which control the rotation, but only a few of them might work with the HDMI output too.

Varti

hi, just to clarify the photos I uploaded in the other post as I didn't mention it before: If I use the integrated force rotate, the display on the device will switch to portrait mode, and the image displayed on the external monitor will still only be shown on the same part of the monitor and then reflect the portrait mode on the gemini (I dont remember if this was even up-side down)
Gemini PDA x27