Author Topic: Problem with kernel. No downgrade possible  (Read 226 times)

leonce

  • Newbie
  • *
  • Posts: 3
    • View Profile
Problem with kernel. No downgrade possible
« on: October 14, 2021, 06:27:26 pm »
Hello! I am here in 2021 flashing opie into a Zaurus sl5500!!

I am installing the last version I found 3.5.4.1
However I see that it is pretty empty innterms of apps and compatibility qith my wifi cf…and I want to go back to 3.5.4 but! I see there is no way to change the kernel, it is stuck on 3.5.4.1.rc4
It still works but I would like to know if you still possible to go down to the 3.5.4 kernel  version

Thanks
I have tried the  3.5.4.1 but I can’t pick any wifi despite being open or wep… if i have to stick with this version I would like to know how to make lt work and edit the feed lf packages

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
Re: Problem with kernel. No downgrade possible
« Reply #1 on: October 21, 2021, 06:40:46 am »
I think that a full installation should work, unless there are settings on the current system which you'd like to keep. There should be an option in the recovery menu to do a full erase of the internal NAND.

Regarding the Wifi option, it's strange that it doesn't work even with an open network. Does your Zaurus see the network at all? Make also sure that your router supports the old 802.11b protocol, if not you might try sharing a wifi connection with a phone.

Varti
« Last Edit: October 21, 2021, 06:45:46 am by Varti »
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!

leonce

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Problem with kernel. No downgrade possible
« Reply #2 on: October 21, 2021, 06:56:38 am »
Hello! Thank you!
I solved the kernel thing! Sometimes when I placed the image file on the CF the file extension was present… without file extension worked fine and could install opie 3.5.4

In order to make the wifi cf work I had to upgrade the firmware. I used winupdate and an old comp and a cf to pcmcia adapter aaand a with pcmcia. That worked and now I can connect and see all wifi essids around.

What I can’t do now…
Install anything on sd card.
I updated all ipk feeds to these
http://feed.zaurusfr.org/openzaurus/
And also software
http://www.ngsoft-fr.com/zaurus/Cacko/feed/

Sd is formated to ext2 but once the ipk is downloades i see a lot of errors. The program files are on the sd but the program is not usable  ::)
I
« Last Edit: October 21, 2021, 08:24:47 am by leonce »

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
Re: Problem with kernel. No downgrade possible
« Reply #3 on: October 21, 2021, 08:05:55 am »
Great to hear that you have succeded :)

What kind of errors do you see while using the SD card? Are you having issues install FROM or ON the SD card? The card itself might be corrupted or have bad blocks, you might try running fsck on it.

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!

leonce

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Problem with kernel. No downgrade possible
« Reply #4 on: October 21, 2021, 01:26:46 pm »
I get it downloaded. On the package installer I selct Sd as destination (500mb SD)
The problem is with the links or seomthing like that….    :o