Author Topic: Flashing hangs at 80% on system  (Read 488 times)

d2a

  • Newbie
  • *
  • Posts: 14
    • View Profile
Flashing hangs at 80% on system
« on: May 04, 2024, 06:08:38 am »
So I bought a 4G gemini that was stuck in a boot loop - vibrate, show planet logo, black screen, repeat. I've been trying to get it reflashed with some success:

Failed tests
  • virtualbox windows 8 (macOS host)
  • virtualbox fedora 39

Partially working
  • Fedora 39 live USB

Using the live USB (after following the instructions https://support.planetcom.co.uk/index.php/Linux_Flashing_Guide ) I could connect to the Gemini, backup the NVRAM and start the flash process. I chose to just reflash the system partition (to try to fix the boot loop) and it started ok, but froze at 80% and eventually timed out with a "STATUS_DOWNLOAD_EXCEPTION" error. I then tried a full firmware update and it progressed well until the system partition stage where it again failed at 80%. I used the base system Gemini_x27_MP_16032018 from Planet suuport

Once I had unplugged this failed update, I held the esc and silver keys to reboot, and noticed the keycaps blue led light up and the boot screen disappeared and I saw a broken android logo. I retried the flash with the same results but this is at least some progress.

Anyone have any recommendations for further progress? I think i'll try flashing a newer base system next

d2a

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Flashing hangs at 80% on system
« Reply #1 on: June 04, 2024, 07:46:02 am »
Just an update on this. Tried a full update using the latest Planet Android image and hey presto. Reflash completed, gemini rebooted and all was good. Battery is actually working well (!) and overall the device is pretty happy. Few keys have zero travel and wobble a little which is a known issue. I may try to find a fix but at least it├Žs useable.