Author Topic: Wireless Question?  (Read 1400 times)

Arrummzen

  • Newbie
  • *
  • Posts: 15
    • View Profile
Wireless Question?
« on: May 14, 2004, 08:38:40 pm »
When I run kismet it crashes after a while. The time varys from 2 seconds to 3 minites, but it always happens. How do I stop this? The chanal seems to freez (In other words it stops scanning and locks onto one chanal). Methinks it may have to do with some other componet trying to enable one of the lan profiles, but I can\'t be sure.

Thank you for your time,
Arrummzen

EZ

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • http://
Wireless Question?
« Reply #1 on: May 14, 2004, 09:39:16 pm »
Make sure your card is not attempting to get a DHCP address. If it is it can cause the problem you described.
SLC-860 / pdaXrom

Arrummzen

  • Newbie
  • *
  • Posts: 15
    • View Profile
Wireless Question?
« Reply #2 on: May 14, 2004, 09:46:15 pm »
How can I make sure my card is not trying to get a dhcp address?

Thank you for your time,
Arrummzen

EZ

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • http://
Wireless Question?
« Reply #3 on: May 14, 2004, 09:58:13 pm »
Thats going to depend on what ROM you are using. If you can open up multiple shells you can issue a ps -ax | grep dhcp to see if a dhcp client is running. If it is kill it. A simpler way is to configure your card to have a static address - doesnt matter what so your device wont go looking for one.
SLC-860 / pdaXrom

EZ

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • http://
Wireless Question?
« Reply #4 on: May 14, 2004, 10:03:29 pm »
Well Im an idiot - based on the fact you posted this in the pdaXrom cat Im guessing your running that rom. When you boot or put your WiFI card in drop to a shell and do a ps -ax | grep eth0. You should see several scripts and a dhcpdc process. Thats whats most likely causing your troubles.
SLC-860 / pdaXrom

Arrummzen

  • Newbie
  • *
  • Posts: 15
    • View Profile
Wireless Question?
« Reply #5 on: May 15, 2004, 10:30:47 pm »
Yep, you were right. Sorry it took me so long to reply, my internet wasn\'t working.

Thank you for your time,
Arrummzen