Author Topic: gimp icon?  (Read 3656 times)

offroadgeek

  • Administrator
  • Hero Member
  • *****
  • Posts: 1419
    • View Profile
    • https://www.oesf.org
gimp icon?
« on: December 08, 2003, 10:22:09 pm »
now to show everyone how little I know about linux and X...    

I\'ve successfully installed gimp onto the x11 rom, and I can run it great from konsole, but I\'d like to have the pretty icon in the apps folder as well.  The only thing I can find is .gimp-1.2.

Any suggestions?

offroadgeek
Search the OESF Wiki
C1000 w/Cacko 1.23 beta (from Streamline) / 760 pdaxrom rc9 / 6000L (thanks Santa's elf!) / 5500 - OZ 3.3.5 / SIMpad SL4
1GB, 256mb SanDisk CF / 2x 1GB, 512mb, 256mb, 128mb SanDisk SD
Ambicom WL100C-CF wifi / Socket 56k CF modem / AmbiCom BT2000-CF (x2)
Pocketop keyboard, Piel Frama case (1000 & 5500), PDAir case (760 & 1000)
sip:536093@fwd.pulver.com
| OESF | ELSI | Zaurus User Group | ZaurusThemes |

omin0us

  • Full Member
  • ***
  • Posts: 105
    • View Profile
    • http://
gimp icon?
« Reply #1 on: December 09, 2003, 12:59:00 am »
are you looking for an icon to use? or how to set up the icon. If you are wanting to create the icon you need to have a loot at ~/usr/apps/ROX-CLib/Help/README, that should have  all you need to make them. also check out ~/usr/apps/ROX-CLib/Help/rox-clib.html

hope that helps you out.
pdaXrom Developer team member - http://www.pdaxrom.org
c760/X11 based ROM, sl-5500/OZ 3.3.5
Ambicom WL1100C-1 WiFi card, Targus CF 56k Modem.
Ericsson T610 phone. (still need a BT card though)
FreeBSD 4.8/Slackware 9.1

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
gimp icon?
« Reply #2 on: December 09, 2003, 02:36:26 pm »
Quote
are you looking for an icon to use? or how to set up the icon. If you are wanting to create the icon you need to have a loot at ~/usr/apps/ROX-CLib/Help/README, that should have  all you need to make them. also check out ~/usr/apps/ROX-CLib/Help/rox-clib.html

hope that helps you out.

Thanks for info, but not all of us are young wiz-kids like yourself (note small measure of jealousy on both the youth & wiz parts).

In looking at the help doc and then opening AppRun in vi, am I correct in assuming that if you copy the AppRun file; replace the BIN= line with the path to the executable you want to add and make appropriate revisions the xml file and add a AppIcon.xpm that would work?

The above assumes you\'re adding this to a new folder named for the app

Am I close?

Thanks,

Jerry
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

offroadgeek

  • Administrator
  • Hero Member
  • *****
  • Posts: 1419
    • View Profile
    • https://www.oesf.org
gimp icon?
« Reply #3 on: December 09, 2003, 09:48:25 pm »
Quote
In looking at the help doc and then opening AppRun in vi, am I correct in assuming that if you copy the AppRun file; replace the BIN= line with the path to the executable you want to add and make appropriate revisions the xml file and add a AppIcon.xpm that would work?

The above assumes you\'re adding this to a new folder named for the app

Am I close?

Thanks,

Jerry

jerry - what you described there woked for me.  which is great, I can now launch gimp via an icon in the apps directory    

last question though, where do i get the appropriate AppIcon.xpm?  I used mc to do a search, but nothing turned up for gimp... maybe I\'ll look for one on my suse box.

thanks for the help!

offroadgeek
Search the OESF Wiki
C1000 w/Cacko 1.23 beta (from Streamline) / 760 pdaxrom rc9 / 6000L (thanks Santa's elf!) / 5500 - OZ 3.3.5 / SIMpad SL4
1GB, 256mb SanDisk CF / 2x 1GB, 512mb, 256mb, 128mb SanDisk SD
Ambicom WL100C-CF wifi / Socket 56k CF modem / AmbiCom BT2000-CF (x2)
Pocketop keyboard, Piel Frama case (1000 & 5500), PDAir case (760 & 1000)
sip:536093@fwd.pulver.com
| OESF | ELSI | Zaurus User Group | ZaurusThemes |