Author Topic: Sharp Camera Ce-ag06  (Read 4984 times)

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Sharp Camera Ce-ag06
« Reply #15 on: January 06, 2005, 12:46:20 pm »
As far as I can tell, it already does more than the sharp package did.

edit :Off for a sip account and a test of vid conferencing on kphone. very very cool
« Last Edit: January 07, 2005, 06:08:57 pm by adf »
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

grog

  • Hero Member
  • *****
  • Posts: 692
    • View Profile
    • http://
Sharp Camera Ce-ag06
« Reply #16 on: January 12, 2005, 02:48:49 pm »
Don't mean to open old wounds, but it seems I'm back at square one again. I had to reinstall OZ & now when trying to reinstall the camera support I get an error:
Code: [Select]
root@poodle:/mnt/card/Install_Files# ipkg install sharp-camera-support_2.4.18-rmk7-pxa3-embedix-r4_poodle.ipk
Clearing state_want and state_flag for pkg=sharp-camera-support (arch_priority=0 flag=16 want=2)
Cannot find package sharp-camera-support.
Check the spelling or perhaps run 'ipkg update'
An error ocurred, return value: 4.
It worked fine before. Could I be missing something else?
GROG!

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
Sharp Camera Ce-ag06
« Reply #17 on: January 12, 2005, 03:08:45 pm »
sharp-camera-support is not in the feed. they're @ vanille.de/temp. Download the proper package for your system and ipkg install it. Restart pcmcia and insert the card.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

grog

  • Hero Member
  • *****
  • Posts: 692
    • View Profile
    • http://
Sharp Camera Ce-ag06
« Reply #18 on: January 12, 2005, 03:38:11 pm »
Quote
sharp-camera-support is not in the feed. they're @ vanille.de/temp. Download the proper package for your system and ipkg install it. Restart pcmcia and insert the card.
I did d/l the package from your fine temp directory originally. Just for the heck of it I just re-downloaded it again & tried to install it, same error. The only thing I don't know what to do is to 'restart pcmcia'? I removed my wireless card & inserted the camera (it came up as an unrecognized card) & tried again, no diff.

I worked for me before I reinstalled OZ 3.5.2 & I don't think I've done anything different.
GROG!

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
Sharp Camera Ce-ag06
« Reply #19 on: January 12, 2005, 06:34:23 pm »
One last idea: You have to install files in your local directory with prepending ./ - otherwise ipkg searches the feeds (where it's not found, of course).
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

grog

  • Hero Member
  • *****
  • Posts: 692
    • View Profile
    • http://
Sharp Camera Ce-ag06
« Reply #20 on: January 12, 2005, 07:49:42 pm »
Quote
One last idea: You have to install files in your local directory with prepending ./ - otherwise ipkg searches the feeds (where it's not found, of course).
Tried that too, same ;^<. This is really frustrating. It worked before, why not now? I had --force-depends installed opie-camera at some time, so I tried removing it then installing the camera support. same. tried installing it with ipkg and with the package manager, no difference.

I tried using ipkg pointed at the web site instead of locally. no diff. Then I turned on all the options in package manager & saved the debug output. make any difference?
Code: [Select]
      /mnt/card/Install_Files/sharp-camera-support_2.4.18-rmk7-pxa3-embedix-r4_poodle.ipk

Press the start button to begin.

loading conf file /etc/ipkg.conf
Package dviviewer version 1.0.2 has no architecture specified, defaulting to arm.
pkg_info_preinstall_check: updating arch priority for each package
Clearing state_want and state_flag for pkg=sharp-camera-support (arch_priority=0 flag=16 want=2)
pkg_info_preinstall_check: update file owner list
best installation candidate for sharp-camera-support
 adding sharp-camera-support to providers
  sharp-camera-support arch=poodle arch_priority=0 constraint=1
Cannot find package sharp-camera-support.
Check the spelling or perhaps run 'ipkg update'
Configuring unpacked packages
An error ocurred, return value: 4.
hash_table[pkg-hash] n_buckets=1423 n_elements=3194 max_conflicts=9 n_conflicts=957
hash_table[file-hash] n_buckets=1423 n_elements=1639 max_conflicts=6 n_conflicts=461
hash_table[obs-file-hash] n_buckets=1423 n_elements=0 max_conflicts=0 n_conflicts=0
Does any of that make any difference?
GROG!

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
Sharp Camera Ce-ag06
« Reply #21 on: January 12, 2005, 07:59:49 pm »
Does /etc/ipkg/arch.conf contain poodle?
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

grog

  • Hero Member
  • *****
  • Posts: 692
    • View Profile
    • http://
Sharp Camera Ce-ag06
« Reply #22 on: January 12, 2005, 10:25:58 pm »
Quote
Does /etc/ipkg/arch.conf contain poodle?
Interesting. There is *nothing* under /etc/ipkg/. Could that be the problem? What file(s) are supposed to be there besides arch.conf, and what should they contain?
GROG!

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
Sharp Camera Ce-ag06
« Reply #23 on: January 13, 2005, 08:24:04 am »
Just arch.conf. On your system it should read:

Code: [Select]
arch all 1
arch any 1
arch noarch 1
arch arm 10
arch poodle 20
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

grog

  • Hero Member
  • *****
  • Posts: 692
    • View Profile
    • http://
Sharp Camera Ce-ag06
« Reply #24 on: January 13, 2005, 10:31:05 am »
Quote
Just arch.conf. On your system it should read:

Code: [Select]
arch all 1
arch any 1
arch noarch 1
arch arm 10
arch poodle 20
EUREKA!! That did it. Now I wonder why that file was missing in the first place? But hey, life goes on.

Thanks a bunch, Mickey.
GROG!