Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - m3xican

Pages: 1 [2]
16
Italy / Problema Connessione Usb/linux
« on: June 20, 2005, 04:49:40 am »
Salve, ho postato già questa richiesta di aiuto in 5x00 General discussions, ma la riposto qui in italiano per aumentare la speranza che qualcuno mi aiuti...

Il problema è il seguente, in pratica utilizzando il cradle usb dello Z non riesco a connettermi nè dal pc allo Z nè dallo Z al pc (o a internet).
L'unica cosa che sono riuscito ad ottenere è pingare lo Z dal pc (divertente, ma poco utile...  ).

Lo Z è riconosciuto perfettamente da hotplug (utilizzo Linux Slackware 10.0), e su di esso gira un sshd, funzionante (ci si riesce a connettere dallo Z stesso), ma non accedibile dall'esterno.
Ogni tentativo di connessione mi viene rifiutato, eppure sullo Z ho configurato sia inetd.conf che hosts.allow per accettare richieste da chiunque.
Ovviamente sullo Z sono aperte anche le porte per effettuare FTP (4242, 4243), ma ogni tentativo di connessione porta sempre allo stesso fallimento...  

Qualcuno può aiutarmi?

17
5x00 General discussions / Usb/linux Connection Problems...
« on: June 18, 2005, 10:37:21 am »
Quote
You're pinging the Z from itself?
No, I'm pinging the Z from my pc, I have connected to ssh from the Z itself (To test if sshd works).

Quote
What does ifconfig show on your PC?
I obtain this:
Quote
usb0      Link encap:Ethernet  HWaddr 46:8F:DE:4E:3A:4E
          inet addr:192.168.129.201  Bcast:192.168.129.255  Mask:255.255.255.255
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

18
Italy / Salve
« on: June 18, 2005, 07:16:15 am »
Salve,

da pochi giorni sono possessore di uno Z SL-5500, attualmente ho un pò di problemi di configurazione, ma spero di risolverli presto (se qualcuno mi vuole aiutare può partecipare alla discussione linkata) e di utilizzare a pieno questo fantastico PDA.

Posto per salutare la comunità (che purtroppo mi sembra molto esigua...) e per chiedere se in italia esiste un qualche sito di riferimento per lo Z.

A presto.

19
5x00 General discussions / Usb/linux Connection Problems...
« on: June 18, 2005, 07:11:01 am »
Hi... I'm loosing my mind, so I hope that someone here could help me!  

I have a SL-5500 with Opie 0.9.3-snapshot - OZ 3.2 - kernel 2.4.6-rmk1-np2-embed.

I can't connect to my Z from Linux (Slackware 10.0) neither connect to my pc from Z.

My Linux box recognizes the Z when I put it into the cradle:
Quote
hub.c: new USB device 00:0d.0-1, assigned address 2
usb.c: USB device 2 (vend/prod 0x4dd/0x8004) is not claimed by any active driver.
usb.c: registered new driver acm
acm.c: v0.21:USB Abstract Control Model driver for USB modems and ISDN adapters
usb.c: registered new driver usbnet
usb0: register usbnet usb-00:0d.0-1, Sharp Zaurus SL-5x00

I set the usb interface with:
Quote
ifconfig usb0 192.168.129.201 netmask 255.255.255.255 up
(note: if I set usb0 to 192.168.129.1 how I have read on several HOWTO nothing works )
obtaining:
Quote
usb0      Link encap:Ethernet  HWaddr 46:8F:DE:4E:3A:4E
          inet addr:192.168.129.201  Bcast:192.168.129.255  Mask:255.255.255.255
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0   TX bytes:0 (0.0
and I can ping the Z
Quote
bash-2.05b# ping 192.168.129.201
PING 192.168.129.201 (192.168.129.201) 56(84) bytes of data.
64 bytes from 192.168.129.201: icmp_seq=1 ttl=64 time=0.060 ms
64 bytes from 192.168.129.201: icmp_seq=2 ttl=64 time=0.050 ms

--- 192.168.129.201 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.050/0.055/0.060/0.005 ms
But I can't have any kind of connection on it.

On the Z is running a ssh daemon, Z can connect to itself (at least this...), but no connection is possible from the pc.

I have followed the connecting to a linux pc over USB HOWTO, but nothing (except ping from pc) works...

Any suggestions?

Pages: 1 [2]