Author Topic: Kernel Panic  (Read 1360 times)

HearWa

  • Newbie
  • *
  • Posts: 28
    • View Profile
Kernel Panic
« on: March 07, 2005, 06:57:18 pm »
So, I ran out and bought a CF card to flash my Zaurus SL-5500. I followed the flashing directions perfectly (including checking checksums & taking the card out once I finish flashing), and apparently it worked but with only one small problem. Kernel panic.

The first errors I begin to see are something like the following:
(stuff that I can't read because it dissapears too quickly)

About 50 of these:
jffs2_scan_eraseblock(): magic bitmask 0x1986 not found at [address]

Then about 50 of these:
Inode #[number] was a directory with children - removing those too...

Then, the dreaded:
VFS: Mounted root (jffs2 filesystem) readonly.
Freeing init memory: 80k
Kernel panic: no init found. Try passing init=option to kernel.

So apparently the initrd.bin file isn't on my cf card? I'll have to get a card reader/writer now. :S

This isn't what you would call a "brick" is it? I can still flash it and such.
« Last Edit: March 07, 2005, 06:58:57 pm by HearWa »
Sharp Zaurus SL-5500 +
Sanded (600 grit) and polished (RB-538) to be black +
Open Zaurus 3.5.2, Opie-image (64-0) +
Sandisk 128MB SD Card, Verbatim 128MB CF Card +
10 Base Ethernet Card, 802.11b Wireless CF Card +
Generic leather PDA case =
One happy geek!

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Kernel Panic
« Reply #1 on: March 08, 2005, 08:02:10 am »
Yes it can still flash.

Check the md5sums of the initrd.bin & zImage before you go again.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva