Author Topic: Broken Sd Slot Thingy...  (Read 1945 times)

bkudria

  • Jr. Member
  • **
  • Posts: 66
    • View Profile
Broken Sd Slot Thingy...
« on: May 04, 2005, 06:30:30 pm »
I have come to the conclusion that my SD slot thingamajig is broken, so I recently took my Z (a 5600) apart to take a look at the SD slot.  Everything looked fine (except for the fact that I dropped and lost the little metal pin in the slot, and now SD cards get stuck in the slot) on the surface.  So, my next step is to try and replace the whole SD circuit board thing.  Does anyone have any idea if I can take the circuit board from a 5600, or a 5500, and just plug it in?  Would that work?  Or should I send it in to Sharp for repair?  Will they replace it?  If so, who do I contact...and do I have to know how to speak Japanese?  Thanks!

bkudria

  • Jr. Member
  • **
  • Posts: 66
    • View Profile
Broken Sd Slot Thingy...
« Reply #1 on: May 14, 2005, 04:10:05 pm »
No one has *any* idea, then?

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Broken Sd Slot Thingy...
« Reply #2 on: May 15, 2005, 11:06:15 am »
The board from a 5500 won't work as the board itself controls the port on the 5500, replacing it with a working one from a 5600 would be a better bet, however I was under the impression that the PXA processors handled the SD slot themselves, perhaps it's just a broken solder joint or something like that?

I'd look carefully at some kernel output to make sure it isn't something more basic.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

bkudria

  • Jr. Member
  • **
  • Posts: 66
    • View Profile
Broken Sd Slot Thingy...
« Reply #3 on: May 16, 2005, 06:12:12 pm »
Ok..well, maybe you could provide more insight if you look at the thread where I described the problem in detail...take a look:

https://www.oesf.org/forums/index.php?showtopic=9366&hl=

*Any* help is appreciated.
I'll also open it up and look for physical defects.  The pins are very clean.

Thanks!

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Broken Sd Slot Thingy...
« Reply #4 on: May 17, 2005, 05:21:50 am »
Have you looked into where those messages are generated - it could give you an idea of what exactly the problem might be - I'm thinking a connection might have failed somewhere, if you can look in the kernel source, you might be able to work out whether the card is detected, etc., and therefore narrow down which connection, etc.

Anyway, I'm just flailing wildly now, I really don't know.

Sorry,


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

bkudria

  • Jr. Member
  • **
  • Posts: 66
    • View Profile
Broken Sd Slot Thingy...
« Reply #5 on: May 17, 2005, 08:28:40 am »
Well, I guess I could take a look...but isn't the Sharp SD/MMC module closed?  Thanks for the advice, though.

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Broken Sd Slot Thingy...
« Reply #6 on: May 17, 2005, 08:51:45 am »
You said had a 5600 (which means the processor controls the SD slot), I forgot that 2.6 isn't up and running on it yet, my mistake.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva