Author Topic: Installing Opie  (Read 5699 times)

Hellmark

  • Newbie
  • *
  • Posts: 14
    • View Profile
Installing Opie
« Reply #15 on: September 01, 2005, 12:29:47 pm »
It does it right after it says its gonna load Opie.

And this is right after I'm loading with the stock 3.5.3 kernel. I've never got to where I could upgrade to the new one yet.
« Last Edit: September 01, 2005, 12:30:56 pm by Hellmark »

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Installing Opie
« Reply #16 on: September 01, 2005, 01:11:16 pm »
Actually you could update the kernel now; I presume you drop to a command prompt when Opie fails to start (I do wonder why that happens though - very odd).

You can edit ipkg.conf and run ipkg upgrade as I'd have recommended you did this from the terminal anyway even if you had Opie running.

Regarding the Opie failure - try running the commands in /etc/init.d/opie by hand to see where it fails (or run syslogd, then use logread to see what it has to say),


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

Hellmark

  • Newbie
  • *
  • Posts: 14
    • View Profile
Installing Opie
« Reply #17 on: September 01, 2005, 01:33:06 pm »
Got it working. For shits and grins I flashed with the last Sharp ROM and it said that there was an error with part of the file system, and asked to repair it. I let it repair it. After that I immediately reflashed back to OZ with opie and it flashed faster, plus booted into opie without a problem. Also, it looks as if the partition on my SD card is dorked up. Oh well, this entire experience is giving me the chance to switch to a 64/0 setup, and have the SD card formatted to EXT2.

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Installing Opie
« Reply #18 on: September 01, 2005, 03:19:31 pm »
Cool, glad you got it sorted.

Do make sure you flash the updated kernel though (upgrade the kernel modules then just place the zImage on its own on your CF card and flash as usual).


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva