Author Topic: Pdaxrom Rc11 For Pxa Devices  (Read 34235 times)

albertr

  • Hero Member
  • *****
  • Posts: 535
    • View Profile
    • http://
Pdaxrom Rc11 For Pxa Devices
« Reply #90 on: October 06, 2005, 11:38:35 am »
There's no need in a new ide-cs module. I believe sometime along the way, the module name was changed from ide_cs to ide-cs. But you still seem to be using old pcmcia config files which were not updated to reflect name change. Just grep for "ide_cs" in /etc/pcmcia/ and replace it with "ide-cs".
-albertr

offthefront

  • Newbie
  • *
  • Posts: 26
    • View Profile
    • http://
Pdaxrom Rc11 For Pxa Devices
« Reply #91 on: October 06, 2005, 12:22:00 pm »
Quote
There's no need in a new ide-cs module. I believe sometime along the way, the module name was changed from ide_cs to ide-cs. But you still seem to be using old pcmcia config files which were not updated to reflect name change. Just grep for "ide_cs" in /etc/pcmcia/ and replace it with "ide-cs".
-albertr
[div align=\"right\"][a href=\"index.php?act=findpost&pid=98406\"][{POST_SNAPBACK}][/a][/div]

Cheers albertr. That did the trick. I copied /etc/pcmcia/config across when I upgraded from RC10 because of my wi-fi card definition. I've edited config now for ide_cs and it works.

Thanks
Sue.

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
Pdaxrom Rc11 For Pxa Devices
« Reply #92 on: October 07, 2005, 04:56:02 am »
or you can add patch to kernel which will rename ide-cs to ide_cs like we did in OZ kernels.
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

hasues

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • http://twitter.com/hasues
Pdaxrom Rc11 For Pxa Devices
« Reply #93 on: October 16, 2005, 03:35:04 am »
Greets..
  I have a 6000L.  One thing I have noticed is that eventually, I can suspend the ROM and when I attempt to resume, the system becomes available, but it's as if the interface isn't responding.  I mean, I can move my mouse around the screen, but it does not allow me to click anything.  The keypad will not allow input either.  I noticed that the time and date reset as well, even after I have reset it.  I read about loading up embedix-utils, but those are already on my system.  I'm able to continue to SSH into the system, but I thought I would bring it to someone's attention.  I am using the Matchbox display manager as well.  This is for ROM RC11.  It does look really good, however.

If I kill the xterm that was open from a remote SSH session, that changed the cursor to looking regular, but I was still unable to make any input.  I would also like to add that I had modified the system's clock at some point as well before suspending.

Haz
« Last Edit: October 16, 2005, 03:41:59 am by hasues »

gromituk

  • Full Member
  • ***
  • Posts: 207
    • View Profile
Pdaxrom Rc11 For Pxa Devices
« Reply #94 on: October 17, 2005, 08:22:15 am »
This is a long-standing problem covering all models, which is discussed in places like here.  I think it would be really useful if it could be fixed, because it does the ROM no favours at all.

g33k

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Pdaxrom Rc11 For Pxa Devices
« Reply #95 on: October 19, 2005, 04:00:29 pm »
Regarding VNCviewer - when I attempt to execute it, I get

"error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory"

FINDing from root confirms that this file is not present in my filesystem.

I'm running RC11 on a C860.

Gorth

  • Newbie
  • *
  • Posts: 15
    • View Profile
    • http://
Pdaxrom Rc11 For Pxa Devices
« Reply #96 on: October 19, 2005, 10:11:13 pm »
"I think it would be really useful if it could be fixed, because it does the ROM no favours at all."
For the sl-6000 especially this is a critical issue.  With the clamshell, the workaround is to set the time, exit to console and suspend using the power button.  Since power button suspend does not work on the 6000, there is no way to live with X that I have discovered.  The inability to keep the time set and resume from a suspend in X has forced me to temporarily abandon pdaxrom on the sl-6000.  
Has anyone come up with a work-around or solution?

trichmon

  • Full Member
  • ***
  • Posts: 148
    • View Profile
Pdaxrom Rc11 For Pxa Devices
« Reply #97 on: October 20, 2005, 12:29:34 am »
Well as for the time thing, somewhere in this forum it tells you how to fix it.  You have to reinstall a package, Im sorry I dont remember what it was.  It had to do with setting the hardware clock (hwclock binary).  The script from the new install calls a file that is not installed.  Sorry i wish i could remember the package name.  As for resume, I have had no problems with suspend/resume, with the exception of alarms.  There is a thread here that has a fix for alarms and kopi that seems to work on everything but the 6000.  Im hoping to see an RC 12 test for the 6000 soon, and hoping even more that it fixes both of these issues.  Then I can make pdaxrom my daily rom.  

Todd
again thanks pdaxrom for your effort!
SL-6000l running pdaXrom RC12 icewm + rox
Targus keyboard
Trendnet cf 10/100 ethernet
Linksys CF wireless
Sandisk 256mb SD card
Lexar 1gig SD card
SL-5500 running zynergy rom

werner

  • Newbie
  • *
  • Posts: 3
    • View Profile
Pdaxrom Rc11 For Pxa Devices
« Reply #98 on: October 21, 2005, 01:49:56 am »
Hmm, rc11 supports 1000 and 3100, but no 3000 ?
Is it because nobody has actually tried it yet, or is
there anything more fundamental wrong with it ?

- Werner

Quickfry

  • Newbie
  • *
  • Posts: 46
    • View Profile
    • http://www.quickfry.com
Pdaxrom Rc11 For Pxa Devices
« Reply #99 on: October 21, 2005, 12:15:51 pm »
I'm guessing because 1000 and 3100 both have 128 internal flash, and 3000 has only 64

werner

  • Newbie
  • *
  • Posts: 3
    • View Profile
Pdaxrom Rc11 For Pxa Devices
« Reply #100 on: October 21, 2005, 06:54:37 pm »
Quote
and 3000 has only 64

16 MB, actually. Hmm, I thought pdaXrom already supported split
storage (or plain disk) installation. So it doesn't ?

It's a pity that we're still stuck at 2.4. If a 2.6 kernel would run
usefully on the 3000, I could just port kboot, run everything off
the disk, and never worry about the Flash again.

- Werner

jcabrer

  • Full Member
  • ***
  • Posts: 161
    • View Profile
Pdaxrom Rc11 For Pxa Devices
« Reply #101 on: October 26, 2005, 06:20:16 pm »
Quote
Well as for the time thing, somewhere in this forum it tells you how to fix it.  You have to reinstall a package, Im sorry I dont remember what it was.  It had to do with setting the hardware clock (hwclock binary).  The script from the new install calls a file that is not installed.  Sorry i wish i could remember the package name.  As for resume, I have had no problems with suspend/resume, with the exception of alarms.  There is a thread here that has a fix for alarms and kopi that seems to work on everything but the 6000.  Im hoping to see an RC 12 test for the 6000 soon, and hoping even more that it fixes both of these issues.  Then I can make pdaxrom my daily rom.   

Todd
again thanks pdaxrom for your effort!
[div align=\"right\"][a href=\"index.php?act=findpost&pid=100112\"][{POST_SNAPBACK}][/a][/div]
I believe the package you are refering to is embedix-utils

ipkg install embedix-utils

this fixes the missing hwclock problem.
Sharp SL-C3100 - pdaXrom Beta 3
Sharp SL-6000L - pdaXrom Beta 1