Author Topic: Cacko Rom 1.23 Is Released  (Read 197465 times)

zmike

  • Jr. Member
  • **
  • Posts: 77
    • View Profile
    • http://
Cacko Rom 1.23 Is Released
« Reply #15 on: November 04, 2005, 09:07:14 am »
Just a quick question for your early adopters - Does TextMaker-2002 run under the 1.23 ROM?
SLC860, Zubuntu, Symbol Spectrum24 Wireless CF, 4GB SD Card

stbrock

  • Full Member
  • ***
  • Posts: 149
    • View Profile
    • http://
Cacko Rom 1.23 Is Released
« Reply #16 on: November 04, 2005, 10:04:18 am »
Quote
Just a quick question for your early adopters - Does TextMaker-2002 run under the 1.23 ROM?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102245\"][{POST_SNAPBACK}][/a][/div]

I got a segmentation fault at the very end of the ipkg installation, but ignored it and TextMaker has been running fine after a reboot. It is important to install the Hi-Res update ipkg (available at the TextMaker web site) or TextMaker may be erratic or hang, at least on a C1000.

All in all, I've found 1.23 highly reliable and polished, and with Meanie's work there are now very powerful addons that install easily, well configured. Hats off to Maslovsky!

wowo123

  • Jr. Member
  • **
  • Posts: 81
    • View Profile
    • http://
Cacko Rom 1.23 Is Released
« Reply #17 on: November 04, 2005, 11:07:39 am »
I have just installed the new ROM on my C860 and like it very much. Seems to run a little bit faster then 1.22.
Finally I created a NAND-Image and restored the 1.22-version to backup some additional data. When now trying to restore the NAND-image of 1.23, I always get Restore ...failed format error. I think the problem is the new 32MB root partition. I tried bams suggestion and did a factory restore in the service menu, but same error. So what's the exact procedure for a working NAND-restore?

gsgmx

  • Newbie
  • *
  • Posts: 32
    • View Profile
Cacko Rom 1.23 Is Released
« Reply #18 on: November 04, 2005, 04:07:13 pm »
Hi,

made yesterday the switch to 1.23 on my c1000.

Great!  Thanks alot Anton.


One point i can´Żąt get to run as expected is iptables.
Neither by hand myself nor with the simple snowfence.
Generally it works, but missing is the iptables state module.
By design?

Code: [Select]
# iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables v1.2.11: Couldn't load match `state':/usr/lib/iptables/libipt_state.so: cannot open shared object file: No such file or directory
 
Try `iptables -h' or 'iptables --help' for more information.  
These modules can be found:
Code: [Select]
# ls -al /usr/lib/iptables/
drwxr-xr-x    2 root     root            0 Nov  4 13:41 .
drwxr-xr-x    8 root     root            0 Nov  4 13:41 ..
lrwxrwxrwx    1 root     root           36 Nov  4 13:41 libipt_DNAT.so -> /usr/lib.rom/iptables/libipt_DNAT.so
lrwxrwxrwx    1 root     root           42 Nov  4 13:41 libipt_MASQUERADE.so -> /usr/lib.rom/iptables/libipt_MASQUERADE.so
lrwxrwxrwx    1 root     root           40 Nov  4 13:41 libipt_REDIRECT.so -> /usr/lib.rom/iptables/libipt_REDIRECT.so
lrwxrwxrwx    1 root     root           40 Nov  4 13:41 libipt_standard.so -> /usr/lib.rom/iptables/libipt_standard.so
lrwxrwxrwx    1 root     root           35 Nov  4 13:41 libipt_tcp.so -> /usr/lib.rom/iptables/libipt_tcp.so
lrwxrwxrwx    1 root     root           35 Nov  4 13:41 libipt_udp.so -> /usr/lib.rom/iptables/libipt_udp.so                                          

I checked the different iptables ipks from the feed, nothing there neiher.

Could i compile the missing module myself?  If so -- sorry -- how?


Like preinstalled Opera very much.  On original i had instelled 7.55 now we have 7.25.  Does anybody know which difference exists between these two?


TiA
Georg
SL-C1000 with Cacko 1.23
DLlink CF WiFi
Socket CF Ethernet

fry

  • Newbie
  • *
  • Posts: 5
    • View Profile
Cacko Rom 1.23 Is Released
« Reply #19 on: November 05, 2005, 09:22:26 pm »
I'm a first time user of Cacko rom (Cacko 1.23 full) - I installed it a couple of days ago on my C1000 which is also my first Z.
Below are my first impressions - at length.


The installation itself worked without a hitch (32M root, clean user are etc) and I kept no trace of the previous rom (trisoft/sharp) or apps on the SD card.  The 1G SD card (SanDisk) is permanently kept in the machine.

For the apps I used the mirror feed from http://web.mol.ru/~zaurus/feed/.

I couldn't connect w the WiFi card (Pretec CompactWLAN 802.11b). The card took a very long time to initialize but only sometimes became usable; not very often. This card works almost flawlessly w the sharp rom: I use it w Kismet, Opera etc.
That's why I made a feed directory on the SD card & put all I wanted there.

The apps install fine (GUI or cmd line). I used only apps from this feed: opie reader, kismet, kismet-qt, wellenreiter etc. They worked ok.  I installed only a few apps not mentioned here on the SD card - most of them & all libs in the main memory.

Wellenreiter could use the card every time without problems but it would only start from the cmd line - never from the icon. If left on for a long time it would run out of available memory thus needing a reboot. I put the file logs/capture on a usb hdd w powered hub - no problems. The same if no capture was enabled. This may be a wellenreiter specific problem - don't give up reading just yet.

Kismet qt & terminal versions both seemed to run ok as usual.


Now - there was a real problem when I tried to use the machine without the external power, only on battery. I must point out that it wasn't over/underclocked & the battery was always over 75% (75 to 100) charged according to the battery applet.
Backlight at minimum on battery, suspend after 30 min. There was no active screensaver and no network card inserted.

When I removed the external power the screen went blank for a second and come back for two-three seconds only to go blank again by itself sometimes or the first time I would touch a key or the screen. This was repeatable with only opie reader running.
Different things happened after this depending on my actions  :P
- If I plugged the power back in it would resume work "normally" without touching the power button.
- If I pressed the power button briefly it would sometimes flick on for a second or not then go blank again. It would not start anymore from the power button - external power or not. Reboot needed.

Reboot w external power would be ok.
Without it would go blank at the first fullscreen splash or immediately after that when showing the clock. Plug in the power and it would repeat the above.

The only app kept in memory was opie reader. The battery cover was closed & the switch properly set. I checked repeatedly.
I didn't see anybody having this problem yet and I wonder if there is anything one would care to suggest.

As another experiment I restored a full NAND backup made before Cacko install and I'm waiting to see if the problem would appear w the previous sharp rom. I also restored my SD card contents w apps & whatnot. It's been already an hour and everything worked fine through a few suspend resume cycles. I'll play for a while w the network card and see if it causes any problems.

Leaving aside this problem it looks like a very thorough job, thanks Anton.

On another subject: are the Cacko sources available from somewhere w or without  instructions for setting up a development environment?

    TIA,
        Fry
C1000 [From Conics.net]
Sharp - Qtopia (orig)
1G SD SanDisk
Pretec CF 802.11b

wowo123

  • Jr. Member
  • **
  • Posts: 81
    • View Profile
    • http://
Cacko Rom 1.23 Is Released
« Reply #20 on: November 06, 2005, 02:44:49 am »
hallo fry,

the problem with NAND-backup doesn't occur with backups, you made before cacko 1.23-install, but with NAND-restore AFTER installing the new rom. After experiencing that problem, I could restore my old NAND-backup from version 1.22 without problems. But now I'm back to the old version because my backup from 1.23 will not restore
« Last Edit: November 06, 2005, 02:50:33 am by wowo123 »

fry

  • Newbie
  • *
  • Posts: 5
    • View Profile
Cacko Rom 1.23 Is Released
« Reply #21 on: November 06, 2005, 01:28:31 pm »
Quote
... now I'm back to the old version because my backup from 1.23 will not restore ...
 Hi wowo123,

I didn't make any NAND backups while v1.23 was installed so I can't tell if they would restore or not.

With the restored sharp NAND everything works as before - no problems w suspend/restore even if I use the network CF (any mode). Didn't need to reboot since the restore.


One other thing I forgot to mention for v1.23:
The Settings->Netwok->Current tab would only work for less than a second when connected.  It would not refresh any dynamic info; only some of the static text.

    Fry
C1000 [From Conics.net]
Sharp - Qtopia (orig)
1G SD SanDisk
Pretec CF 802.11b

cybersphinx

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
    • http://
Cacko Rom 1.23 Is Released
« Reply #22 on: November 06, 2005, 01:35:52 pm »
Quote
When I removed the external power the screen went blank for a second and come back for two-three seconds only to go blank again by itself sometimes or the first time I would touch a key or the screen. This was repeatable with only opie reader running.
Different things happened after this depending on my actions   
- If I plugged the power back in it would resume work "normally" without touching the power button.
- If I pressed the power button briefly it would sometimes flick on for a second or not then go blank again. It would not start anymore from the power button - external power or not. Reboot needed.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102492\"][{POST_SNAPBACK}][/a][/div]
That's a problem I have also encountered - when you use the lowest brightness setting, sometimes the backlight gets switched off completely. Just use Fn+4 (increase brightness) and you should see something again. Took me a while to figure that out.
« Last Edit: November 06, 2005, 01:40:41 pm by cybersphinx »

cdarek

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • http://
Cacko Rom 1.23 Is Released
« Reply #23 on: November 06, 2005, 04:55:33 pm »
Thank you Anton !!!
Great work again.


Quote
...  Wireless:
...   
    - Socket/Symbol WiFi card is now fully supported via Network Setup
    - New Socket WiFi card (with Agere Hermes II chipset) is supported (OpenKey WEP only)
 ... [div align=\"right\"][a href=\"index.php?act=findpost&pid=101565\"][{POST_SNAPBACK}][/a][/div]


Does the above info mean that I can use my Linksys WCF54G wireless card. I tried to but with no luck - but my experience with wifi on linux is null so it might be the reason.
SL-C760
Cacko ROM 1.23
Transcend SD 1GB
Pretec CF 2GB
Socket rev G Bluetooth CF
Linksys WCF54G Wifi CF
Audiovox RTM-8000 CF

Flandry

  • Jr. Member
  • **
  • Posts: 77
    • View Profile
    • http://
Cacko Rom 1.23 Is Released
« Reply #24 on: November 07, 2005, 12:51:22 am »
Quote
Quote
When I removed the external power the screen went blank for a second and come back for two-three seconds only to go blank again by itself sometimes or the first time I would touch a key or the screen. This was repeatable with only opie reader running.
Different things happened after this depending on my actions   
- If I plugged the power back in it would resume work "normally" without touching the power button.
- If I pressed the power button briefly it would sometimes flick on for a second or not then go blank again. It would not start anymore from the power button - external power or not. Reboot needed.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102492\"][{POST_SNAPBACK}][/a][/div]
That's a problem I have also encountered - when you use the lowest brightness setting, sometimes the backlight gets switched off completely. Just use Fn+4 (increase brightness) and you should see something again. Took me a while to figure that out.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102581\"][{POST_SNAPBACK}][/a][/div]

Yes, that's a well-documented and long-standing problem with Cacko ROM.  I remember it really had me freaked out the first time i encountered it.  Once you're aware of it, it's just a nuisance.

Regarding the sdl lib... does the best version depend on our Zaurus model?  I seem to recall that the new clamshells have a different graphics chip, so i assume that means a different optimized library.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko Rom 1.23 Is Released
« Reply #25 on: November 07, 2005, 03:03:00 am »
Quote
I have just installed the new ROM on my C860 and like it very much. Seems to run a little bit faster then 1.22.
Finally I created a NAND-Image and restored the 1.22-version to backup some additional data. When now trying to restore the NAND-image of 1.23, I always get Restore ...failed format error. I think the problem is the new 32MB root partition. I tried bams suggestion and did a factory restore in the service menu, but same error. So what's the exact procedure for a working NAND-restore?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102274\"][{POST_SNAPBACK}][/a][/div]

Did you try to restore root partition size to the default value?

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko Rom 1.23 Is Released
« Reply #26 on: November 07, 2005, 03:06:07 am »
Quote
Quote
When I removed the external power the screen went blank for a second and come back for two-three seconds only to go blank again by itself sometimes or the first time I would touch a key or the screen. This was repeatable with only opie reader running.
Different things happened after this depending on my actions   
- If I plugged the power back in it would resume work "normally" without touching the power button.
- If I pressed the power button briefly it would sometimes flick on for a second or not then go blank again. It would not start anymore from the power button - external power or not. Reboot needed.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102492\"][{POST_SNAPBACK}][/a][/div]
That's a problem I have also encountered - when you use the lowest brightness setting, sometimes the backlight gets switched off completely. Just use Fn+4 (increase brightness) and you should see something again. Took me a while to figure that out.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102581\"][{POST_SNAPBACK}][/a][/div]

It would have taken you much less time if you've read Cacko FAQ

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko Rom 1.23 Is Released
« Reply #27 on: November 07, 2005, 03:08:54 am »
Quote
Thank you Anton !!!
Great work again.


Quote
...  Wireless:
...   
    - Socket/Symbol WiFi card is now fully supported via Network Setup
    - New Socket WiFi card (with Agere Hermes II chipset) is supported (OpenKey WEP only)
 ... [div align=\"right\"][a href=\"index.php?act=findpost&pid=101565\"][{POST_SNAPBACK}][/a][/div]


Does the above info mean that I can use my Linksys WCF54G wireless card. I tried to but with no luck - but my experience with wifi on linux is null so it might be the reason.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102612\"][{POST_SNAPBACK}][/a][/div]

What chipset does your Linksys WCF54G card use? If it's II.5 - it's NOT supported, the driver only with I and II revisions.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko Rom 1.23 Is Released
« Reply #28 on: November 07, 2005, 03:12:16 am »
Quote
On another subject: are the Cacko sources available from somewhere w or without  instructions for setting up a development environment?

Actualy there is no such thing as "Cacko ROM sources". Sharp applications are used as is and they don't come with the source code. Third-party applications are typicaly GPL or freeware and their sources can be found elsewhere. Application that I wrote myself and also GPL and if you need particular sources for any application - just let me know - I sometimes may just forget to upload them..

You can use standard Sharp SDK to build applications for Cacko ROM (as well as for any Sharp-based ROM)

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko Rom 1.23 Is Released
« Reply #29 on: November 07, 2005, 03:14:41 am »
Quote
Regarding the sdl lib... does the best version depend on our Zaurus model?  I seem to recall that the new clamshells have a different graphics chip, so i assume that means a different optimized library.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=102641\"][{POST_SNAPBACK}][/a][/div]

You need to install libsdl_1.2.5-bvdd... from the Cacko feed for CxK models or libsdl_1.2.5-slzaurus20041025 for C7x0