Author Topic: Ssh(dropbear) Not Working?  (Read 1595 times)

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
Ssh(dropbear) Not Working?
« on: January 19, 2006, 01:02:21 am »
I'm running 3.5.4RC/Opie on my 5500. When I try to ssh in via my usb0 connection, I get the following error
Code: [Select]
The authenticity of host '192.168.129.1 (192.168.129.1)' can't be established.
RSA key fingerprint is 0f:0e:47:2f:ff:e5:d7:c1:51:8f:73:c3:e0:86:b9:da.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.129.1' (RSA) to the list of known hosts.
Permission denied (publickey).
The first part is pretty standart, it's the last line that bothers me. Is it my settings, or is it the dropbear client? Do I need to reflash?
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
Ssh(dropbear) Not Working?
« Reply #1 on: January 19, 2006, 03:07:50 am »
You need to set password for root on device first. Default password is empty and dropbear refuse to connect.
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
Ssh(dropbear) Not Working?
« Reply #2 on: January 19, 2006, 03:36:19 pm »
on the zaurus? ok, that makes sense. Thanks
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
Ssh(dropbear) Not Working?
« Reply #3 on: January 23, 2006, 12:51:25 am »
this fixed it, thanks again.
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux