Author Topic: 1.1.0beta2 For Cxxxx  (Read 84368 times)

km2783

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #45 on: March 16, 2006, 10:53:19 am »
Quote
did you try:

Code: [Select]
/etc/sdcontrol eject
/etc/sdcontrol insert
?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=118835\"][{POST_SNAPBACK}][/a][/div]

I tried insert.  It just hangs there, doing nothing, just like:

Code: [Select]
mount /dev/mmcda /mnt/card
mount /dev/mmcda1 /mnt/card
mount /dev/mmcda2 /mnt/card
SL-C3100 - pdaXii3 5.4.9

km2783

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #46 on: March 16, 2006, 11:08:14 am »
I wonder if there is an issue with suspending somehow?  It is like instead of going into suspend, it stayed on all night.  Because my battery is drained, and under Beta1 I would leave it in suspend for days sometimes, and never had any issues.  This morning, I had to leave it plugged in for a few minutes like I said previously, and when I got back into X, the battery applet showed 60% power.  Then it plumetted, the backlight went off, and I had to plug it back in.

I used the menu to suspend, like I do 99% of the time.

But back to the 4GB card, I can't get it to recognize anything.  But I am willing to keep trying if anyone has any more suggestions.

My Tungsten T3 did not recognize the card, either, but I believe that is just because it is an older unit.  Supposedly w/ out some patch I did not get, it won't read cards larger than 256MB, though it read my 512 just fine.

I will try to pick up an SD card reader to see if windows XP can recognize it.
« Last Edit: March 16, 2006, 11:11:50 am by km2783 »
SL-C3100 - pdaXii3 5.4.9

ULhume

  • Newbie
  • *
  • Posts: 38
    • View Profile
    • http://artisan.karma-lab.net
1.1.0beta2 For Cxxxx
« Reply #47 on: March 16, 2006, 11:15:14 am »
I still have suspend/resume problem with my SL-C1000. It's not always but really often. When I let power management suspend the device, i am not able to restart it again. I have sometime a picture for 1 second and down again... Any idea ?

km2783

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #48 on: March 16, 2006, 04:31:03 pm »
update:

Picked up a card reader at lunch.  Windows 2000 says...

the frickin' thing is not formatted  

but alas, I do not have the authority to format at work.  so I will try again when I get home since i can't mount it under pdaxrom to format it under linux
« Last Edit: March 16, 2006, 04:31:54 pm by km2783 »
SL-C3100 - pdaXii3 5.4.9

0xDEADBEEF

  • Jr. Member
  • **
  • Posts: 52
    • View Profile
1.1.0beta2 For Cxxxx
« Reply #49 on: March 16, 2006, 04:46:30 pm »
Quote
update:

Picked up a card reader at lunch.  Windows 2000 says...

the frickin' thing is not formatted  

but alas, I do not have the authority to format at work.  so I will try again when I get home since i can't mount it under pdaxrom to format it under linux
[div align=\"right\"][a href=\"index.php?act=findpost&pid=118917\"][{POST_SNAPBACK}][/a][/div]

Windows may say it is unformatted becuase it cannot read it either.
In linux first you format then mount.

try
dd if=/dev/mmcda of=firstblk.bin count=1 bs=512
it should read first sector from the device
if it fails it means that the driver or slot cannot read from the card

then
Try running fdisk /dev/mmcda and see if it works
Create a partition table. Create fat32 or ext2 partition.
Then format it (mke2fs, mkdosfs)

km2783

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #50 on: March 16, 2006, 05:06:51 pm »
thanks for the help

every command involving mmcda just sits there with a cursor forever, and w/ out a reset/battery removal, the SD slot is forever tied up and won't even recognize my tried and true 512MB card.

I do not think it is the card itself, because the latest gamepark will recognize it.
SL-C3100 - pdaXii3 5.4.9

km2783

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #51 on: March 16, 2006, 08:55:40 pm »
According to my home machine running Windows XP the card is formatted FAT32.  This is the only option I am given to format this card with as well.  It was the card reader, I needed to install a driver from the D that came with it before anything in the reader would be recognized, even on my XP machine.


Unrelated, I still don't know why it sits there forever when issuing the "shutdown now" command.
it gets to "Unloading USB modules:" and just sits there, blinking a cursor at me  

Picked up a 160GB hard drive from best buy for $70, plan to shove it into a surprisingly good PC I have laying around and seeing if maybe ext2 or ext3 or something might work better for it.  I guess it is worth a shot.  

i'm bored anyway, what else do I have to do tonight?  but it probably won't happen tonight, my internet connection is not the fastest... but at least it's better than ISDN or dial-up...   I still need the iso files
« Last Edit: March 17, 2006, 10:26:07 am by km2783 »
SL-C3100 - pdaXii3 5.4.9

scheck.r

  • Sr. Member
  • ****
  • Posts: 320
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #52 on: March 20, 2006, 04:56:14 pm »
I don't see any difference when waking up the Z compared to beta1. It still redraws the screen 2 or 3 times amd sometimes it froze while I had a microdrive already inserted.
SL-C1000 from PriceJapan(cheap and very fast shipping) with EA-70 power adapter, iRiver USB Host cable, PDAIR case, pentopia stylus, ultra clear screen-protector from shop.brando.com.hk only $3 for shipping worldwide
4GB Hitachi Microdrive, 1GB Kingston Elite Pro CF, 4GB Transcend 150x SD, Symbol Spectrum 4137 CF WiFi(low power)
PdaXrom pdaxii13 5.4.9 updated with Kkazakov13's feed. I owned a SL-6000L before

john4

  • Newbie
  • *
  • Posts: 41
    • View Profile
1.1.0beta2 For Cxxxx
« Reply #53 on: March 21, 2006, 03:52:30 am »
I feel very disappointed  with pdaXrom development team.

It seems no one would like to solve the CF umount-problem.

Another problem:
Is there someone using C750/7500C can tell me how to make a swapfile under beta2 and fix the cf problem.

DaemonsGR

  • Full Member
  • ***
  • Posts: 237
    • View Profile
1.1.0beta2 For Cxxxx
« Reply #54 on: March 21, 2006, 04:19:17 am »
SWAP:
dd if=/dev/zero of=/mnt/PATH/.swap bs=1M count=64
mkswap /mnt/PATH/.swap
swapon /mnt/PATH/.swap


PS: pdax works more than great on my 3100!!! Thnx
Tasos Varoudis (Tech)
Tasos Varoudis (Architecture)

Zaurus sl-c3100 + Wlan, Lan ,BT ,etc
NOW running... pdaXrom 1.1.0beta3 + OOo + custom apps/setup + debian +.. not yet installed OpenBSD snapshot

WAS:Cacko 1.23 + X/QT + debian

Home-Net
Debian WIFI Router ,OpenBSD Bridge Firewall ,Win 2k Domain Server , :) Sun Fire v120 , :) Gentoo Main Server: Dual PIII

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
1.1.0beta2 For Cxxxx
« Reply #55 on: March 21, 2006, 04:20:51 am »
Quote
here's a fun thing.

After being suspended all night, it won't come back on.  I removed the battery, replaced it, and it still won't come back on  

I can't even get into the service menu   Magical.

The power LED comes on to show the battery is being charged.  That is all.

No power plugged in, I remove the battery for several seconds (at least 5), put it back in, plug in power, hold Ok and press power.  Nothing.  Nothing but tears  

Time for some OESF search engine queries

**edit**

after being plugged in for a few minutes, it turned on  The battery had nearly a full charge, wtf  oh well.

Now I can try it
[div align=\"right\"][a href=\"index.php?act=findpost&pid=118872\"][{POST_SNAPBACK}][/a][/div]

remove the SD - before you suspend - and all problems will be solved. (at least that's what happened to me).

Chero.
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.

km2783

  • Jr. Member
  • **
  • Posts: 71
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #56 on: March 21, 2006, 10:34:03 am »
Quote
Quote
here's a fun thing.

After being suspended all night, it won't come back on.  I removed the battery, replaced it, and it still won't come back on  

I can't even get into the service menu   Magical.

The power LED comes on to show the battery is being charged.  That is all.

No power plugged in, I remove the battery for several seconds (at least 5), put it back in, plug in power, hold Ok and press power.  Nothing.  Nothing but tears  

Time for some OESF search engine queries

**edit**

after being plugged in for a few minutes, it turned on  The battery had nearly a full charge, wtf  oh well.

Now I can try it
[div align=\"right\"][a href=\"index.php?act=findpost&pid=118872\"][{POST_SNAPBACK}][/a][/div]

remove the SD - before you suspend - and all problems will be solved. (at least that's what happened to me).

Chero.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=119536\"][{POST_SNAPBACK}][/a][/div]

I think the problem was due to the sd slot being hung up after not recognizing the 4GB card.  After trynig the 4GB card, the 512MB card would not be recognized, either.

I always leave the 512MB card in the slot and never have issues.
SL-C3100 - pdaXii3 5.4.9

badog

  • Full Member
  • ***
  • Posts: 248
    • View Profile
1.1.0beta2 For Cxxxx
« Reply #57 on: March 26, 2006, 04:29:16 am »
where is beta2 for SL-6000L/W?

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #58 on: March 26, 2006, 11:32:16 am »
Quote
According to my home machine running Windows XP the card is formatted FAT32.  This is the only option I am given to format this card with as well.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=118951\"][{POST_SNAPBACK}][/a][/div]
Sorry to chime in, as I'm using cacko.
As to the 4GB SD card. Anything above 2GB needs to be formatted as FAT32 under windows.
May I suggest someone running pdaXrom, get a 2GB SD card and try it.
A 2GB card will actually be under 2GB in size, so it can be formatted as FAT under windows.
Maybe this would "work" better with the new SD driver.
Then you would know that the 1GB limit of Zaurus has been broken
Jon
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

tahoe1579

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • http://
1.1.0beta2 For Cxxxx
« Reply #59 on: March 29, 2006, 11:44:49 am »
Quote
Quote
According to my home machine running Windows XP the card is formatted FAT32.  This is the only option I am given to format this card with as well.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=118951\"][{POST_SNAPBACK}][/a][/div]
Sorry to chime in, as I'm using cacko.
As to the 4GB SD card. Anything above 2GB needs to be formatted as FAT32 under windows.
May I suggest someone running pdaXrom, get a 2GB SD card and try it.
A 2GB card will actually be under 2GB in size, so it can be formatted as FAT under windows.
Maybe this would "work" better with the new SD driver.
Then you would know that the 1GB limit of Zaurus has been broken
Jon
[div align=\"right\"][a href=\"index.php?act=findpost&pid=120321\"][{POST_SNAPBACK}][/a][/div]

I just joined this forum and after reading everything I can find out there about mounting a 2GB SD
card I still can't get mine to work. I'm running pdaXrom 1.1.0beta2 on my C760, and I can see the
card info in /proc/mmc/host0/card0 but there is no /dev/mmc or /dev/mmcda so I can't actually mount
the card. sdcontrol is looking for /dev/mmcd/disc0/part1. I have tried formating the disk with FAT, FAT32, ext2, ext3 with no changes.

Has anyone else run into this same problem?
Zaurus C760
pdaXrom v1.1.0beta2
Netgear MA701 CF Wifi