Author Topic: Pma400 Sdk And Qtopia 1.7 Sdk Compiling Error  (Read 1979 times)

hp1109

  • Newbie
  • *
  • Posts: 4
    • View Profile
Pma400 Sdk And Qtopia 1.7 Sdk Compiling Error
« on: March 08, 2006, 07:33:06 pm »
I'm tring to build a console app on pma400, and i simply included "audiodevice.h". The following error occured.

arm-linux-g++ -c -pipe -DQWS -fno-exceptions -fno-rtti -Wall -W -O2 -DNO_DEBUG -I/opt/Qtopia/arm/include -o ArchosAudio.o ArchosAudio.cpp
arm-linux-g++  -o ArchosAudio ArchosAudio.o  -L/opt/PMA400/lib -larchos -lcsl -laimaging -L/opt/Qtopia/arm/lib -lqtopia -lqte -lqpe -ljpeg -luuid

/opt/PMA400/lib/libarchos.so: undefined reference to `QExclusiveLock::unlock(QExclusiveLock::Type)'
/opt/PMA400/lib/libarchos.so: undefined reference to `QWSDisplay::fblock'
/opt/PMA400/lib/libarchos.so: undefined reference to 'QExclusiveLock::lock(QExclusiveLock::Type)'

anyone has any idea how this happened. plz help  

Thanks

birdman

  • Newbie
  • *
  • Posts: 22
    • View Profile
Pma400 Sdk And Qtopia 1.7 Sdk Compiling Error
« Reply #1 on: June 10, 2006, 04:18:17 pm »
I cant help you right now but if you view my post "archos pma 430" and answer my questions Then i'll be able to help you once i get mine, thanks, any advice will be apreciated  

lpotter

  • Sr. Member
  • ****
  • Posts: 450
    • View Profile
    • http://qtopia.net
Pma400 Sdk And Qtopia 1.7 Sdk Compiling Error
« Reply #2 on: June 11, 2006, 04:00:16 pm »
you might want to try pulling the libqte and libqpe and friends off the Archos,  and putting them in /opt/Qtopia/arm/lib, replacing the ones that are there.
Software Engineer, Systems Group, MES, Trolltech
irc.freenode.net #qtopia
http://qtopia.net