Author Topic: Scp In 3.5.4rc, Not Working  (Read 1063 times)

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
Scp In 3.5.4rc, Not Working
« on: March 19, 2006, 09:57:06 pm »
I'm trying to upgrade to 3.5.4, and when I try to use the command
Code: [Select]
scp initrd.bin root@exiguitas:initrd.binI get the error
Code: [Select]
sh: scp: not found
lost connection

Suggestions? It's running dropbear if that helps.
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

ant

  • Full Member
  • ***
  • Posts: 167
    • View Profile
    • http://
Scp In 3.5.4rc, Not Working
« Reply #1 on: March 20, 2006, 04:15:53 am »
Quote
I'm trying to upgrade to 3.5.4, and when I try to use the command
Code: [Select]
scp initrd.bin root@exiguitas:initrd.binI get the error
Code: [Select]
sh: scp: not found
lost connection

Suggestions? It's running dropbear if that helps.
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

Dropbear is a "stripped down" version and doesn't contain all ssh beauties: scp, sftp, ...
You need the full openssh suite, splitted here:
[a href=\"http://oz.hentges.net/mirror/oz3.5.4/feed/base/]http://oz.hentges.net/mirror/oz3.5.4/feed/base/[/url]
« Last Edit: March 20, 2006, 06:31:08 am by ant »

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Scp In 3.5.4rc, Not Working
« Reply #2 on: March 20, 2006, 05:13:05 am »
I've had varying degrees of success with different clients.

Winscp works for me with the 3.5.4pre releases that I built.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
Scp In 3.5.4rc, Not Working
« Reply #3 on: March 20, 2006, 09:04:05 am »
the thing is, I don't have a card reader, and I don't have capabilities to transfer over to the CF card, because sftp, and scp aren't there. Does anyone know of any clients for linux that work? I'd rather not have to boot windows to transfer.
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
Scp In 3.5.4rc, Not Working
« Reply #4 on: March 20, 2006, 09:28:45 am »
As you're running opie you could try ftp to port 4242 with root:rootme

Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
Scp In 3.5.4rc, Not Working
« Reply #5 on: March 20, 2006, 09:47:23 am »
Yes, I'm currently running opie. what do you mean root:rootme? Is that the username:password? I'll try that tonight, I'm at school right now.
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
Scp In 3.5.4rc, Not Working
« Reply #6 on: March 20, 2006, 11:47:05 pm »
got it working. Thanks to all, I'm now running 3.5.4 GPE. I must say, I like GPE better than OPIE. Anything like fluxbox for the Z?
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
Scp In 3.5.4rc, Not Working
« Reply #7 on: March 21, 2006, 02:28:41 am »
currently we do not have many window managers - GPE use matchbox and we have xfce in feed (does not know how usable xfce is). E17 for collie is currently unavailable - problems with building.
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.