Author Topic: A Love Letter To The Oz Team  (Read 4690 times)

burned

  • Newbie
  • *
  • Posts: 4
    • View Profile
A Love Letter To The Oz Team
« on: March 20, 2006, 03:52:54 am »
I've been intently following the development of 3.5.4 and just installed it yesterday on my 3.5.3 collie/5500.  What follows is a list of things that are marvellous.

- card manager instantly recognizes & configures my cards.  AMAZING; wifi magically works, Opie Mediaplayer2 even populates its list properly and the Documents tab has everything.  wasn't so in 3.5.3 and it was a big pain and now it's magically fixed!  My SD doesn't show up in "slot 1" when it's mounted, but I think it's because it's ext2 and not vfat, so once I find where mkfs.vfat got off to, that'll be sorted.

- reload icons icon.  greatly appreciated.

- the reorganized o-menu is sweet

- altshell is a very nice addition (what is the password I set on first boot?  i know it's not the rootword, but it's never asked me for it again so i'm a little confused)

I guess there isn't that much to this list, but I'm basically in awe that it's working already since reflashing yesterday.  3.5.3 was never this smooth... it rocks.

BUT: my one beef is that SD packages (like opie mediaplayer2, my killer app) still get installed to /media/sd/packages/usr, while "ipkg-link mount /media/sd" looks for things in /media/sd/usr.  I have to make a symlink every time I reformat, which is annoying, but at least I know (took about a week of sporratic research to find out...).  That's my only problem, really; a path reorg a while ago seems to not have proliferated as far as it should've.  

All in all though, totally rad.  Maybe it's psychosomatic, but everything feels smoother and less, well, linuxey.  Thanks devs!

YoG

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
A Love Letter To The Oz Team
« Reply #1 on: March 20, 2006, 04:12:48 am »
Quote
My SD doesn't show up in "slot 1" when it's mounted, but I think it's because it's ext2 and not vfat
I have a vfat SD, it doesn't appear in the mount manager also... so it's not the filesystem. but I only use one SD so it's not that much of a problem.

YoG
« Last Edit: March 20, 2006, 04:14:15 am by YoG »
C860 Autobuilt Angstrom (OPIE) & Zubuntu 9.04  dual boot using kexec
SanDisk SDHC 4GB, Agiwara Sys-Com CF 1GB, Sandisk CF 256MB, Socket BT, Linksys WCF12 Wifi card, RoyalTek RBT-1000 Bluetooth GPS
yogzlog.blogspot.com

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
A Love Letter To The Oz Team
« Reply #2 on: March 20, 2006, 07:09:57 am »
Quote
My SD doesn't show up in "slot 1" when it's mounted, but I think it's because it's ext2 and not vfat, so once I find where mkfs.vfat got off to, that'll be sorted.

Card manager does not care about SD at all - that 'slot 1' is not existing second cf slot reported by 2.4.18 kernel.
Quote
- altshell is a very nice addition (what is the password I set on first boot?  i know it's not the rootword, but it's never asked me for it again so i'm a little confused)
it is used when you will choose 'boot into sh' option
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

burned

  • Newbie
  • *
  • Posts: 4
    • View Profile
A Love Letter To The Oz Team
« Reply #3 on: March 20, 2006, 03:40:58 pm »
Amazing reply speed!  Thank you!

raybert

  • Full Member
  • ***
  • Posts: 233
    • View Profile
A Love Letter To The Oz Team
« Reply #4 on: March 21, 2006, 04:45:56 pm »
Quote
[snip] everything feels smoother and less, well, linuxey.  [snip]
...and that's a *good* thing????

hmmm......

 
« Last Edit: March 21, 2006, 04:47:06 pm by raybert »

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
A Love Letter To The Oz Team
« Reply #5 on: March 21, 2006, 05:20:32 pm »
Thanks for the nice words. These improvements would not have been possible without the use of our OpenEmbedded build system, so I'm glad that "it will pay off in the long run" now starts to come reality.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

koen

  • Hero Member
  • *****
  • Posts: 1008
    • View Profile
    • http://dominion.thruhere.net/koen/cms/
A Love Letter To The Oz Team
« Reply #6 on: March 21, 2006, 05:26:59 pm »
Quote
Thanks for the nice words. These improvements would not have been possible without the use of our OpenEmbedded build system, so I'm glad that "it will pay off in the long run" now starts to come reality.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=119698\"][{POST_SNAPBACK}][/a][/div]

I bet lineo was saying "it will pay off in the long run" about the 2.4-crappix kernels
Forums are not bugtrackers!!! Smart questions
Ångström release team
iPAQ h2210, iPAQ h5550, iPAQ hx4700, Zaurus SL-C700, Nokia 770, all running some form of GPE
My blog