Author Topic: Announce: Zbedic 1.1  (Read 4984 times)

rafm

  • Full Member
  • ***
  • Posts: 145
    • View Profile
Announce: Zbedic 1.1
« on: June 14, 2006, 07:40:05 am »
The latest release of the dictionary reader with (probably) the largest collection of free dictionaries, can be downladed from:

http://bedic.sourceforge.net/

The major effort has been devoted to make zbedic run on Linux desktop (QT without QTopia). Therfore binary packages for Debian and other Linux distributions are available starting from this release. This release has also several improvements for the Zaurus version: images can be included in dictionaries, redesigned 'add dictionary' interface and new file dialogs.
SL-C1000 w/ Cacko ROM 1.23

xamindar

  • Hero Member
  • *****
  • Posts: 803
    • View Profile
    • http://www.radnimax.com
Announce: Zbedic 1.1
« Reply #1 on: June 14, 2006, 01:39:14 pm »
Thanks!  I'll check it out.
SL-C3100 happily Dualbooting Japanese Rom 1.02 and Debian Eabi
Replaced internal CF with 8gb seagate cf hard drive
Ambicom CF GPS
CyberPower battery powered USB hub
D-link DCF-650W (MAN THIS THING IS HUGE!!)

rebski

  • Full Member
  • ***
  • Posts: 129
    • View Profile
Announce: Zbedic 1.1
« Reply #2 on: June 14, 2006, 02:53:20 pm »
Yes, thanks for the heads up. This is one of the esssential Zaurus apps.

The English dictionary is identical to the $15 BDicty version. Multilanguage support is not so good and I need BDicty for French and Spanish.

Zbedic reader works great with Wikipedia, Wiktionary, WikiQuote, WikiSimple, etc.  

That little lot swallows up half of my 1gb SD card.

albertr

  • Hero Member
  • *****
  • Posts: 535
    • View Profile
    • http://
Announce: Zbedic 1.1
« Reply #3 on: June 14, 2006, 03:36:47 pm »
Code: [Select]
g++ -o objs.noqpe/zbedic -L../libbedic/objs.  objs.noqpe/main.o objs.noqpe/zbedic.o objs.noqpe/moc_zbedic.o objs.noqpe/settings.o objs.noqpe/moc_settings.o objs.noqpe/keyboard_shortcuts.o objs.noqpe/moc_keyboard_shortcuts.o objs.noqpe/editor.o objs.noqpe/moc_editor.o objs.noqpe/dicproperties.o objs.noqpe/moc_dicproperties.o objs.noqpe/abstract_config.o objs.noqpe/registry.o -L/usr/lib/qt/lib -lqt-mt -L../libbedic/objs/ -lbedic -L/opt/native/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/lib -lsqlite3
objs.noqpe/zbedic.o(.text+0x6c58): In function `ZBEDic::showHelp()':
: undefined reference to `HelpDialog::HelpDialog(QWidget*)'
objs.noqpe/zbedic.o(.text+0x6ce8): In function `ZBEDic::showHelp()':
: undefined reference to `vtable for HelpDialog'
collect2: ld returned 1 exit status
make: *** [objs.noqpe/zbedic] Error 1

Any idea what's wrong? Trying to build it for pdaXrom...

-albertr

brashley46

  • Sr. Member
  • ****
  • Posts: 277
    • View Profile
    • http://brashley46.no-ip.info
Announce: Zbedic 1.1
« Reply #4 on: June 14, 2006, 03:43:30 pm »
Thanks for the headsup!
B. Ross Ashley
http://brashley46.livejournal.com
http://brashley46.no-ip.info
Home desktops: Hewlett-Packard Kayak XM600 running Xandros Desktop Home Edition Premium (4.1), on a P3 Coppermine processor w/ 20G harddrive, 256 MB RAM; Abyss X2 server running on a local shop-built special with Intel Celeron 1.8GHz processor, 40G harddrive running Win XP Home SP2; and my wife's eMac running OS X3.9

Handheld: C860 running CACkO 1.23, with a Panasonic Class 2 1G SD card and a GXT 1G CF card; AmbiCom WL1100C-CF wifi card, and a CE-AG06 camera card.

albertr

  • Hero Member
  • *****
  • Posts: 535
    • View Profile
    • http://
Announce: Zbedic 1.1
« Reply #5 on: June 14, 2006, 04:16:56 pm »
Making some progress

Code: [Select]
g++ -c -o objs.noqpe/helpdialog.o -pipe -Wall -Os -ffast-math -fomit-frame-pointer -fsigned-char -fno-strict-aliasing -mcpu=xscale -mtune=xscale  -I/opt/native/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/include -I/usr/lib/qt/include  -DDESKTOP=1 -DPKG_DATA_PATH=\"/usr/local/share/zbedic\" -I../libbedic/include -DVERSION=\"1.1-0\" -DPREFIX_PATH=\"/usr/local\" src/helpdialog.cpp
g++ -o objs.noqpe/zbedic -L../libbedic/objs.  objs.noqpe/main.o objs.noqpe/zbedic.o objs.noqpe/moc_zbedic.o objs.noqpe/settings.o objs.noqpe/moc_settings.o objs.noqpe/keyboard_shortcuts.o objs.noqpe/moc_keyboard_shortcuts.o objs.noqpe/editor.o objs.noqpe/moc_editor.o objs.noqpe/dicproperties.o objs.noqpe/moc_dicproperties.o objs.noqpe/abstract_config.o objs.noqpe/helpdialog.o objs.noqpe/registry.o -L/usr/lib/qt/lib -lqt-mt -L../libbedic/objs/ -lbedic -L/opt/native/arm/3.4.4-xscale-softvfp/armv5tel-cacko-linux/lib -lsqlite3
objs.noqpe/zbedic.o(.text+0x6ce8): In function `ZBEDic::showHelp()':
: undefined reference to `vtable for HelpDialog'
objs.noqpe/helpdialog.o(.text+0x58): In function `HelpDialog::HelpDialog(QWidget*)':
: undefined reference to `HelpDialog::tr(char const*, char const*)'
objs.noqpe/helpdialog.o(.text+0x3dc): In function `HelpDialog::HelpDialog(QWidget*)':
: undefined reference to `HelpDialog::tr(char const*, char const*)'
objs.noqpe/helpdialog.o(.text+0x6d4): In function `HelpDialog::HelpDialog(QWidget*)':
: undefined reference to `vtable for HelpDialog'
objs.noqpe/helpdialog.o(.text+0x75c): In function `HelpDialog::HelpDialog(QWidget*)':
: undefined reference to `HelpDialog::tr(char const*, char const*)'
objs.noqpe/helpdialog.o(.text+0xae0): In function `HelpDialog::HelpDialog(QWidget*)':
: undefined reference to `HelpDialog::tr(char const*, char const*)'
objs.noqpe/helpdialog.o(.text+0xdd8): In function `HelpDialog::HelpDialog(QWidget*)':
: undefined reference to `vtable for HelpDialog'
collect2: ld returned 1 exit status
make: *** [objs.noqpe/zbedic] Error 1

-albertr

albertr

  • Hero Member
  • *****
  • Posts: 535
    • View Profile
    • http://
Announce: Zbedic 1.1
« Reply #6 on: June 14, 2006, 04:52:01 pm »
Ok, I gave up on trying to fix it, and just commented out HelpDialog call from zbedic.cpp. Now it compiles and runs.
-albertr

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
Announce: Zbedic 1.1
« Reply #7 on: June 15, 2006, 04:11:42 pm »
I'll try to upgrade OZ version in next week.
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

rafm

  • Full Member
  • ***
  • Posts: 145
    • View Profile
Announce: Zbedic 1.1
« Reply #8 on: June 17, 2006, 01:30:10 pm »
Quote
Making some progress

Code: [Select]
...
g++ -o objs.noqpe/zbedic -L../libbedic/objs.  objs.noqpe/main.o objs.noqpe/zbedic.o objs.noqpe/moc_zbedic.o objs.noqpe/settings.o objs.noqpe/moc_settings.o objs.noqpe/keyboard_shortcuts.o objs.noqpe/moc_keyboard_shortcuts.o objs.noqpe/editor.o objs.noqpe/moc_editor.o objs.noqpe/dicproperties.o objs.noqpe/moc_dicproperties.o objs.noqpe/abstract_config.o objs.noqpe/helpdialog.o objs.noqpe/registry.o -L/usr/lib/qt/lib -lqt-mt -L../libbedic/objs/ -lbedic
...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=131148\"][{POST_SNAPBACK}][/a][/div]

The command line seems to be missing objs.noqpe/moc_helpdialog.o.

This should be fixed in the latest sources (1.1-1), which you can download from the CVS, but which are missing as tar.gz.
SL-C1000 w/ Cacko ROM 1.23

ShiroiKuma

  • Hero Member
  • *****
  • Posts: 900
    • View Profile
Announce: Zbedic 1.1
« Reply #9 on: June 17, 2006, 04:24:13 pm »
Quote
I'll try to upgrade OZ version in next week.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=131304\"][{POST_SNAPBACK}][/a][/div]
Unfortunately, the OZ version is the Opie (Qtopia) version. I've been trying to compile a GPE version for some time... Keep failing. Have includes problems etc.

Could some kind soul compile for GPE and post it?

This really is the quintessential Z app for me too, it's so hard to get by without it - yet GPE on OZ otherwise is the greatest, I think...
[span style=\'font-size:8pt;line-height:100%\']Das ganze tschechische Volk ist eine Simulantenbande.[/font][/span]
Militäroberarzt Bautze

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
Announce: Zbedic 1.1
« Reply #10 on: June 18, 2006, 05:42:19 pm »
I'm working on new recipes for zbedic so versions for both enviroments will be provided.

rafm: I will send you some patches to review soon.
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

kurochka

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
Announce: Zbedic 1.1
« Reply #11 on: June 22, 2006, 04:29:42 pm »
This is great news.  I think this should be advertised to the general Linux community.
Thanks, rafm.  Special thanks for working on including images.
SL-C3100 (from PriceJapan.com): modified Sharp Rom (couldn't make Japanese input work in Cacko Rom)

ex-SL-C3000; ex-SL-5600; ex-Simpad

kurochka

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
Announce: Zbedic 1.1
« Reply #12 on: August 14, 2006, 04:35:24 pm »
2or0 has compiled zbedic for pdaXrom.  Should the package be added to the zbedic download list (or at least a link)?

https://www.oesf.org/forums/index.php?showt...ndpost&p=138407
SL-C3100 (from PriceJapan.com): modified Sharp Rom (couldn't make Japanese input work in Cacko Rom)

ex-SL-C3000; ex-SL-5600; ex-Simpad

kurochka

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
Announce: Zbedic 1.1
« Reply #13 on: August 15, 2006, 05:17:29 am »
Some feedback.

I put the zbedic on Suse and it runs well.  The only issue was with finding libaudio.so.2 (??) I linked it to some libaudiofile library in Suse.  Why does it need an audio library?

When I first noticed that some entries where not displayed (just nothing, the word on the left shows but nothing in the right pane), I thought it was the dictionary's problem.  However, it appears that it's zbedic.  Can't see why some (quite a few) entries are not displayed.  Has anybody else seen this?  For me it's both on zbedic and Suse.
Do we need to recompile all the dictionaries for the new zbedic to fix this problem.  You were saying somewhere something about new mkbedic.

Is there some info somewhere about the image tags?  Just plain html?
SL-C3100 (from PriceJapan.com): modified Sharp Rom (couldn't make Japanese input work in Cacko Rom)

ex-SL-C3000; ex-SL-5600; ex-Simpad

rafm

  • Full Member
  • ***
  • Posts: 145
    • View Profile
Announce: Zbedic 1.1
« Reply #14 on: August 15, 2006, 09:41:00 am »
Quote
Some feedback.

I put the zbedic on Suse and it runs well.  The only issue was with finding libaudio.so.2 (??) I linked it to some libaudiofile library in Suse.  Why does it need an audio library?

Perhaps QT requires audio library. zbedic does not use it.

Quote
When I first noticed that some entries where not displayed (just nothing, the word on the left shows but nothing in the right pane), I thought it was the dictionary's problem.  However, it appears that it's zbedic.  Can't see why some (quite a few) entries are not displayed.  Has anybody else seen this?  For me it's both on zbedic and Suse.
Do we need to recompile all the dictionaries for the new zbedic to fix this problem.  You were saying somewhere something about new mkbedic.

Which dictionaries show this problem? If you could put one of them (the smaller, the better) somewhere to dowload, I would take a look at it.

I noticed some problems with the dictionaries that use char-precedence and do not list all the characters they use.  

Quote
Is there some info somewhere about the image tags?  Just plain html?
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

See: [a href=\"http://bedic.sourceforge.net/doc/zbedic-editing.html]http://bedic.sourceforge.net/doc/zbedic-editing.html[/url] and look for "{img".
SL-C1000 w/ Cacko ROM 1.23