Author Topic: X11 Forwarding?  (Read 7804 times)

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
X11 Forwarding?
« on: June 17, 2006, 07:49:04 pm »
I'm trying to get X11 forwarding from my 5500 to my laptop working. I've followed all the steps I can find online, and it seems like it'd work, but apparently not. When i try to run sylpheed, I get the error
Code: [Select]
root@exiguitas:~# sylpheed

(process:1765): LibSylph-WARNING **: SSLv23 SSL_CTX_load_verify_locations failed.


(process:1765): LibSylph-WARNING **: TLSv1 SSL_CTX_load_verify_locations failed.


(sylpheed:1765): Gtk-WARNING **: cannot open display:

Suggestions?
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

iamasmith

  • Hero Member
  • *****
  • Posts: 1248
    • View Profile
X11 Forwarding?
« Reply #1 on: June 17, 2006, 08:18:20 pm »
Firstly I am presuming that you are running ssh connection as follows..

ssh -X user@host

this is the normal mechanism.. to give trusted rights required for some apps to function try..

ssh -Y user@host

a quick check to see if it is working is to inspect the DISPLAY environment variable over the ssh session.
it should look something like this

echo $DISPLAY
localhost:10.0


Secondly sshd on the machine that you are ssh'ing into to run the X client (against your X server) may have it disabled... look for sshd_config (default location is /etc/ssh/sshd_config but may be different on your distro) check the line X11Forwarding and make sure it is uncommented and set to yes (restart sshd after that).

If this doesn't help then kill off sshd and run

sshd -ddd

on the Zaurus console (yes that is 3 d's for level 3 debug). sshd will accept one connection like this then terminate but it will show complete debug output for that connection.

Hope this helps,

(if this was posted on an OpenBSD list even about the Zaurus you would get back a one line response as follows...

sshd(8)

...since even the Zaurus carries full man pages )

-Andy
« Last Edit: June 17, 2006, 08:26:02 pm by iamasmith »
OpenBSD 4.2 -current on full 4Gb of SL-C3000
Microdrive replaced with 4Gb SanDisk Extreme III card

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
X11 Forwarding?
« Reply #2 on: June 17, 2006, 11:33:23 pm »
ok, two issues. Firstly, DISPLAY doesn't seem to be set. I tried running
Code: [Select]
export DISPLAY=10and that didn't work.

Secondly, there isn't anything called sshd. There's a /etc/init.d/ssh, but that won't take the -ddd parameter.

Also, the 5500 doesn't have man pages, but I did look at the man pages for ssh on my debian box.

Off topic, but how hard is OpenBSD to learn, coming from linux?
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

iamasmith

  • Hero Member
  • *****
  • Posts: 1248
    • View Profile
X11 Forwarding?
« Reply #3 on: June 18, 2006, 04:57:13 am »
Quote
ok, two issues. Firstly, DISPLAY doesn't seem to be set. I tried running
Code: [Select]
export DISPLAY=10and that didn't work.

No that won't work... sshd sets the DISPLAY enironment for you but what it actually does is create a listener port acting as a comms endpoint for the connection - this perhaps illustrates more what I mean.

Code: [Select]
mungo$ netstat -na
Active Internet connections (including servers)
Proto Recv-Q Send-Q  Local Address          Foreign Address        (state)
tcp        0      0  127.0.0.1.6010         *.*                    LISTEN
...
mungo$ echo $DISPLAY
localhost:10.0

A base TCP port number for X is 6000 and if your local display is using display numeber 0.0 and a TCP connection it will use port 6000.

All sshd does is to generate a tcp listener endpoint on the system running the X clients. In this case it has picked 6010. It then sets the display variable to localhost:10.0 which tells the XLibs to talk to port 6010 instead of 6000 on the localhost.

When the Xlibs talk to this port number the sshd daemon tunnels it over the ssh connection to your X server.

The DISPLAY environment variable is therefore set automatically by sshd to point to the TCP port on the local host and sshd forwards this. In short don't bother trying to set the DISPLAY environment variable because sshd must do it.


Quote
Secondly, there isn't anything called sshd. There's a /etc/init.d/ssh, but that won't take the -ddd parameter.

have a look at the script /etc/init.d/ssh that will probably show you where the ssh daemon is being run from (I'm assuming here that this is OpenSSH as most Linux uses it)

Quote
Also, the 5500 doesn't have man pages, but I did look at the man pages for ssh on my debian box.

Off topic, but how hard is OpenBSD to learn, coming from linux?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=131591\"][{POST_SNAPBACK}][/a][/div]

It depends on how much Linux you know etc.. there are a few userland differences but as I mentioned all the man pages are there.

There are quite a few differences when you start to look at the Kernel - if you are a developer then you should find the readability of the Kernel source pretty good. The Kernel obviuosly isn't a Linux kernel and kernel configuration/tweaking/is handled quite differently from Linux.

Startup scripts are quite different to most Linux distributions... having said that if you accept the differences between a RedHat and a Gentoo startup script set then you shouldn't have too many problems with OpenBSD. Essentially OpenBSD starts all base built stuff from a script called /etc/rc depending upon the state of flags set in /etc/rc.conf it then runs /etc/rc.local allowing you to add your own stuff.

OpenBSD is one BSD UNIX distro (strictly speaking I should say UNIX like operating system) and is the same on every installation regardless of architecture - that is, install it on your Zaurus and it is the same installation that you have when you install it on a PC or a Vax etc. etc. - of course you will probably want to customise the installation yourself for the Zaurus at that point.

(heh, the amount of things I started to explain on this thread and then simply snipped them out because it sounded like I was having a dig at Linux or GNU you wouldn't believe... I'm trying not to get into that here, just give plain differences).

-Andy
« Last Edit: June 18, 2006, 05:08:06 am by iamasmith »
OpenBSD 4.2 -current on full 4Gb of SL-C3000
Microdrive replaced with 4Gb SanDisk Extreme III card

iamasmith

  • Hero Member
  • *****
  • Posts: 1248
    • View Profile
X11 Forwarding?
« Reply #4 on: June 18, 2006, 05:36:07 am »
btw: you didn't mention what OZ image you are using but I will charge up my old C860 and install a version of OZ so I know what the scripts look like.
OpenBSD 4.2 -current on full 4Gb of SL-C3000
Microdrive replaced with 4Gb SanDisk Extreme III card

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
X11 Forwarding?
« Reply #5 on: June 18, 2006, 11:22:41 am »
I'm running 3.5.4 of OZ. running sshd -ddd threw up a bunch of debug stuff, but nothing that seemed pertinent to this. Is there any way to force ssh to set the DISPLAY variable, as I'm assuming that's what's not working?

I don't often look at the startup scripts, as I'm worried about screwing something up. I'd consider myself an amateur programmer, and I've looked at some of the linux source. It's .... well, I didn't understand any of it, except the basics as to what it was doing (looping etc.). I run debian, and not much else, so I don't really know the differences between distros either. I'm sure I could find my way around in something else, and played around with slackware for a short amount of time. Thanks for the info.
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

iamasmith

  • Hero Member
  • *****
  • Posts: 1248
    • View Profile
X11 Forwarding?
« Reply #6 on: June 19, 2006, 05:55:24 am »
Well I installed the OZ-E image on my old SL-C860, which didn't function correctly because I had an old pdaXrom image with the full 121Mb of available flash given over to the root file system. - I thought I might get away with it (after removing the /home mount) but it seems that I will need to repartition for this to function correctly.

What I did notice is that the ssh services provided do not use OpenSSH but instead use dropbear which is a somewhat smaller version and a good alternative for embedded Linux.

Unfortunatly my install doesn't let me log in for more than about 5 seconds until it logs me out again so I need to reinstall before I get to look for config files - also note there is no documentation on either the dropbear site or in text files accompanying the source. yeah - way to go folks (another reason for me liking OpenBSD, a missing, incomplete or innacurate man page is deemed a sufficient problem for it not to get in).

-Andy
OpenBSD 4.2 -current on full 4Gb of SL-C3000
Microdrive replaced with 4Gb SanDisk Extreme III card

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
X11 Forwarding?
« Reply #7 on: June 19, 2006, 09:25:20 am »
I've installed the OpenSSH packages from the feed. I've looked at online documentation for OpenSSH, and I've followed the instructions for X11 forwarding from another thread somewhere on this forum. I honestly don't know.
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
X11 Forwarding?
« Reply #8 on: June 19, 2006, 09:44:18 am »
Quote
I've installed the OpenSSH packages from the feed. I've looked at online documentation for OpenSSH, and I've followed the instructions for X11 forwarding from another thread somewhere on this forum. I honestly don't know.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=131834\"][{POST_SNAPBACK}][/a][/div]

just use putty and tick the Enable X11 checkbox
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
X11 Forwarding?
« Reply #9 on: June 19, 2006, 03:07:09 pm »
putty in linux? I've used putty from windows, but I run a linux desktop most of the time.
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
X11 Forwarding?
« Reply #10 on: June 19, 2006, 06:44:57 pm »
Quote
putty in linux? I've used putty from windows, but I run a linux desktop most of the time.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=131872\"][{POST_SNAPBACK}][/a][/div]

sure there is. there's even putty for Zaurus, at least pdaXrom has it
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
X11 Forwarding?
« Reply #11 on: July 25, 2006, 10:43:47 pm »
Meanie, that didn't work either. I'm kinda stuck, I need to get the DISPLAY variable set. Suggestions?
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux

nevarrie

  • Full Member
  • ***
  • Posts: 188
    • View Profile
    • http://www.thegrantclan.org
X11 Forwarding?
« Reply #12 on: July 25, 2006, 11:22:58 pm »
On my zaurus I run:

     export DISPLAY=192.168.0.1:0.0

On my Mac or windows or Linux workstation(depends on which I am going to display to) I run:

     xhost +192.168.0.13

or if you are not worried about others open programs on your display:

     xhost +

192.168.0.13 is the IP for my Z
192.168.0.1 is the IP for my desktop

With this setup I only have to run the export command in each of my terms and then any command I run open to the desktop I DISPLAY exported to.

At least that is how I do it everyday...
***********************
Jeremy "Nevarrie" Grant
SL-6000L
OpenZaurus 3.5.4.1 GPE(2.6 kernel)|GrantRom 0.01(e-image clone)
Targus IR Keyborad

koen

  • Hero Member
  • *****
  • Posts: 1008
    • View Profile
    • http://dominion.thruhere.net/koen/cms/
X11 Forwarding?
« Reply #13 on: July 26, 2006, 03:04:00 am »
You could also use the 'teleport' panel app to send apps to a different display.
Forums are not bugtrackers!!! Smart questions
Ångström release team
iPAQ h2210, iPAQ h5550, iPAQ hx4700, Zaurus SL-C700, Nokia 770, all running some form of GPE
My blog

microsoft/linux

  • Full Member
  • ***
  • Posts: 237
    • View Profile
    • http://
X11 Forwarding?
« Reply #14 on: July 26, 2006, 10:40:03 am »
I thought exporting the DISPLAY variable didn't work? Ah well, I'll play w/ it some more tonight, when I have more time. Is there an easy howto for it? I think the issue is that the display isn't getting set. Could somone w/ it working post their sshd_config and their ssh_config files, so I can compare(these files are from the Z)?

Suggestions for a good IRC client?
C3200(exiguitas) Angstrom Beta(version not designated)/GPE
SL-5500(immotus) OpenZaurus 3.5.4/GPE, OpenZaurus 3.5.4/Opie(loopmount)
1GB SD Card
128MB CF Card/8MB CF Card
Gentoo/Windows XP Home SP2

Numbers rule the Universe.
        --The Pythagoreans

Microsoft/Linux