Author Topic: Updated Ruby And Rubygems Ipk  (Read 7174 times)

Sy Ali

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Updated Ruby And Rubygems Ipk
« on: June 19, 2006, 05:07:45 am »
http://rubyforge.org/projects/ruby/
http://rubyforge.org/projects/rubygems/

Ruby is up to 1.8.4, and an ipk file for rubygems would be handy.

I try a manual installation of RubyGems, and I get a string of errors.

The most interesting one seems to be:
Quote
/opt/QtPalmtop/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29: in `require': libcrypto.so.0.9.6: cannot load shared object file: No such file or directory - /opt/QtPalmtop/lib/ruby/1.8/arm-linux/digest/md5.so (LoadError)

I'm going to check with the ruby-talk mailing list.. maybe I can solve the install problem.

melee

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
    • http://
Updated Ruby And Rubygems Ipk
« Reply #1 on: June 19, 2006, 12:51:36 pm »
Quote
Ruby is up to 1.8.4, and an ipk file for rubygems would be handy.

Hi

1.8.4 is already posted on this site thanks to FabianE

https://www.oesf.org/forums/index.php?showtopic=18415&st=45#

seems to include gems

Melee
C860 - with Sharp ROM
1GB SD and 2 GB & 256MB CF
WiFi, Bluetooth and Sharp CF camera cards
Ubuntu 6.06
(WinXP if I really have to)

Sy Ali

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Updated Ruby And Rubygems Ipk
« Reply #2 on: June 19, 2006, 01:31:21 pm »
fabianE reports:
I've compiled Ruby 1.8.4 including ri, gems and irb with auto-complete enabled. You can download it at http://mail.pdaxrom.org/contrib/fabian/ .

However, running "gem" gives:
Quote
/home/QtPalmtop/bin/gem:3 in `require': no such file to load -- rubygems (LoadError)

if I cd into

Code: [Select]
/home/QtPalmtop/lib/ruby/site_ruby/1.8
and I run it, I get a different error:

Quote
./rubygems.rb:51: warning: already initalized constant RubyGemsPackageVersion
./rubygems.rb:53: warning: already initalized constant DIRECTORIES

I'm not entirely sure if I have it working or not.  =)

...

I've been using Cacko 1.23 so far, but perhaps I should switch over to pdaXrom 1.1.0beta4
« Last Edit: June 19, 2006, 02:00:31 pm by Sy Ali »

Sy Ali

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Updated Ruby And Rubygems Ipk
« Reply #3 on: June 23, 2006, 07:05:00 pm »
Installing rubygems from source hasn't worked out.  I can get it to install, although I get an error with the post-install.  'gem' runs, but I cannot instally any gems with it.  I get:

ERROR:  Error installing gem (filename)[.gem]: invalid date

fabianE

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Updated Ruby And Rubygems Ipk
« Reply #4 on: June 30, 2006, 03:55:39 am »
Hello,

the reason is probably that you use Cacko Rom, and not pdaxrom. My version of ruby was compiled for the later, so it probably won't work.

If you have another install of ruby for your rom and have problems with installing gems, you may lack some development packages or additional libraries.

Regards,

Fabian

Quote
Installing rubygems from source hasn't worked out.  I can get it to install, although I get an error with the post-install.  'gem' runs, but I cannot instally any gems with it.  I get:

ERROR:  Error installing gem (filename)[.gem]: invalid date
[div align=\"right\"][a href=\"index.php?act=findpost&pid=132644\"][{POST_SNAPBACK}][/a][/div]

Sy Ali

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Updated Ruby And Rubygems Ipk
« Reply #5 on: July 27, 2007, 11:33:15 pm »
Ruby 1.8.6 is out.

I'm using weeXpc now, which is pdaXrom-based, so I'll try rubygems one more time.

Sy Ali

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Updated Ruby And Rubygems Ipk
« Reply #6 on: July 28, 2007, 07:25:29 am »
Using ruby 1.8.4, I was able to get rubygems 0.9.4 working.

It gave some odd warnings while I ran the setup, and it paused for a *long* time and then gave 'terminated', but running 'gem' seems to work.,