Author Topic: Move Root To Cf Card  (Read 3534 times)

frazras

  • Newbie
  • *
  • Posts: 2
    • View Profile
Move Root To Cf Card
« on: August 21, 2006, 03:18:43 pm »
I want to use the 64-0 zImage but I dont know how to make the root go to the CF

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
Move Root To Cf Card
« Reply #1 on: August 21, 2006, 05:04:23 pm »
I dont believe there is a bootloader for the SL-5x00 set to allow booting from alternate media... Not sayin it can't be done... because it can... but I dont believe its been done yet...

Late
« Last Edit: August 21, 2006, 05:05:06 pm by InSearchOf »
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

frazras

  • Newbie
  • *
  • Posts: 2
    • View Profile
Move Root To Cf Card
« Reply #2 on: August 22, 2006, 02:28:25 am »
The problem I am having is when I installed openzaurus I used the 32-32 zImage, however it leaves a very small
space for root </dev/root  :14464> [used 13272  Free:1192]. I know I can install programs on my cf card but some will not work unless its on root
the rest of the space usage is </media/ram: 31729> [Used: 1718  Free:30011]
I think there should be more for root but I dont know... Any suggestions??

chal

  • Jr. Member
  • **
  • Posts: 98
    • View Profile
    • http://
Move Root To Cf Card
« Reply #3 on: August 22, 2006, 07:43:49 am »

PDAs
2 SL5500s
tKc Rom
Lexar 1GB CF card
Viking 512GB  CF card
PC 1. Mandriva 2009
PC 2. Windows XP
[/font]

rolf

  • Full Member
  • ***
  • Posts: 105
    • View Profile
    • http://home.arcor.de/leggewie/
Move Root To Cf Card
« Reply #4 on: August 27, 2006, 03:03:33 pm »
Quote
I want to use the 64-0 zImage but I dont know how to make the root go to the CF

How about altboot'ing to a loop image file on SD or CD?

hakujin

  • Newbie
  • *
  • Posts: 37
    • View Profile
Move Root To Cf Card
« Reply #5 on: November 19, 2006, 03:12:55 am »
Quote
Quote
I want to use the 64-0 zImage but I dont know how to make the root go to the CF

How about altboot'ing to a loop image file on SD or CD?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=139947\"][{POST_SNAPBACK}][/a][/div]

I would like to altboot to a loop file but for some reason I am getting no altboot menu when I start up my Z. I am running OZ 3.5.4 the latest release with opie on an SL-5600 . I have installed all the altboot ipks. I am not sure but it might be there but I can't see it because I don't see any boot messages is there any way to enable boot messages on 3.5.4. After I installed the altboot ipks it now takes a little longer to get to init and if I hit a button before init starts it just sticks (I see the Open Zaurus logo and that chinpo dinosaur thing)and init never starts and  I have to reset.
Hentges 2.6 ROM with opie on pxa255 poodle
1GB Kingston SD card
4GB Seagate (photo camera) CF hard drive
SanDisk Connect Plus wifi card
USB cradle to laptop to ethernet bridge to Debian firewall/router/webserver
Wife threatening to leave me if I play around anymore with my Z

CoreDump

  • Hero Member
  • *****
  • Posts: 713
    • View Profile
    • http://www.hentges.net
Move Root To Cf Card
« Reply #6 on: November 26, 2006, 06:41:55 pm »
Quote
Quote
Quote
I want to use the 64-0 zImage but I dont know how to make the root go to the CF

How about altboot'ing to a loop image file on SD or CD?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=139947\"][{POST_SNAPBACK}][/a][/div]

I would like to altboot to a loop file but for some reason I am getting no altboot menu when I start up my Z. I am running OZ 3.5.4 the latest release with opie on an SL-5600 . I have installed all the altboot ipks. I am not sure but it might be there but I can't see it because I don't see any boot messages is there any way to enable boot messages on 3.5.4. After I installed the altboot ipks it now takes a little longer to get to init and if I hit a button before init starts it just sticks (I see the Open Zaurus logo and that chinpo dinosaur thing)and init never starts and  I have to reset.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=146650\"][{POST_SNAPBACK}][/a][/div]

3.5.4 means kernel 2.4 right? Did you install both altboot.ipk and altboot-conf.ipk?
Webmaster of hentges.net & Embedded Linux Developer.