Author Topic: C1000 And Openbsd  (Read 6260 times)

cal

  • Full Member
  • ***
  • Posts: 112
    • View Profile
C1000 And Openbsd
« on: September 11, 2006, 08:42:04 pm »
Edit: First post was rambling, here's what works so far


Prepareing the installation:

1.
fdisk cf card
   Stops an error that sometimes happens when the card is not unmounted properly.

2.
copy the following files to /home/root/
  bsd
  bsd.rd
  zboot
  zbsdmod.o



Start BSD Installation
Run the following:

Code: [Select]
cd /home/root/
su
insmod zbsdmod.o
cp bsd.rd /proc/zboot


You are on your own from here.  I cannot get a network adapter running, and my SD carder reader won't mount.  Hope this helps.  I'll post more when I figure it out.
« Last Edit: September 12, 2006, 08:51:31 pm by cal »

cal

  • Full Member
  • ***
  • Posts: 112
    • View Profile
C1000 And Openbsd
« Reply #1 on: September 12, 2006, 06:45:07 am »
9/12
6:37A
New day...

Did a ctrl Z and paused the installation, and droped to a comandline.  The mount showed there was no /dev/sda0 mounted.  

mount -t /dev/sda0 /mnt2    errors with "device not configured"

I'm going to drop to linux and see if I can copy the 3.9 directory from the sd card to the CF card.  Maybe I can skip labeling thing this time.

6:49A
No dice, cacko can't read bsd filesystems.
« Last Edit: September 12, 2006, 06:51:19 am by cal »

mathemajikian

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
    • http://exit3.i-55.com/~xikon/openbsdzaurus.html
C1000 And Openbsd
« Reply #2 on: September 12, 2006, 06:55:41 am »
What partitions are you creating on the CF card? What device is the CF card reported as? Where are you installing zboot zbsdmod.o? They should be located in /bsd on /dev/mtdblock2. Why can't you use your USB wifi adapter with a powered usb hub to access an FTP server to aquire the bsd distribution sets? Does the C1000 have an emergeny boot linux you can access? (On the C3200 you can access sharps emergency boot linux by holding down D+B during a reboot) If so why are you doing this from within cacko? The first step is to get OpenBSD installed onto the CF card.  

Quote
9/12
6:37A
New day...

Did a ctrl Z and paused the installation, and droped to a comandline.  The mount showed there was no /dev/sda0 mounted. 

mount -t /dev/sda0 /mnt2    errors with "device not configured"

I'm going to drop to linux and see if I can copy the 3.9 directory from the sd card to the CF card.  Maybe I can skip labeling thing this time.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=141211\"][{POST_SNAPBACK}][/a][/div]
« Last Edit: September 12, 2006, 07:19:20 am by mathemajikian »

cal

  • Full Member
  • ***
  • Posts: 112
    • View Profile
C1000 And Openbsd
« Reply #3 on: September 12, 2006, 07:39:10 am »
Quote from: mathemajikian,Sep 12 2006, 06:55 AM
What partitions are you creating on the CF card? What device is the CF card reported as? Where are you installing zboot zbsdmod.o? They should be located in /bsd on /dev/mtdblock2. Why can't you use your USB wifi adapter with a powered usb hub to access an FTP server to aquire the bsd distribution sets? Does the C1000 have an emergeny boot linux you can access? (On the C3200 you can access sharps emergency boot linux by holding down D+B during a reboot) If so why are you doing this from within cacko? The first step is to get OpenBSD installed onto the CF card.  


D+B doesn't bring up an emergency linux.  

Wifi works on my laptop, but gives "can't write" errors.  The drivers may have been added in 4.0 as it uses a relatively new chipset if I recall.  Actually, I don't have the adapter here at the office but, it might be usb2.  Duh, forgot to check.

In  BSD the CF is reported as wd0 .  

There is only one partition on the CF now, but I'm thinking of adding a 250m second partition to hold the installation sets.

The SD card in a usbreader is sd0

I have zboot and zbdsmod.o in /home/root/ .  

in cacko / is readonly so "mkdir /bsd" give "Cannot create directory '/bsd': Read-only file system

mathemajikian

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
    • http://exit3.i-55.com/~xikon/openbsdzaurus.html
C1000 And Openbsd
« Reply #4 on: September 12, 2006, 08:29:52 am »
Leaving zboot, and zbsdmod.o where they are located in your cacko install( /home/root ) you will need to rename and then copy this file to the directory stated below:
 
 [ Invalid Attachment ]
 
(MAKE SURE YOU MAKE A BACKUP OF YOUR ORIGINAL FILE rc.rofilesys FIRST!) Rename the file rc.rofilesys.txt to rc.rofilesys and copy it to to /root/etc/rc.d/ .  This has been edited to look for and load zboot and zbsdmod.o in /home/root. If you can install OpenBSD on the CF then you should be good to go using your current cacko installation.  

You might also want to check out some of the other files found in this post: https://www.oesf.org/forums/index.php?showtopic=21249

Quote
D+B doesn't bring up an emergency linux. 

Wifi works on my laptop, but gives "can't write" errors.  The drivers may have been added in 4.0 as it uses a relatively new chipset if I recall.  Actually, I don't have the adapter here at the office but, it might be usb2.  Duh, forgot to check.

In  BSD the CF is reported as wd0 . 

There is only one partition on the CF now, but I'm thinking of adding a 250m second partition to hold the installation sets.

The SD card in a usbreader is sd0

I have zboot and zbdsmod.o in /home/root/ . 

in cacko / is readonly so "mkdir /bsd" give "Cannot create directory '/bsd': Read-only file system
[div align=\"right\"][a href=\"index.php?act=findpost&pid=141213\"][{POST_SNAPBACK}][/a][/div]
« Last Edit: September 17, 2006, 07:48:34 pm by mathemajikian »

cal

  • Full Member
  • ***
  • Posts: 112
    • View Profile
C1000 And Openbsd
« Reply #5 on: September 12, 2006, 08:45:15 am »
Thanks, hope I get far enought to use it...  
Unfortunately, the problem now is installing BSD to the CF...  I cant mount the usb sd reader, so I can't install the installation sets.  I'm going to try copying the files to a second partition on the cf card.  that might work.  Does the bsd  labeling change when you have second partition on a disk?
« Last Edit: September 12, 2006, 08:46:18 am by cal »

mathemajikian

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
    • http://exit3.i-55.com/~xikon/openbsdzaurus.html
C1000 And Openbsd
« Reply #6 on: September 12, 2006, 09:09:01 am »
Your best bet is to use a OpenBSD supported network adapter to download the distribution sets during the installation process. Also you should try and use the latest 4.0 snapshot. I thought you had managed to get the SD card mounted earlier during the OpenBSD install?    

Quote
Thanks, hope I get far enought to use it...   
Unfortunately, the problem now is installing BSD to the CF...  I cant mount the usb sd reader, so I can't install the installation sets.  I'm going to try copying the files to a second partition on the cf card.  that might work.  Does the bsd  labeling change when you have second partition on a disk?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=141218\"][{POST_SNAPBACK}][/a][/div]

cal

  • Full Member
  • ***
  • Posts: 112
    • View Profile
C1000 And Openbsd
« Reply #7 on: September 12, 2006, 09:54:02 am »
Nope the sd card is recognised, but will not mount.  I'll try a network install after work.

iamasmith

  • Hero Member
  • *****
  • Posts: 1248
    • View Profile
C1000 And Openbsd
« Reply #8 on: October 13, 2006, 04:36:55 pm »
This isn't going to work. zboot only looks at CF.
OpenBSD 4.2 -current on full 4Gb of SL-C3000
Microdrive replaced with 4Gb SanDisk Extreme III card

cal

  • Full Member
  • ***
  • Posts: 112
    • View Profile
C1000 And Openbsd
« Reply #9 on: January 28, 2007, 09:20:47 pm »
Figured it out...  Sort of.  Did have a few problems though.  FTP installs stalled everytime for every mirror.  HTTP worked perfectly first time.  I don't know why but it may have something to do with my usb ethernet adapter.

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
C1000 And Openbsd
« Reply #10 on: April 23, 2007, 04:26:20 pm »
Found a japanese site with detailed guide on setting up OpenBSD on C1000:

http://www10.ocn.ne.jp/~a.koba/openbsd/zaurus.html

But it's all in Japanese, so no use to me for now.  

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

cal

  • Full Member
  • ***
  • Posts: 112
    • View Profile
C1000 And Openbsd
« Reply #11 on: April 23, 2007, 04:37:20 pm »
I actually got it to work fine...  I guess I should have posted that.  I'm not an OpenBSD expert yet so I was better off using linux, which of course we all knew from the beginning.  I did however,  get everything set up the way I liked it and was able to use OBSD for a week or so before I had some sort of crash.  I had to shut down without running a halt, and  I could never get my installation to boot again.  About that time the announcement was made that SD actually working, so I looked into that for awhile and ultimately decided to wait until a official release was made.  In the mean time I'm using pdaXrom
« Last Edit: April 23, 2007, 04:37:45 pm by cal »

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
C1000 And Openbsd
« Reply #12 on: April 23, 2007, 05:04:14 pm »
Oh that sounds scary enough.
May i ask what has actually happened?
But anyhow i will surely use my 3200 with OpenBSD on the microdrive once it arrives.  

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

mathemajikian

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
    • http://exit3.i-55.com/~xikon/openbsdzaurus.html
C1000 And Openbsd
« Reply #13 on: April 24, 2007, 07:16:52 am »
Quote
Found a japanese site with detailed guide on setting up OpenBSD on C1000:

http://www10.ocn.ne.jp/~a.koba/openbsd/zaurus.html

But it's all in Japanese, so no use to me for now.   

Here's a translated version of the page:  Translated Installing OpenBSD/Zaurus on the C1000

 But look at the section near the end titled "Trying installing to SL-C1000."  He seems to be stating what you would see during the OBSD installation process if you could get the OBSD kernel to boot on the C1000.
« Last Edit: April 24, 2007, 07:35:19 am by mathemajikian »