Author Topic: Sl-7500c 128m Flash Upgrade Failed!  (Read 32410 times)

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« on: September 18, 2006, 11:05:16 pm »
Last week I opened my Zaurus SL-7500C and replaced the Flash chip with a K9F1G08UOM. (My original chip is also K9F... the only difference is the capacity).

I carefully checked the pins to make sure they are properly connected. Then I booted to the Service Menu using Fn+D+M. The up-right corner of Sevice Menu shows "SL-C760". But the chip wasn't properly recognized. Clicking on the version list gave me the following information:
 
CPU: PXA255 A0
Board: c760
Serial No: 00000b0d
ROM Checksum: bca1
RAM Size: 65536KB
NAND modules(0MB)
unknown[unknown]

I tried all the NAND Flash related command (NAND restore and NAND Full Erase) in the service menu and they all gave me an "Error -2". Restoring NAND backup or installing U-Boot didn't work either.

I can't put back my original chip because I damaged it when I removed it. (There must be some glue under the chip.) So basically my 7500 is dead.

I heard that somebody has successfully upgraded their Flash chip. So maybe he can share his experience with me. I'd be very appreciated.
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

Reaper

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #1 on: September 19, 2006, 12:33:02 am »
I'm going to upgrade my C3000 and the first thing I care about is to SAVE THE ORIGINAL CHIP. I think that hot air blower with careful temperature adjusting will help to melt the glue and save the chip, maybe at 200 C or a little bit higher (chip won't desolder at temperatures lower than 180 C, if I'm correct).

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #2 on: September 19, 2006, 04:11:18 am »
Quote
I'm going to upgrade my C3000 and the first thing I care about is to SAVE THE ORIGINAL CHIP. I think that hot air blower with careful temperature adjusting will help to melt the glue and save the chip, maybe at 200 C or a little bit higher (chip won't desolder at temperatures lower than 180 C, if I'm correct).
[div align=\"right\"][a href=\"index.php?act=findpost&pid=141765\"][{POST_SNAPBACK}][/a][/div]

It was so difficult to remove the original chip from the board. I didn't have any trouble when I removed the chip I was going use from a USB key drive, but blowing the chip off Zaurus is another story.

Let me know when you finish the upgrade work. I still want to know whether the new chip is supposed to be recognized automatically.
« Last Edit: September 19, 2006, 04:12:09 am by wrc4 »
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

Hrw

  • Hero Member
  • *****
  • Posts: 1366
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #3 on: September 19, 2006, 08:10:58 am »
wrc4: you probably need to use same chip as the one in c760/c860 because sharp bootloader (which initialize chip) has it hardcoded rather.
OpenZaurus 3.5.4x Release Manager
OpenEmbedded, Ångström, Poky developer
My website

Misc embedded hardware.

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #4 on: September 19, 2006, 09:08:46 am »
Quote
wrc4: you probably need to use same chip as the one in c760/c860 because sharp bootloader (which initialize chip) has it hardcoded rather.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=141782\"][{POST_SNAPBACK}][/a][/div]

That's what I'm afraid of: If the code is in the EEPROM. there will be no way to upgrade it. That would also mean the bootloader in my 7500C is the same or at least very similar to that of a C760. (The most confusing part is the Service Menu says my Zaurus is a C760, but the only thing I changed is the Flash chip).

Does anyone want to open his/her C760 and tell me the exact model of the Flash chip? I really wonder what is the difference between the SAMSUNG chips (K9K, K9F, etc.). Is there a way to trick one model into another? I heard that the Flash of some Windows CE PDAs (like the iPaq hx4700) can be easily upgraded.
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #5 on: September 22, 2006, 05:50:25 am »
I found a same 64MB chip as the previous one and soldered it back. (Thanks Jason for giving me your old USB drive.) Now my 7500 is up and running again. (With a bad block in the flash, thanks Jason again for using it so HARD...)

So one conclusion is that K9F1G08UOM does NOT work on SL-7500C (and may be the same thing is true for SL-C750).
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

chyang

  • Sr. Member
  • ****
  • Posts: 270
    • View Profile
    • http://mail.ustc.edu.cn/~chyang/
Sl-7500c 128m Flash Upgrade Failed!
« Reply #6 on: September 22, 2006, 06:08:17 am »
Wow, so cool.
I even asked the maker on this repair issue, they cannot provide since they don't have the flash chip.
But you made it.
Flash chip may have different sector size in organization. It seems that RAM may be a little easier.
SL-C3200+Symbol CF WIFI+Corsair 2GB SD
SL-5500+Sharp-3.13 ROM+Viking 512MB CF+Kinston 256MB SD
[img]http://sunsetyang.googlepages.com/c3200.gif\" border=\"0\" class=\"linked-sig-image\" /][img]http://sunsetyang.googlepages.com/5500.gif\" border=\"0\" class=\"linked-sig-image\" /]
Socket CF Bluetooth + EagleTec CF Lan Card + EagleTec CF Modem
Histroy:
[SL-C3000 Cacko 1.23 Beta 1] Sold on 2006/07/27
MA701 CF WIFI + EagleTec CF Bluetooth + D-Link DCF-660W WIFI
[SL5500+Sharp-3.13 ROM+SimpleTech 64MB CF+Hagiwara 128MB SD] Lost on 18,March,04

pelrun

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
Sl-7500c 128m Flash Upgrade Failed!
« Reply #7 on: September 22, 2006, 09:36:01 am »
What was the full code on the original chip? When I looked at the datasheet I'm pretty sure that different K9F's can report different chip ID's - which would definitely make your Z unable to recognise the chip even if it's otherwise compatible.
SL-C3100 with usb power mod running debian eabi
pdaXii13 still on the NAND for dualbooting
16GB SDHC! (a new one, after I sat on the old one and it went kaput)
D-Link 660 wifi, Socket Bluetooth rev H
External 9800mAh LiIon battery and slimline dvd drive
Homebrew microphone and remote

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #8 on: September 22, 2006, 08:52:36 pm »
pelrun,

The full code is:
K9F1G08UOM YCBO

I will try to look at the datasheet and compare the difference between the chips. (I really should have done this BEFORE changine the chip)

chyang,

You can easily find such a chip in an old "LG" branded USB disk. The 128M model usually has two of such chips.
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

pelrun

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
Sl-7500c 128m Flash Upgrade Failed!
« Reply #9 on: September 22, 2006, 11:49:08 pm »
No, I meant the original chip from your Z, you already mentioned the one you replaced it with
SL-C3100 with usb power mod running debian eabi
pdaXii13 still on the NAND for dualbooting
16GB SDHC! (a new one, after I sat on the old one and it went kaput)
D-Link 660 wifi, Socket Bluetooth rev H
External 9800mAh LiIon battery and slimline dvd drive
Homebrew microphone and remote

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #10 on: September 23, 2006, 04:54:25 am »
Quote
No, I meant the original chip from your Z, you already mentioned the one you replaced it with
[div align=\"right\"][a href=\"index.php?act=findpost&pid=142096\"][{POST_SNAPBACK}][/a][/div]

Sorry:
K9F1208UOM YCBO

It's really just the size difference. Every other code is the same.
« Last Edit: September 23, 2006, 05:05:46 am by wrc4 »
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

pelrun

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
Sl-7500c 128m Flash Upgrade Failed!
« Reply #11 on: September 23, 2006, 12:04:26 pm »
From the datasheets, the K9F1208UOM ID is 76C0, but the K9F1G08UOM's is F115 - the Z would be querying the ID and giving up on the unfamiliar one, even if the chips are functionally identical.

The only real way to get it to work in that case would be to cram in a microcontroller to intercept the new ID and inject the old one in a similar fashion as a console modchip does.

It might also be possible to patch the in-flash version of the firmware to replace the ID with the newer one - though if that worked you couldn't use the Fn+D+M menu (as it's in ROM) to save you from a bad subsequent flashing...
SL-C3100 with usb power mod running debian eabi
pdaXii13 still on the NAND for dualbooting
16GB SDHC! (a new one, after I sat on the old one and it went kaput)
D-Link 660 wifi, Socket Bluetooth rev H
External 9800mAh LiIon battery and slimline dvd drive
Homebrew microphone and remote

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #12 on: September 23, 2006, 08:36:47 pm »
Quote
From the datasheets, the K9F1208UOM ID is 76C0, but the K9F1G08UOM's is F115 - the Z would be querying the ID and giving up on the unfamiliar one, even if the chips are functionally identical.

The only real way to get it to work in that case would be to cram in a microcontroller to intercept the new ID and inject the old one in a similar fashion as a console modchip does.

It might also be possible to patch the in-flash version of the firmware to replace the ID with the newer one - though if that worked you couldn't use the Fn+D+M menu (as it's in ROM) to save you from a bad subsequent flashing...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=142124\"][{POST_SNAPBACK}][/a][/div]

Is there any way to patch the in-flash version of the firmware? Can it be done by running some scripts in the SD or CF card or by connecting to the serial port? Since the Fn+D+M is rarely used and even if it's needed, we can restore the original fireware and patch it again. I wonder how much we can do with the Service Menu.

The good thing is, if we can modify the firmware, we might be able to use even larger flash chips--maybe a 1GByte one.
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)

pelrun

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
Sl-7500c 128m Flash Upgrade Failed!
« Reply #13 on: September 23, 2006, 10:30:50 pm »
How would you replace the firmware if you need the Fn+D+M menu to do it and it doesn't recognise your flash?

Not to mention the whole problem of getting the firmware on there in the first place - though if you were scavenging the chip from a USB key you could probably use it to write the raw firmware to the chip before transplanting it.

Come to think of it, the Z would be using the ROM copy as a first stage bootloader, so you're probably SOL already - can't read the flash until you've already got some code loaded that lets you read the flash, and that code is in the flash. Ouch.
SL-C3100 with usb power mod running debian eabi
pdaXii13 still on the NAND for dualbooting
16GB SDHC! (a new one, after I sat on the old one and it went kaput)
D-Link 660 wifi, Socket Bluetooth rev H
External 9800mAh LiIon battery and slimline dvd drive
Homebrew microphone and remote

wrc4

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Sl-7500c 128m Flash Upgrade Failed!
« Reply #14 on: September 23, 2006, 11:37:47 pm »
Quote
How would you replace the firmware if you need the Fn+D+M menu to do it and it doesn't recognise your flash?

Not to mention the whole problem of getting the firmware on there in the first place - though if you were scavenging the chip from a USB key you could probably use it to write the raw firmware to the chip before transplanting it.

Come to think of it, the Z would be using the ROM copy as a first stage bootloader, so you're probably SOL already - can't read the flash until you've already got some code loaded that lets you read the flash, and that code is in the flash. Ouch.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=142149\"][{POST_SNAPBACK}][/a][/div]

Yes, you're right.

In fact, I would think about building a daughter board just for the flash chip. After all, there are only about 20 out of the 48 pins need to be connected. This way we can change the chip whenever we want and preload the basic boot loader that can recognize the chip. But that's a little far from what I can do now.
Zaurus SL-C1000 (Debian)
Zaurus SL-7500C
Nokia N810
KOHJINSHA SC3
ASUS EEEPC 701
ASUS WL-HDD 2.5
ASUS WL-500GPv2
WD MyBookWorldEdition (with a Segate 500G HD inside)