Author Topic: Terminfo For Console  (Read 3351 times)

iamphet

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
    • http://iamphet.nm.ru
Terminfo For Console
« on: October 03, 2006, 02:43:26 am »
Is there a terminfo definition for the OZ console? I tried to keep TERM unset, set it to linux, xterm, rxvt; Midnight Commander doesn't work correctly in any case.

..bk..

  • Newbie
  • *
  • Posts: 16
    • View Profile
    • http://
Terminfo For Console
« Reply #1 on: October 10, 2006, 09:53:25 am »
Quote
Is there a terminfo definition for the OZ console? I tried to keep TERM unset, set it to linux, xterm, rxvt; Midnight Commander doesn't work correctly in any case.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=142939\"][{POST_SNAPBACK}][/a][/div]

there's a line in/etc/profile setting TERM=vt100, comment that out...

iamphet

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
    • http://iamphet.nm.ru
Terminfo For Console
« Reply #2 on: October 12, 2006, 06:31:01 am »
..bk..
Thanks, now it works far better, although there are some visual artifacts anyway.

Da_Blitz

  • Hero Member
  • *****
  • Posts: 1579
    • View Profile
    • http://www.pocketnix.org
Terminfo For Console
« Reply #3 on: October 16, 2006, 04:15:53 am »
i have min set as TERM=linux (i use bootstarp with no X) and it works great with ncmpc with a config to enable color
Personal Blog
Code
Twitter

Gemini Order: #95 (roughly)
Current Device: Samsung Chromebook Gen 3
Current Arm Devices Count: ~30
Looking to acquire: Cavium Thunder X2 Hardware

..bk..

  • Newbie
  • *
  • Posts: 16
    • View Profile
    • http://
Terminfo For Console
« Reply #4 on: October 16, 2006, 12:24:53 pm »
Quote
i have min set as TERM=linux (i use bootstarp with no X) and it works great with ncmpc with a config to enable color
[div align=\"right\"][a href=\"index.php?act=findpost&pid=144085\"][{POST_SNAPBACK}][/a][/div]

with commenting out the TERM=vt100 line in /etc/profile,  TERM is set to "rxvt" by, ha, rxvt. (i use gpe) this works quite ok.

PS: for some console apps the default font size is still to big (vi for instance),  so you get garbeld output when wrapping lines around. i have it set to 14, this seems small enough for vi and big enough for me ;-)

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Terminfo For Console
« Reply #5 on: October 16, 2006, 03:33:39 pm »
Quote
Is there a terminfo definition for the OZ console? I tried to keep TERM unset, set it to linux, xterm, rxvt; Midnight Commander doesn't work correctly in any case.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=142939\"][{POST_SNAPBACK}][/a][/div]
hmm, I set mine to "xterm" in /etc/profile and MidnightCommander works fine, also Kismet runs in color as well.

Cheers
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

..bk..

  • Newbie
  • *
  • Posts: 16
    • View Profile
    • http://
Terminfo For Console
« Reply #6 on: October 16, 2006, 07:32:37 pm »
Quote
hmm, I set mine to "xterm" in /etc/profile and MidnightCommander works fine, also Kismet runs in color as well.

Cheers
[div align=\"right\"][a href=\"index.php?act=findpost&pid=144115\"][{POST_SNAPBACK}][/a][/div]

hm, i think "xterm" vs "rxvt" doesn't quite make a difference...