Author Topic: Pdaxii13 On Nand  (Read 76750 times)

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 On Nand
« Reply #60 on: February 08, 2007, 11:09:19 pm »
Quote
You're the man.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153554\"][{POST_SNAPBACK}][/a][/div]

i also recompiled xterm so it doesn't look so odd anymore and no more missing font warning...
meh, now have to reupload everything again, sigh...
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

HoloVector

  • Hero Member
  • *****
  • Posts: 533
    • View Profile
    • http://
Pdaxii13 On Nand
« Reply #61 on: February 08, 2007, 11:11:35 pm »
Quote
Quote
You're the man.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153554\"][{POST_SNAPBACK}][/a][/div]

i also recompiled xterm so it doesn't look so odd anymore and no more missing font warning...
meh, now have to reupload everything again, sigh...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153556\"][{POST_SNAPBACK}][/a][/div]
Thanks Meanie for all your hard work.  We really appreciate it.
I think I'm coming down with what kahm's got!  I now have 3 Zaurii in house!  ;)
Current: Zaurus SL-C3200 -  Bobby (Configuring pdaXii13 Akita with Full 5.4.9 upgrade running IceWM)
Zaurus SL-C1000 - Hachiko (Configuring Cacko 1.23 with evilJazz's new kernel)
Zaurus SL-C860 - Fett (Customized Cacko 1.23 with handmade Boba Fett Theme)
Symbol WiFi CF card|Buffalo WiFi CF Card|Buffalo Ethernet CF Card|Red Piel Frama Case|PDAir Case|Black Pelican 1020 Case|Pentopia Stylii|SaruTek Protectors|Transcend SDs (4GB 150X, 1GB 80X, 256MB 45X, 128MB 45X)|2GB PNY SD|2GB SanDisk SD|Transcend CFs (1GB 80X, 512MB 80X)|Sandisk CFs (4GB, 512MB, 256MB)|256MB Netac USB-CF|RH-1 Remote
Check out the ScummVM@tyrannozaurus page if you are an "adventurer" type of person.

Raul

  • Full Member
  • ***
  • Posts: 133
    • View Profile
Pdaxii13 On Nand
« Reply #62 on: February 09, 2007, 01:16:58 am »
Quote
i also recompiled xterm so it doesn't look so odd anymore and no more missing font warning...
meh, now have to reupload everything again, sigh...
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153556\"][{POST_SNAPBACK}][/a][/div]
If I see your nick I know there will be good news  Thanks for doing such a great job for this community

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Pdaxii13 On Nand
« Reply #63 on: February 09, 2007, 03:14:51 am »
Can it hurt to have too many thanks?  

Wow!  Truly outstanding work....
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 On Nand
« Reply #64 on: February 09, 2007, 04:21:54 am »
folks... may I present to you pdaXii13 Akita (Sally) 5.3

this release is considered stable and does not have module dependency errors any more and will correctly detect the internal MicroDrive if you have one of course
it fixes most annoying bugs (the one that annoy me at least) in beta3 including the xterm

http://www.tyrannozaurus.com/feed/pdaXii13/akita/
« Last Edit: February 09, 2007, 04:29:00 am by Meanie »
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

matthis

  • Full Member
  • ***
  • Posts: 217
    • View Profile
    • http://badaboum.bidibom.free.fr/mat/
Pdaxii13 On Nand
« Reply #65 on: February 09, 2007, 04:24:35 am »
Woohoo! Thank you so much!

psycoman

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
    • http://www.tuxforum.com.br
Pdaxii13 On Nand
« Reply #66 on: February 09, 2007, 05:01:45 am »
Meanie / Antik

Just a idea.

Why not create a wiki, to put all info about pdaxii13 together ?

xD

and im tryind this version write now.

psycoman

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
    • http://www.tuxforum.com.br
Pdaxii13 On Nand
« Reply #67 on: February 09, 2007, 05:06:33 am »
I flahsed it write now and i give this error:

grep: error while loading shared libraries: libpcre.so.0 .... File not found...

to fix this, just press ctrl-c and install pcre xD

Warnings

1 - My hda1 is empty and when pdaxii13 try to mount show a mount error, can make check after mount and show a mensage, like, no hdimage installed os something like


Menaie, another question how i can remove scim from hdfull image instalation ?
« Last Edit: February 09, 2007, 05:18:26 am by psycoman »

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 On Nand
« Reply #68 on: February 09, 2007, 05:42:00 am »
Quote
I flahsed it write now and i give this error:

grep: error while loading shared libraries: libpcre.so.0 .... File not found...

to fix this, just press ctrl-c and install pcre xD

Warnings

1 - My hda1 is empty and when pdaxii13 try to mount show a mount error, can make check after mount and show a mensage, like, no hdimage installed os something like


Menaie, another question how i can remove scim from hdfull image instalation ?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153572\"][{POST_SNAPBACK}][/a][/div]

hdimage-full.tgz has not finished uploading yet, so you could not have possibly installled it already. only the initrd.bin which is pdaXii13 Akita base has finished uploading so far...

use Package Manager to remove packages, just remove all packages that have scim in the package name..
« Last Edit: February 09, 2007, 05:42:29 am by Meanie »
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

ntrolls

  • Newbie
  • *
  • Posts: 22
    • View Profile
Pdaxii13 On Nand
« Reply #69 on: February 09, 2007, 05:45:16 am »
Thank you Meanie, this version works perfectly with my C1000.

One thing though. Scim works with Qt apps, but not with GTK ones. What I did was:

- Installed a Korean TTF font
- Installed scim-hangul
- Modified /etc/sysconfig/locale with "export LANG=ko_KR.UTF-8"

SCIM is loaded successfully, but control+space does not work at all with GTK apps. Where should I look?
SL-C1000/pdaXii13

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 On Nand
« Reply #70 on: February 09, 2007, 05:57:55 am »
Quote
Thank you Meanie, this version works perfectly with my C1000.

One thing though. Scim works with Qt apps, but not with GTK ones. What I did was:

- Installed a Korean TTF font
- Installed scim-hangul
- Modified /etc/sysconfig/locale with "export LANG=ko_KR.UTF-8"

SCIM is loaded successfully, but control+space does not work at all with GTK apps. Where should I look?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153576\"][{POST_SNAPBACK}][/a][/div]

what do the following commands show:

env | grep scim

grep scim /etc/gtk-2.0/gtk.immodules
« Last Edit: February 09, 2007, 06:04:35 am by Meanie »
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

psycoman

  • Jr. Member
  • **
  • Posts: 75
    • View Profile
    • http://www.tuxforum.com.br
Pdaxii13 On Nand
« Reply #71 on: February 09, 2007, 06:26:19 am »
Menaie this is a great thing to mount hda2 as swap or additional data partion, very very nice this xD, but if mount fail this show error message, i think you forget the /dev/null

Code: [Select]
mount -t ext3 -o rw,noatime,umask=000,iocharset=utf8 ${MDD}2 /mnt/ide2 2> /dev/null
sorry my very very bad english  
« Last Edit: February 09, 2007, 06:28:03 am by psycoman »

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 On Nand
« Reply #72 on: February 09, 2007, 06:40:11 am »
Quote
Menaie this is a great thing to mount hda2 as swap or additional data partion, very very nice this xD, but if mount fail this show error message, i think you forget the /dev/null

Code: [Select]
mount -t ext3 -o rw,noatime,umask=000,iocharset=utf8 ${MDD}2 /mnt/ide2 2> /dev/null
sorry my very very bad english 
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153580\"][{POST_SNAPBACK}][/a][/div]

oh no! you already found a tiny bug  
too bad for 3100/3200 users, you will need to apply a patch
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

ntrolls

  • Newbie
  • *
  • Posts: 22
    • View Profile
Pdaxii13 On Nand
« Reply #73 on: February 09, 2007, 06:54:37 am »
Quote
what do the following commands show:

env | grep scim

grep scim /etc/gtk-2.0/gtk.immodules
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153578\"][{POST_SNAPBACK}][/a][/div]

Code: [Select]
root:-)env | grep scim
QT_IM_MODULE=scim
GTK_IM_MODULE=scim

root:-)grep scim /etc/gtk-2.0/gtk.immodules
"/usr/lib/gtk-2.0/2.4.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" "*"

Seems OK to me. Thank you for the quick response.
SL-C1000/pdaXii13

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 On Nand
« Reply #74 on: February 09, 2007, 06:58:01 am »
Quote
Quote
what do the following commands show:

env | grep scim

grep scim /etc/gtk-2.0/gtk.immodules
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153578\"][{POST_SNAPBACK}][/a][/div]

Code: [Select]
root:-)env | grep scim
QT_IM_MODULE=scim
GTK_IM_MODULE=scim

root:-)grep scim /etc/gtk-2.0/gtk.immodules
"/usr/lib/gtk-2.0/2.4.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" "*"

Seems OK to me. Thank you for the quick response.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153582\"][{POST_SNAPBACK}][/a][/div]

is the size of /usr/lib/libgtk-x11-2.0.so.0.600.2 exactly 2272576 ?
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K