Author Topic: Libgcc: How To Replace?  (Read 4963 times)

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Libgcc: How To Replace?
« on: February 10, 2007, 10:57:48 pm »
I didn't quite know where to post this info or ask for help, and this seemed like the best place to do so, so forgive me if this is off-topic.

I've successfully recompiled the gcc3.4.5 suite to include the g77 fortran compiler natively on pdaxrom.  I'm very new to building gcc from source, and it's a little overwhelming, so it took me several tries to configure to a point of semi-usability, wherein the "g77" command could actually produce object code (*.o).

I did this using the pdaxrom gcc3.4.5 cross compiler for x86.   However, it does not seem to work with the existing libgcc AFAIK, giving linker errors, and keeping  certain applications as "qpkg" from running until the compiler is un-installed.

Does anyone have any advice about rebuilding gcc for an existing platform such as pdaxrom?  I'm fairly aware that OpenZaurus already has this working, so it is not my intention to do so for that platform, I'm just trying to focus on pdaxrom.

My questions are:
* What purpose exactly does "libgcc" serve natively?  
* What effect does it have to replace the existing library?
* How can I replace the existing "libgcc" or link to it with the g77 compiler?
* Is there a simple way to get OE to do this for me?
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus

koen

  • Hero Member
  • *****
  • Posts: 1008
    • View Profile
    • http://dominion.thruhere.net/koen/cms/
Libgcc: How To Replace?
« Reply #1 on: February 11, 2007, 03:51:19 am »
Quote
I didn't quite know where to post this info or ask for help, and this seemed like the best place to do so, so forgive me if this is off-topic.

[div align=\"right\"][a href=\"index.php?act=findpost&pid=153786\"][{POST_SNAPBACK}][/a][/div]

Try asking it on the openembedded devel mailinglist, where it is appropriate.
Forums are not bugtrackers!!! Smart questions
Ångström release team
iPAQ h2210, iPAQ h5550, iPAQ hx4700, Zaurus SL-C700, Nokia 770, all running some form of GPE
My blog

radiochickenwax

  • Full Member
  • ***
  • Posts: 158
    • View Profile
Libgcc: How To Replace?
« Reply #2 on: February 11, 2007, 03:56:24 pm »
Quote
Quote
I didn't quite know where to post this info or ask for help, and this seemed like the best place to do so, so forgive me if this is off-topic.

[div align=\"right\"][a href=\"index.php?act=findpost&pid=153786\"][{POST_SNAPBACK}][/a][/div]

Try asking it on the openembedded devel mailinglist, where it is appropriate.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=153791\"][{POST_SNAPBACK}][/a][/div]

Okay, sorry to clutter up this thread.  I just thought we might all benefit from this type of info.
« Last Edit: February 11, 2007, 04:15:05 pm by radiochickenwax »
ZAURII:    sl-6000 : (temporarily) bricked pdaxrom b1   ||   sl-c3200 : yonggun/Debian-EABI
OTHERS:  htc-excalibur,  axim x5,  ipaq 4355, (still trying to find useable linux setups)
thinking about gumstix to replace/augment zaurus