Author Topic: Keyboard Not Working On C1000....  (Read 2417 times)

Ragnorok

  • Sr. Member
  • ****
  • Posts: 296
    • View Profile
    • http://
Keyboard Not Working On C1000....
« on: April 04, 2007, 01:51:24 pm »
- The day before yesterday Hiro, my C1k, started rotating to portrait every time I turned him on.  Today, the keyboard stopped working, and won't respond even after popping the battery.
- I pressed the little switch that tells the Z it's screen has been folded down, and it seems that is working only intermittently, so it thinks it should go to portrait because the switch isn't right.
- I've no clue on the keyboard.  It's just dead.
- Otherwise the unit appears to work perfectly.  Touch screen, backlight, expansion slots, USB, everything works like a charm.
- Any hints on what I might do to troubleshoot this?  I'm thinking disassembly, but don't want to just rip into it without a plan of action.
- After reading about the production stop, I'm wondering if Hiro isn't just depressed.  (wry grin) Thanks for your time...

EDIT: Aha!  They are one in the same.  The portrait mode switch disables the keyboard.  I'm still thinking dismantle and clean, and I'm still soliciting input...
« Last Edit: April 04, 2007, 02:07:03 pm by Ragnorok »
| I shed a tear for the passing of Hiroshi; he served me well
| Zaurus zealot since Nov 2002, PDA user since Oct 1991
| Replaced Z with UMID BZ February 2010

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Keyboard Not Working On C1000....
« Reply #1 on: April 04, 2007, 05:27:08 pm »
I'm not sure if this will help.
Rotate the screen 90ยบ from "laptop" mode and check if the screws in the hinge are loose.
These screws are recessed in the flat chrome part that is usually not visible. (It's covered by the screen bezel).
I checked my C3100, after only about 1 year's use, and the 2 hinge screws were loose.
I used an eyeglass screwdriver to tighten them.
« Last Edit: April 04, 2007, 05:27:35 pm by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

Ragnorok

  • Sr. Member
  • ****
  • Posts: 296
    • View Profile
    • http://
Keyboard Not Working On C1000....
« Reply #2 on: April 05, 2007, 02:08:25 pm »
- I can reach three of the four and none are loose.  Thanks for the suggestion, Jon_J!
| I shed a tear for the passing of Hiroshi; he served me well
| Zaurus zealot since Nov 2002, PDA user since Oct 1991
| Replaced Z with UMID BZ February 2010

TRIsoft

  • Sr. Member
  • ****
  • Posts: 332
    • View Profile
    • http://www.trisoft.de
Keyboard Not Working On C1000....
« Reply #3 on: April 06, 2007, 04:19:22 am »
Hi Raganorok,

while you've disassembled the Zaurus so far, try to
check the two microswitches on the mainboard.
Maybe it's just a bit dirt blocking the switch.

Also the keyboard test in the diagnostics menu is
very helpful in such cases.

And regarding that your Zaurus just maybe depressed
about the production stop, you should read the thread
again ;-)
End of production ?

///TRIsoft

Marc Stephan

Ragnorok

  • Sr. Member
  • ****
  • Posts: 296
    • View Profile
    • http://
Keyboard Not Working On C1000....
« Reply #4 on: April 06, 2007, 04:11:08 pm »
- Never thought about that pesky diagnostic menu.  I'll give that a whirl to confirm my suspicion (?) about the switches before ripping the whole thing apart.  I view that with more than a little trepidation.  The last low-power device I disassembled I managed to zatch it ... dead as a doornail.  (whimper)  Then again, that could be a prime reason to get a 3200!  (bemused grin)  Still and all, I'd hate to have something happen to Hiroshi.  He's been a good little unit.
- Then again Hiro's been fine since yesterday.  Maybe the continued production vibes just perked him up?  (heh heh)
- Thanks for the info, TRIsoft!...
| I shed a tear for the passing of Hiroshi; he served me well
| Zaurus zealot since Nov 2002, PDA user since Oct 1991
| Replaced Z with UMID BZ February 2010