Author Topic: Pdaxii13 5.4.8 Hostap And Wpa  (Read 2972 times)

Lemuus

  • Newbie
  • *
  • Posts: 35
    • View Profile
Pdaxii13 5.4.8 Hostap And Wpa
« on: August 09, 2007, 09:28:58 pm »
I was testing the new 5.4.8 release, and wpa is not working with the new modules, i am not  sure what is the problem... but if i use the hostap modules from 5.4.7 works perfect.
I also tested the new spca module, works with my camera with a lot of interference, but works!!!!
well that's for the moment...
Daniel.

danboid

  • Hero Member
  • *****
  • Posts: 881
    • View Profile
    • http://
Pdaxii13 5.4.8 Hostap And Wpa
« Reply #1 on: August 10, 2007, 12:31:42 pm »
Anybody else having problems with wpa under 5.4.8?
Zaurus SL-C3000 w/ MD swapped for a Kingston 32GB Ultimate 266X CF running ALARM
Banana Pi running ALARM on a WD Scorpio SATA II HD
System76 Gazelle Pro i7 laptop w/ SAMSUNG 840 EVO SSD running Arch x64

How to install Arch on your C3x00 Zaurus https://github.com/danboid/ZALARM-install

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 5.4.8 Hostap And Wpa
« Reply #2 on: August 11, 2007, 05:27:16 am »
Quote
I was testing the new 5.4.8 release, and wpa is not working with the new modules, i am not  sure what is the problem... but if i use the hostap modules from 5.4.7 works perfect.
I also tested the new spca module, works with my camera with a lot of interference, but works!!!!
well that's for the moment...
Daniel.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=166023\"][{POST_SNAPBACK}][/a][/div]

did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

Lemuus

  • Newbie
  • *
  • Posts: 35
    • View Profile
Pdaxii13 5.4.8 Hostap And Wpa
« Reply #3 on: August 11, 2007, 08:37:45 pm »
Quote
did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=166075\"][{POST_SNAPBACK}][/a][/div]

yes and yes, i copy the old hostap modules from 5.4.7 on top of 5.4.8, and used the updated tools.tar.

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 5.4.8 Hostap And Wpa
« Reply #4 on: August 11, 2007, 10:26:45 pm »
Quote
Quote
did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=166075\"][{POST_SNAPBACK}][/a][/div]

yes and yes, i copy the old hostap modules from 5.4.7 on top of 5.4.8, and used the updated tools.tar.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=166101\"][{POST_SNAPBACK}][/a][/div]

hmm, I will test again with the older hostap modules to see if they work too and if so, will make them default instead.
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13 5.4.8 Hostap And Wpa
« Reply #5 on: August 12, 2007, 01:56:26 am »
Quote
Quote
Quote
did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=166075\"][{POST_SNAPBACK}][/a][/div]

yes and yes, i copy the old hostap modules from 5.4.7 on top of 5.4.8, and used the updated tools.tar.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=166101\"][{POST_SNAPBACK}][/a][/div]

hmm, I will test again with the older hostap modules to see if they work too and if so, will make them default instead.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=166105\"][{POST_SNAPBACK}][/a][/div]

I confirm that the hostap modules from 5.4.7 work perfectly for scanning and cards like the netgear are assigned to wlan0 instead of eth0 even with the older modules, hence the fixes must have come from the new kernel and the updated wireless tools.

Use this ipk to downgrade your hostap modules so that everything will work.
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K