Author Topic: Angstrom Status On Tosa  (Read 46318 times)

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Angstrom Status On Tosa
« Reply #30 on: November 21, 2008, 10:50:09 am »
Quote from: LeTic
Sorry to post on a dead post but I just wanted to let you know that after lots of debugging from Dmitry he finally manage to solve the 2.6.24 bug on the tosa kernel.

It is available here : http://tosa.lumag.spb.ru/uploads/tosa-stable-images/debug/

So now Angström is booting back with the r19 image. But with that image the backlight doesn't seems to work on my tosa. I haven't tried other images yet though to check.

Discussion on the topic can be found here : http://lists.linuxtogo.org/pipermail/angst...ber/002737.html

More information on Dmitry's tosa page : http://tosa.lumag.spb.ru/news/17/55/Status-update.html

good news late is still good news! does that means the backlight is stuck ON or OFF?
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

LeTic

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://www.letic.fr
Angstrom Status On Tosa
« Reply #31 on: November 21, 2008, 11:54:26 am »
Quote from: speculatrix
good news late is still good news! does that means the backlight is stuck ON or OFF?
Hey Speculatrix,

It was always stuck off, that's why it was unusable   Anyway while I was posting this, Dmitry released a new kernel with a fix at the same place so now you can test the latest Angstrom on the tosa.

Honestly I haven't had the time to try anything on it yet, so I can't tell you if it's good or not but it's still means a working 2.6.24 kernel on tosa !

Anyway if people could have a go with it, I bet Dmitry could do with more tosa users testings.
Zaurus SL 6000L - Hitachi Microdrive 4Go
Sharp ROM with Debian PocketWorkstation XFCE | Angström

PC on Debian Sid
www.letic.fr

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Angstrom Status On Tosa
« Reply #32 on: November 23, 2008, 06:18:37 pm »
http://www.angstrom-distribution.org/relea...2007.12/images/
doesn't seem to list tosa at all! where can I find a tosa firmware image I can flash please?
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

LeTic

  • Newbie
  • *
  • Posts: 21
    • View Profile
    • http://www.letic.fr
Angstrom Status On Tosa
« Reply #33 on: November 24, 2008, 05:04:33 am »
Hey Speculatrix,

Sorry I should have specified

Tosa hasn't been a supported plateform during the latest stable release for lack of maintainers to solve the tosa specific issues. But you can find the 2007.12 r8 images here :
http://www.angstrom-distribution.org/unstable/images/tosa/ which are the last know working images with 2.6.23 kernels. The 2007.12 r9 marked the switch to 2.6.24 and a massive tosa breakage that has just been solved by Dmitry.

You can find all images incudling the new OPIE images here : http://www.angstrom-distribution.org/unsta...autobuild/tosa/ (use the installkits)

It seems the new kernel from Dmitry hasn't been committed yet so you will find the zimage from here : http://tosa.lumag.spb.ru/uploads/tosa-stable-images/debug/

I know you don't need the instructions as you are an experienced tosa users  but in case somebody needs them :

1. For GPE download : http://www.angstrom-distribution.org/unsta...-installkit.tgz
    For OPIE download : http://www.angstrom-distribution.org/unsta...-installkit.tgz
2. Download the alternative kernel from Dmitry : http://tosa.lumag.spb.ru/uploads/tosa-stab...zImage-tosa.bin
3. Rename it to zimage.bin
4. Extract the installkit
5. Replace the zimage.bin by the one from Dmitry
6. Put the files on a FAT formatted CF or SD
7. Reset with the stylus.
8. Press OK while pressing the ON button
9. Choose Update and then CF or SD
10. After the flashing it should reboot automatically
11. Test Angstrom

Let me know if you have any issues
LeTic
Zaurus SL 6000L - Hitachi Microdrive 4Go
Sharp ROM with Debian PocketWorkstation XFCE | Angström

PC on Debian Sid
www.letic.fr

undrwater

  • Full Member
  • ***
  • Posts: 232
    • View Profile
    • http://
Angstrom Status On Tosa
« Reply #34 on: November 24, 2008, 02:00:50 pm »
OK...I had forgotten about the autobuild directory.  I tried the new kernel with the older installkits, so I'm assuming that's why things like sound and backlight are not impacted by Opie or GPE.

Aside from that, things look REALLY good!  Response is very snappy, boot time is short, suspend works (though needs "Menu | Suspend" to go into suspend, button brings out of suspend).  Today I'll try the autobuild rootfs's to see what the difference is.

Excellent work Dmitri!!  

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Angstrom Status On Tosa
« Reply #35 on: November 24, 2008, 06:02:56 pm »
first time it booted, it stuck on the line printed before INIT, but this time looks better.  

--edit-- hm, doesn't seem to suspend. is that normal?


memo to self: fix wonky LCD cable!
« Last Edit: November 24, 2008, 06:05:44 pm by speculatrix »
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

undrwater

  • Full Member
  • ***
  • Posts: 232
    • View Profile
    • http://
Angstrom Status On Tosa
« Reply #36 on: November 24, 2008, 06:21:16 pm »
Quote from: speculatrix
--edit-- hm, doesn't seem to suspend. is that normal?

It suspended for me using the menu (QPE, or Opie); not with the button.  Comes out of suspend via the button, however.

Still no access to increasing / decreasing backlight via settings on either opie or gpe, haven't tested sound through alsa(mixer, player, etc...), but wifi is working (open network at least)!

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Angstrom Status On Tosa
« Reply #37 on: November 25, 2008, 06:26:31 pm »
thanks for that. my frankenzaurus has a loose connection somewhere and the video display has gone funny- upside down and scaled wrongly, so I will open up and have a poke!

computer hardware's been a PITA of late, my wireless NAS's wifi is bust, my sony laptop fan is failing, and my UPS has developed a death-rattle when its fans kick in.
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

lumag

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • http://tosa.lumag.spb.ru
Angstrom Status On Tosa
« Reply #38 on: December 02, 2008, 08:23:09 am »
Quote from: undrwater
Quote from: speculatrix
--edit-- hm, doesn't seem to suspend. is that normal?

It suspended for me using the menu (QPE, or Opie); not with the button.  Comes out of suspend via the button, however.

I'll have to look upon this.

Quote from: undrwater
Still no access to increasing / decreasing backlight via settings on either opie or gpe, haven't tested sound through alsa(mixer, player, etc...), but wifi is working (open network at least)!

I've committed the fix for the opie to .dev branch to support backlight setting. I'll have to look into GPE, but that may need time, as I'm more dedicated to opie for now. The patch should be
pretty easy though (check opie commit).

hakujin

  • Newbie
  • *
  • Posts: 37
    • View Profile
Angstrom Status On Tosa
« Reply #39 on: December 03, 2008, 01:45:30 am »
This may be a bit off topic but I was testing Angstrom on my Tosa but when I tried to reflash my NAND backup it turned out the the backup was bad. Unfortuantely the only NAND backups I have been able to find are Japanese and while that looks cool and all my Japanese is not really up to par. Anyone have a good NAND backup they would be willing to share? Oh yeah also my update menu is still in Japanese even after flashing Angstrom.Thanks
Hentges 2.6 ROM with opie on pxa255 poodle
1GB Kingston SD card
4GB Seagate (photo camera) CF hard drive
SanDisk Connect Plus wifi card
USB cradle to laptop to ethernet bridge to Debian firewall/router/webserver
Wife threatening to leave me if I play around anymore with my Z

lumag

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • http://tosa.lumag.spb.ru
Angstrom Status On Tosa
« Reply #40 on: December 03, 2008, 08:37:55 am »
Quote from: hakujin
Unfortuantely the only NAND backups I have been able to find are Japanese and while that looks cool and all my Japanese is not really up to par.

There are several topics about NAND backups on this forum. Also the page about tosa on www.oesf.org should contain a link to SL-6000 NAND backup. Please take care to check.
« Last Edit: December 03, 2008, 06:45:18 pm by speculatrix »

lumag

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • http://tosa.lumag.spb.ru
Angstrom Status On Tosa
« Reply #41 on: December 03, 2008, 08:42:51 pm »
Quote from: speculatrix
I'm not sure you can ever change the update menu, there's an immutable block of flash for recovery, this is why zaurus is hard to brick.

There is a "diagnostic" menu in ROM, which can not be removed. OTOH "update" menu lies just in bare NAND and can easily be removed (e.g. by installing u-boot).

hakujin

  • Newbie
  • *
  • Posts: 37
    • View Profile
Angstrom Status On Tosa
« Reply #42 on: December 03, 2008, 10:20:00 pm »
Quote from: lumag
Quote from: hakujin
Unfortuantely the only NAND backups I have been able to find are Japanese and while that looks cool and all my Japanese is not really up to par.

There are several topics about NAND backups on this forum. Also the page about tosa on www.oesf.org should contain a link to SL-6000 NAND backup. Please take care to check.

Unfortuantely I have checked and all the links I have been able to find to the sl-6000L NAND backup are broken. I was hoping someone else might have squirreled one away just in case.
Hentges 2.6 ROM with opie on pxa255 poodle
1GB Kingston SD card
4GB Seagate (photo camera) CF hard drive
SanDisk Connect Plus wifi card
USB cradle to laptop to ethernet bridge to Debian firewall/router/webserver
Wife threatening to leave me if I play around anymore with my Z

hakujin

  • Newbie
  • *
  • Posts: 37
    • View Profile
Angstrom Status On Tosa
« Reply #43 on: December 03, 2008, 10:21:16 pm »
Quote from: speculatrix
I'm not sure you can ever change the update menu, there's an immutable block of flash for recovery, this is why zaurus is hard to brick.

trisoft IIRC had downloads of various roms.

Well I have done it. My update menu was in English before but now it is Japanese.
Hentges 2.6 ROM with opie on pxa255 poodle
1GB Kingston SD card
4GB Seagate (photo camera) CF hard drive
SanDisk Connect Plus wifi card
USB cradle to laptop to ethernet bridge to Debian firewall/router/webserver
Wife threatening to leave me if I play around anymore with my Z

lumag

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • http://tosa.lumag.spb.ru
Angstrom Status On Tosa
« Reply #44 on: December 04, 2008, 11:00:39 am »
Quote from: lumag
Quote from: undrwater
Quote from: speculatrix
--edit-- hm, doesn't seem to suspend. is that normal?

It suspended for me using the menu (QPE, or Opie); not with the button.  Comes out of suspend via the button, however.

I'll have to look upon this.
Today the fix went in in the .dev branch. It was just two missed lines in defconfig-tosa. I'll still have to check the keys mappings, check GPE problems etc.
« Last Edit: December 04, 2008, 06:05:03 pm by lumag »