Author Topic: Yet Another Install Image - Testers Wanted!  (Read 17630 times)

Android Zaurus

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://androidzaurus.seesaa.net
Yet Another Install Image - Testers Wanted!
« on: January 22, 2008, 06:54:09 am »
I build an install image of Android for Angstrom Zaurus.

I test it only on my C3000, and I'm hoping here that it will work on any other Zaurus as long as running on Angstrom and some other 2.6.23 based distributions.

An install image of Android for Angstrom - Testers Wanted!
http://androidzaurus.seesaa.net/article/80102284.html

Feedbacks and contributions are very welcome.

Cheers,

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Yet Another Install Image - Testers Wanted!
« Reply #1 on: January 22, 2008, 07:50:55 am »
Quote from: Android Zaurus
I build an install image of Android for Angstrom Zaurus.

I test it only on my C3000, and I'm hoping here that it will work on any other Zaurus as long as running on Angstrom and some other 2.6.23 based distributions.

An install image of Android for Angstrom - Testers Wanted!
http://androidzaurus.seesaa.net/article/80102284.html

Feedbacks and contributions are very welcome.

Cheers,


that sounds great! i'll test it tonight and report here, although i've already got a working android on my c3000 hdd;)
i didn't thought i could put the android rootfs on a sdcard, to be faster and to take no room on the 4GB hdd of the c3000! thanks for that too
by the way, my C3000 is debian customized with the Angstrom kernel. so perhaps some people with true angstrom based C3000 would try too
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Yet Another Install Image - Testers Wanted!
« Reply #2 on: January 22, 2008, 01:08:11 pm »
just tested your android install image : works great without any problem.

wifi internet access : works

thank you!
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

Android Zaurus

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://androidzaurus.seesaa.net
Yet Another Install Image - Testers Wanted!
« Reply #3 on: January 22, 2008, 05:12:11 pm »
Quote from: jpmatrix
just tested your android install image : works great without any problem.

wifi internet access : works

thank you!

Thank you for testing, jpmatrix.

Your post was very suggesting for me to make it work. I guess you notice HDD LED is less busy now.

A guy told me another C3000 with angstrom-consle-image(2007.1-stable) had no problem.

Cheers,

undrwater

  • Full Member
  • ***
  • Posts: 232
    • View Profile
    • http://
Yet Another Install Image - Testers Wanted!
« Reply #4 on: January 29, 2008, 02:19:14 pm »
I tried last night on my Tosa, but the Angstrom console image I had had no loop support, so I couldn't mount the android.img.

If there's any way to mount it without loop support, I'd be happy to entertain another option.

I'll be looking for the loop module for Tosa in the meantime.

And in case any Angstrom devs are watching (bugs.openembedded.org is down right now):

The console image works well, except for suspend.  Actually suspend works fine the first time, but the second time it hangs with a message about waiting for ac97.

I'll post the exact message when the bugtracker is back up.

Thanks all.
« Last Edit: January 29, 2008, 02:21:55 pm by undrwater »

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3703
    • View Profile
Yet Another Install Image - Testers Wanted!
« Reply #5 on: January 29, 2008, 06:11:53 pm »
BTW, what should the apt or ipkg sources be? there didn't seem to be any in the c3xxx installable?
thanks
Paul
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

Android Zaurus

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://androidzaurus.seesaa.net
Yet Another Install Image - Testers Wanted!
« Reply #6 on: January 30, 2008, 12:27:21 am »
Quote from: undrwater
I tried last night on my Tosa, but the Angstrom console image I had had no loop support, so I couldn't mount the android.img.

I took a look into defconfig-tosa in Angstrom bitbake package and found that loopback device is built as a module.

So, it would be possible you could try to modprobe loop before starting Android.

Thanks,

undrwater

  • Full Member
  • ***
  • Posts: 232
    • View Profile
    • http://
Yet Another Install Image - Testers Wanted!
« Reply #7 on: January 30, 2008, 12:47:04 am »
Quote from: Android Zaurus
Quote from: undrwater
I tried last night on my Tosa, but the Angstrom console image I had had no loop support, so I couldn't mount the android.img.

I took a look into defconfig-tosa in Angstrom bitbake package and found that loopback device is built as a module.

So, it would be possible you could try to modprobe loop before starting Android.

Thanks,


Attempted that already...no joy.

Android Zaurus

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://androidzaurus.seesaa.net
Yet Another Install Image - Testers Wanted!
« Reply #8 on: January 30, 2008, 01:38:22 am »
Quote from: undrwater
Attempted that already...no joy.

I built a loop.ko with my Angstrom-spitz environment. Kernel version is still 2.6.23.

 [ Invalid Attachment ]

I'm not sure it works for you...

Good luck,

xjqian

  • Sr. Member
  • ****
  • Posts: 497
    • View Profile
    • http://
Yet Another Install Image - Testers Wanted!
« Reply #9 on: January 30, 2008, 02:40:49 am »
Quote from: undrwater
The console image works well, except for suspend.  Actually suspend works fine the first time, but the second time it hangs with a message about waiting for ac97.

I'll post the exact message when the bugtracker is back up.

you can use http://bugs.openembedded.net/ for now. .org is constantly having dns problem recently. I can confirm the suspend/resume problem you've seen with the 2.6.23 angstrom tosa kernel.

The latest 2.6.24 kernel and suspend/resume issue is being worked on by Dmitry at http://tosa.lumag.spb.ru/news/7/51.html. You can kexec into the zImage provided on the site. If you need more details, we can take our discussion into the tosa forum.

Regards
Gordon
My Blog | 6000L Tosa + sled | is: Angstrom | was: pdaXrom 1.1.0beta1 | was: stock 1.12 rom + no-ffpe fash kernel + X/Qt Debian |
CF GPS (FGPCFCD01) | USB "Prolific 2303" GPS (USB-UG-200) | Socket CF BT rev. H |  USB "Pegasus II" Ethernet (ADM8511) | PocketTop IR kbd | sip:527630@fwd.pulver.com
Todo: OESF wiki | stable VOIP app | usable GPS app |      Wishlist: VOIP + Bluetooth | GPS + Routing Calc

undrwater

  • Full Member
  • ***
  • Posts: 232
    • View Profile
    • http://
Yet Another Install Image - Testers Wanted!
« Reply #10 on: January 30, 2008, 06:01:52 pm »
Android Zaurus: your loop worked, thanks...but the img wouldn't mount.  It worked well enough on my desktop.  

It's showing as ext2, but I'm guessing that's not right.  Might it work better if I knew the fs?  

Nevermind: dmesg states:

Code: [Select]
JFFS2 notice: (1020) check_mode_data: wrong data CRC
So maybe my file is corrupt.  I'll re-download and try again.

xjqian: I have a few questions I'd like to ask.  I'll post a topic in the Tosa forum.