Author Topic: Running Zaurus (akita) Without Battery  (Read 7366 times)

ToneBlind

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
Running Zaurus (akita) Without Battery
« on: June 25, 2009, 04:51:08 pm »
I'm trying to run my SL-C1000 without the battery. I got it to start up via D+B while connecting the AC power, then logged in as root, and rebooted the system (by typing 'reboot' at the root command.) It then proceeds to reboot and load Cacko, but as soon as it finishes loading, I get a window saying "Change the battery" and then the system shuts down.

I'm wondering if there is any possible way to actually run the system without the battery. Is that "Change the battery" message something that does not exist in different ROMs? I tried using the Sharp ROM also and I get the same behavior. But perhaps this is due to the fact that Cacko uses the Sharp ROM extensively.

Has anyone actually gotten their Zaurus to run without battery?

Thanks in advance!

espi

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #1 on: June 25, 2009, 05:08:56 pm »
Hey,
I remember I thought my Z was dead and did a lot of research about it and the battery, etc.
One thing I remember that came up was the power flows in the unit through the battery, so it is designed different than other devices that can bypass the battery and run straight off of mains.
I never could get it to work, found a cheap battery vendor (off of this lovely forum), and never thought about it again.
Best of luck
unused: Sharp Zaurus SL-C3100 • 2008.03.19 • stock cacko, unused • TK: Hopefully Ubuntu success
palmtop: OQO 02 • 2009.02.01 • XP Tablet SP3 | testing Win7 16395 | Ubuntu 8.10 | OSX86 10.5.2 • I want: Backtrack to install
primary: HP TC1100 Hybrid Tablet • 2008.05.12 • XP Tablet SP3 | testing Win7 16395 | Ubuntu 9.04 | Backtrack 4pr | OSX86 10.5.7 • I want: Win7 TIP in XP  
work: Apple Mac Pro 8-core (Jan 08) • 2008.01.28 • OSX 10.5.7 | XP SP3 | Vista SP2 vlite
[/size]

ToneBlind

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #2 on: June 25, 2009, 05:32:14 pm »
Quote from: espi
Hey,
I remember I thought my Z was dead and did a lot of research about it and the battery, etc.
One thing I remember that came up was the power flows in the unit through the battery, so it is designed different than other devices that can bypass the battery and run straight off of mains.
I never could get it to work, found a cheap battery vendor (off of this lovely forum), and never thought about it again.
Best of luck
Thanks, espi.

Actually, I am positive that there is no technical reason why the Zaurus can't run without a battery. Like I said, I can get it to boot into Cacko without a battery in with no problem, but then I get a dialog telling me to replace the battery and the system shuts down.

This is what you do (I got this information from the forum, try it at your own risk):

- Remove the battery.
- Press D + B while you connect the AC adapter. This will bring a command line prompt.
- When you are asked to login, enter 'root' (no quotes). You need no password.
- At the root prompt (#) type 'reboot' (again, no quotes) and hit Enter. This will reboot your Zaurus and load the OS.

Now, the problem is that once the OS reloads, I get that dialog and the system shuts down. I am wondering if that is simply a function of the ROM used, and maybe trying something like Zubuntu I could get it to run without a battery.

On the other hand, maybe there is a compelling reason not to run the Zaurus without a battery (does the battery act as a power regulator)? I run Thinkpads without batteries routinely, and love them because of that. If someone could shed light on a way to run a Zaurus without battery I would greatly appreciate it.

Thanks again, espi!

ToneBlind

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #3 on: June 28, 2009, 04:27:31 pm »
I wanted to confirm that this works (thanks to Cortez which confirmed this should work in the Zubuntu forum) with Zubuntu.

Tron

  • Newbie
  • *
  • Posts: 47
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #4 on: November 03, 2009, 02:37:16 am »
Hello all,

I currently try to revive my Z (C-3100, Cacko 1.23) I haven't used in a while and run into the same problem. I can only get it to start using B+D, after issuing a reboot the device starts, but turns off directly after loading the OS. I can get into the maintenance mode using D+M, but that does not really help. I tried reflashing, but for that I'd need to get into flashing mode (Enter and On), but that does not work, the Z does not respond.

Any ideas? It was working perfectly last time I used it, it just ran out of battery in the meantime.
YT,
Tron

kurochka

  • Sr. Member
  • ****
  • Posts: 301
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #5 on: November 03, 2009, 10:47:35 am »
Quote from: Tron
Hello all,

I currently try to revive my Z (C-3100, Cacko 1.23) I haven't used in a while and run into the same problem. I can only get it to start using B+D, after issuing a reboot the device starts, but turns off directly after loading the OS. I can get into the maintenance mode using D+M, but that does not really help. I tried reflashing, but for that I'd need to get into flashing mode (Enter and On), but that does not work, the Z does not respond.

Any ideas? It was working perfectly last time I used it, it just ran out of battery in the meantime.

I had a similar issue of battery running out and the unit being unresponsive.  I remember I connected it to a charger and left it there for a day or two.  Then, it fixed itself.
SL-C3100 (from PriceJapan.com): modified Sharp Rom (couldn't make Japanese input work in Cacko Rom)

ex-SL-C3000; ex-SL-5600; ex-Simpad

Tron

  • Newbie
  • *
  • Posts: 47
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #6 on: November 04, 2009, 03:26:27 am »
Quote from: kurochka
I had a similar issue of battery running out and the unit being unresponsive.  I remember I connected it to a charger and left it there for a day or two.  Then, it fixed itself.

As the Z obviously does not like running without a battery, I checked mine and found it to have only 2.7V (instead of 3.7V), even after a night of charging. I guess I'll first need to resolve that issue and it'll hopefully work again with a functional and charged battery.
YT,
Tron

the_oak

  • Sr. Member
  • ****
  • Posts: 426
    • View Profile
    • http://
Running Zaurus (akita) Without Battery
« Reply #7 on: November 04, 2009, 12:36:44 pm »
Is it possible that it is not so much the main battery as it is the backup battery that has died? My Dell Axim did this from being left too long in a drawer. The backup battery had to be replaced.
SL-6000L running Sharp 1.12 rom, (SOLD)
Fujitsu U820 with Windows 7
White Intel MacBook

Tron

  • Newbie
  • *
  • Posts: 47
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #8 on: November 04, 2009, 03:13:45 pm »
I think it's primarily the main battery that's dead. The Z seems to charge (yellow LED on) when plugged in, but after a day the battery voltage is still at 2.7V.

Could someone with a working C-3100 test if the Z boots reliably (and is usable) without the battery and just the charger plugged in?
YT,
Tron

pelrun

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
Running Zaurus (akita) Without Battery
« Reply #9 on: November 08, 2009, 03:03:28 pm »
You're somewhat out of luck, I'm afraid. Whilst the D+B trick does allow you to start the system up, the power hardware will still permanently report critical-low battery status. Depending on the distro, this may be ignorable, but I don't think there's any real way to get Cacko or SharpROM to do so. The only real solution here (besides installing something other than Cacko) is to get a replacement battery (original or cheap EBay).

Also, there is no  'backup battery' in the c3xxx series models, so you don't have to worry about that.
SL-C3100 with usb power mod running debian eabi
pdaXii13 still on the NAND for dualbooting
16GB SDHC! (a new one, after I sat on the old one and it went kaput)
D-Link 660 wifi, Socket Bluetooth rev H
External 9800mAh LiIon battery and slimline dvd drive
Homebrew microphone and remote

Tron

  • Newbie
  • *
  • Posts: 47
    • View Profile
Running Zaurus (akita) Without Battery
« Reply #10 on: November 08, 2009, 03:36:35 pm »
Quote from: pelrun
You're somewhat out of luck, I'm afraid. Whilst the D+B trick does allow you to start the system up, the power hardware will still permanently report critical-low battery status.

Thanks for the info, I already thought so. But as a Zaurus is a mobile device, it's not very usable without a battery, is it? So if I want to get it running again, I guess I'll need to look out for a cheap one on eBay or so, the original one is far too expensive.
YT,
Tron

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Running Zaurus (akita) Without Battery
« Reply #11 on: November 09, 2009, 04:56:14 am »
Is it not possible to boot up and shut down apmd before it shuts your Z down? (Just an idea, could be useless )
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt