Author Topic: Got Sync working with "New" ROM  (Read 1977 times)

nontrivial

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
    • http://james.nontrivial.org
Got Sync working with "New" ROM
« on: March 22, 2004, 11:12:34 am »
I didn\'t come up with this, but it works. On either the original ROM or the new cacko Qtopia ROM make sure you have ssh up and sunning. Then install Evolution 1.4 or better and Multisync 0.81 or better. Then go to http://opie.handhelds.org/feed/sharprom/latest/ and install the three PIM packages on your zaurus. Pick SFTP in Multisync and you can see the results after restarting qtopia on the zaurus. I\'m researching a way to get qtopia desktop syncing by installing the \"old\" sync packages.

James

msjones

  • Newbie
  • *
  • Posts: 42
    • View Profile
    • http://
Got Sync working with "New" ROM
« Reply #1 on: March 25, 2004, 01:40:40 pm »
What model zaurus do you have? I just bought a 5600 and it still has the original sharp rom.  I am wondering if your method will work on it? I am looking to sync evolution from my linux desktop.

basmatt

  • Newbie
  • *
  • Posts: 2
    • View Profile
Got Sync working with "New" ROM
« Reply #2 on: April 02, 2004, 06:37:59 am »
What were the exact steps in your procedure? I have ssh (including sftp) running on my zaurus, SharpROM3.13 and the OPIE PIM apps installed from the feed you provide above. On the desktop side I have evolution 1.4.5 and multisync 0.81... but meddling with all the settings on multisync yields no useful response.

Note that I can happily ssh (and sftp) in both directions from my Zaurus to my desktop, and back again...

Which ssh installation did you use? (I have the one from: http://killefiz.de/zaurus/showdetail.php?app=1035)

basmatt

  • Newbie
  • *
  • Posts: 2
    • View Profile
Got Sync working with "New" ROM
« Reply #3 on: April 06, 2004, 07:59:14 am »
To follow myself up...

The step I was missing was to ensure that I could ssh onto the zaurus and back without a password (there\'s a link on how to do this in the Multisync FAQ). I\'ve now managed to synchronise (at least partly the thing does not want to seem to receive all of my addressbook, only parts)... although I still cannot sync using root (just cannot persuade ssh to let me log in to Zaurus as root without a password), so I have had to sync as user zaurus and disable qcop (I don\'t mind restarting the Qtopia after sync, so that is not a problem).

If anyone has any idea about what I could be doing wrong to prevent root from ssh\'ing without password, I would appreciate it...