Author Topic: Zaurus WAS Bricked, Now solved!  (Read 8915 times)

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Zaurus WAS Bricked, Now solved!
« on: March 29, 2004, 10:10:38 am »
Edit: This used to be a post called \"Zaurus Bricked, suggestions?\" but as I\'ve now recovered it which is documented on Page 3 I don\'t think it needs any more attention other than from those of you who have near-bricked your C series Zaurus and although you have the option to do a NAND Flash Restore it fails with the error \"Format Error\". Good luck with your restores people and take better care of your Zaurii, I sure will

Well for the last month my C760 has been out of action, it was killed by a combination of my own stupidity and a bug which has since been resolved with the Cacko ROM and Bluemonkey Bluetooth CF cards.

Here\'s a retrace of my steps:

The bug above meant that I couldn\'t power on my Z, I could get into the service menu but not the ROM flashing screen (where you hold down OK as you turn the unit on). I thought at the time that perhaps there was a problem with the NAND Flash, so I performed a NAND FLASH Read test. Naturally I assumed that because this said READ and had no mention of Writing that this wouldn\'t affect the Zaurus. The menu option I chose is outlined in this path:

Main Service menu ] Page 3/3 ] Option 7 EXTRA MENU ] Option 1 Zaurus Test ] Page 2/4 ] Option 8 NAND Flash Read

I did that and it was so far back that I can\'t remember the result of it, but it definately didn\'t mention anything about erasing / deleting / changing anything. Then I tried Clear Diag Flag Option 6 in the EXTRA MENU and then Reset Option 9 in the same menu.

Now, at this point I didn\'t think I had done anything wrong. I will openly admit this was probably an arrogant / retarded view on my part and boy oh boy do I feel like a complete f***ing idiot now!

The Zaurus reset and then the Mail LED was flashing green. I felt sick at this point.

In the past I\'ve experienced this after tinkering with the other service menu options. I should have been smarter than this but we all have our days where intelligence dissapears but luckily a NAND Flash Restore borrowing a friends 256MB CF card has fixed my Zaurus...

I talked to sashz to see if he could help out and he pointed me to a page with some wierd files to put on a CF card. I learnt today from reading externe.net\'s forums that this is a low level recovery solution for those that can\'t even get into the service menu but I tried it anyway. I couldn\'t get this to work, it didn\'t do anything (and I have no way of monitoring the serial port) so I gave up for a while as I was thoroughly annoyed with it.


About a week ago offroadgeek was very kind in giving me my own 256MB CF card, that arrived today so I downloaded the SYSTC760.DBK file to do another NAND Flash Restore from. As soon as I got the card I formatted it as FAT16 and put the file on it and tried reflashing. The error I get is this:



I can access the service menu fine and post numerous screenshots of any screen there if it would help, here\'s the bottom part of the main service menu screen, I\'m hoping it shows something that can help initially:

[img]http://foxdie.timduru.org/zaurus/nfstatus.jpg\" border=\"0\" class=\"linked-image\" /]

Right now I\'m at a loss, I\'ve searched both this and externe\'s forums for help and I\'ve tried what they\'ve suggested and I don\'t know what to do. Please tell me there\'s someone out there that can help me!


PS. I\'m not sure if my Zaurus has a warranty, it was definately bought in the last 12 months but I don\'t know if it has a warranty, I bought it from a guy called Lawrence Camera on eBay, all I remember about him is he\'s a good friend of the person who runs Conics.net. I doubt he\'ll replace it because of what I\'ve done to it  :?
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt

gene

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://www.fastcube.com
Zaurus WAS Bricked, Now solved!
« Reply #1 on: March 29, 2004, 10:32:43 am »
I had a very similar problem. I had a known good rom and I wasnt able to do a nand reflash. The rom i got was one from a german company that sells zarus c860. It has a known good rom available on its site for c860 and 7xx. I was getting samew problem using a compact flash and i had to use an sd card to reflash it. Try a different card. It can be very finicky.

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Zaurus WAS Bricked, Now solved!
« Reply #2 on: March 29, 2004, 10:41:18 am »
I\'ve tried a SanDisk CF card and a Kingston Technology card, both 256MB and both formatted as FAT16 (and both formatted at least twice). I have also tried redownloading the nand flash restore file and try again but still doesn\'t work

I don\'t know anyone with a 256MB or greater Secure Digital card either, unless there\'s another zaurus user who lives near Birmingham in the UK who has one he can help me restore with if we meet up in the town center (I keep my fingers crossed for that but I expect no luck).
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt

albertr

  • Hero Member
  • *****
  • Posts: 535
    • View Profile
    • http://
Zaurus WAS Bricked, Now solved!
« Reply #3 on: March 29, 2004, 10:54:25 am »
If you can get into service mode, your Z is NOt bricked. I wish I could help, but I don\'t know ways around your service menu (my 5500 has very basic service menu - angel loader, while yours could be using a separate linux kernel with a graphical service program). Try to contact Sash or someone else who\'s experienced with flashing xscale zaurus\'es. As gene says, try different CF and SD cards. Also, that \"format error\" message that you are getting is not very descriptive. Could it be NAND flash format error? Maybe you need to format NAND before attempting to restore? Just a wild guess, don\'t follow it, ask someone who knows. In any case, don\'t give up yet, if it\'s not dead, then it can be revived.
-albertr

gene

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://www.fastcube.com
Zaurus WAS Bricked, Now solved!
« Reply #4 on: March 29, 2004, 11:06:48 am »
yeah, like albert says if you get service menu then it aint bricked, find someone or buy a 256 meg sd and give it another go

gene

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://www.fastcube.com
Zaurus WAS Bricked, Now solved!
« Reply #5 on: March 29, 2004, 11:26:04 am »
Also, here is the link to the german site with the ROM http://www.trisoft.de that i used to reflash. Good luck!

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Zaurus WAS Bricked, Now solved!
« Reply #6 on: March 29, 2004, 12:04:44 pm »
Unfortunately I can\'t read german, and even with a web page translator it\'s difficult to follow. Can you tell me where the files reside?
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt

padishah_emperor

  • Hero Member
  • *****
  • Posts: 849
    • View Profile
    • http://
Zaurus WAS Bricked, Now solved!
« Reply #7 on: March 29, 2004, 12:21:58 pm »
I\'m sending you a private message, check your inbox.
Left Linux and Linux PDAs... sorry, got boring.  Switched to Mac.

markb

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
    • http://
Zaurus WAS Bricked, Now solved!
« Reply #8 on: March 29, 2004, 12:44:16 pm »
Hi foxdie,

I have a C860 and a 256MB SD card.
I also work near Birmingham city centre.
Let me know if I can be any help.
I assume you\'ll bring the expertise, I\'ll just bring the hardware. :-)

- Mark

braindrop

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
    • http://
Zaurus WAS Bricked, Now solved!
« Reply #9 on: March 29, 2004, 01:26:00 pm »
if i was on that side of the water i would loan you my sd... as it is though i\'lll light a candle.

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Zaurus WAS Bricked, Now solved!
« Reply #10 on: March 29, 2004, 03:32:31 pm »
Quote
Hi foxdie,

I have a C860 and a 256MB SD card.
I also work near Birmingham city centre.
Let me know if I can be any help.
I assume you\'ll bring the expertise, I\'ll just bring the hardware. :-)

- Mark

Heh cool, do you have any Instant Messengers? You can find mine in my profile
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt

gene

  • Newbie
  • *
  • Posts: 45
    • View Profile
    • http://www.fastcube.com
Zaurus WAS Bricked, Now solved!
« Reply #11 on: March 29, 2004, 06:17:26 pm »
You asked for link to rom for c-760, here it is. I used one from same company for my c860 it worked like a Charm. I\'d bet good money this will work for you. Best of luck dude.

http://babelfish.altavista.com/babelfish/u...0NAND291003.zip

Stubear

  • Hero Member
  • *****
  • Posts: 1164
    • View Profile
    • http://
Zaurus WAS Bricked, Now solved!
« Reply #12 on: March 29, 2004, 06:55:35 pm »
I\'ve had the \"format error\" when the DBK was corrupted. If reformating the SD/CF card doesn\'t work try downloading the DBK again, I\'ve had IE and occasionally Mozilla give me dodgy files that worked fine after redownloading

Good Luck

Stu
SL-C1000, Hand converted to English with Japanese Input
Running X apps via X/Qt
iRiver USB host cable; Diatec P-Cord usb power cable (extendable); Acro's Reel Cable USB (A to A, B, Mini-B,  & Mini-B 8pin); GreenHouse 1Gb PicoDrive+; 2x256Mb Hagiwara SD cards; 128Mb Transcend CF card; 512Mb PQI CF card; AmbiCom WL1100C-CF 11B WLAN card

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Zaurus WAS Bricked, Now solved!
« Reply #13 on: March 31, 2004, 12:36:51 pm »
Well I tried both downloading the NAND flash file from another website and with a different browser, I also tried it with a 256MB SD card that markb has mailed me (thankyou! I\'ll return it on Saturday, catch me on MSN to discuss a meeting time).

None of these work. sashz recommends I find a zaurus serial lead to check the output when flashing to see what the error is in more detail. Anyone able to lend me a zaurus serial cable? Apparently any model zaurus serial cable will work..

I also tried to contact the guy I bought it from but so far he has not responded after 2 days, I also tried to contact the guy behind conics.net (because they are good friends) but he doesn\'t respond either. I also phoned Sharp UK and they said that Sharp Japan is a different company(??!) and that I\'d have to deal with Sharp Japan instead.

My heart really is sinking on this one
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt

treke

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
    • http://
Zaurus WAS Bricked, Now solved!
« Reply #14 on: March 31, 2004, 12:48:32 pm »
Sharp Japan, Sharp UK, and Sharp USA are pretty much separate entities that often share product designs between themselves.