Author Topic: HowTo make WEP work on OZ 3.3.5  (Read 3544 times)

b5o5m5b

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • http://
HowTo make WEP work on OZ 3.3.5
« on: March 18, 2004, 02:38:06 pm »
(ed. Be sure to read posts further down for even better/cleaner solutions to this issue!)

All of this information was scattered between the OZ site and within this forum, so I thought it would be useful to others to combine it all into a single message.

1. Add \'hostap_crypt_wep\' to the file /etc/modules. From a terminal type the following (noob note: be sure to use double arrows or you\'ll overwrite the /etc/modules file and really be stuck):
Code: [Select]
> echo hostap_crypt_wep >> /etc/modules
2. Reboot
3. Insert your 802.11 card (I was using a Linksys WCF12 when I tested this).
4. Open a terminal and enter the following to configure the wep key for the card:
Code: [Select]
> iwconfig wlan0 key s:YourWepKeyHere
5. And since I was using DHCP to get an address I did the following to make sure I had a fresh address:
Code: [Select]
> udhcp -i wlan0
6. Now try and ping something!


Hopefully, some other users will find this useful.

tawalker

  • Jr. Member
  • **
  • Posts: 82
    • View Profile
    • http://
HowTo make WEP work on OZ 3.3.5
« Reply #1 on: March 19, 2004, 08:03:19 am »
Thanks for collecting this info in one place - I would\'ve found it useful earlier this week

I personally found I didn\'t need to follow steps 4 and 5. 4 didn\'t actually work for me (the command gave me an \"argument too long\" error message), but after step 1 OZ accepted the WEP key I entered via the Network applet. Also, the DHCP seemed to do its thing without being prompted (step 5).

BTW, I also had to edit /etc/pcmcia/hostap_cs.conf to get my Buffalo WLI2-CF-S11 WiFi card recognised. That must be why we love Linux

Thanks again!

Tim
---
Tim Walker - UK
Sharp Zaurus SL-5500 - OZ 3.3.5
"A.N.Other" 128Mb MMC - Buffalo CF WiFi
---

catachresis

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • http://
HowTo make WEP work on OZ 3.3.5
« Reply #2 on: March 19, 2004, 08:49:58 am »
Terrific b5o5m5b.  Maybe after readers have added their comments, this could get transported to part of the ZUG HOWTO section?

jorvic

  • Newbie
  • *
  • Posts: 38
    • View Profile
    • http://
HowTo make WEP work on OZ 3.3.5
« Reply #3 on: March 20, 2004, 02:20:44 pm »
I agree this would e nice in the How-to. This would also let us just point someone to if if they ask this question

b5o5m5b

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • http://
HowTo make WEP work on OZ 3.3.5
« Reply #4 on: March 23, 2004, 10:14:05 am »
I\'m glad I could help out.

Hopefully, I can get a chance to look into finding out exactly WHY I was having these problems, then I could actually contribute a solution to the problem instead of just a bandaid to it.

derekp

  • Full Member
  • ***
  • Posts: 154
    • View Profile
HowTo make WEP work on OZ 3.3.5
« Reply #5 on: March 23, 2004, 10:53:23 am »
A slightly more correct way of getting wep to work is as follows:
1) Edit /etc/pcmcia/hostap_cs.conf and in the line (second from the top) that reads:
    class \"network\" module \"hostap_cs\"
Change this line to:
    class \"network\" module \"hostap_cs\", \"hostap_crypt_wep\"
That way, the wep module will load and unload automatically when the card is inserted/ejected (whereas adding it to /etc/modules causes the wep module to be loaded all the time, which consumes memory).

2) Edit /etc/pcmcia/wireless.opts, set the variables at the bottom to what you need (ESSID, MODE, and add the variable KEY=your wep key)

Now your card should come up automatically on insert, without needing to manually run iwconfig everytime.  And all the related modules should unload when you eject the card.

3) For dhcp settings, set the variable DHCP=\"y\" in /etc/pcmcia/network.opts.  Or set static values in that file if you need.

4) Edit /etc/pcmcia/network, find the line that starts up udhcpc (line 114).  Change the \"-f\" flag to \"-b\".  Now udhcpc will actually create it\'s pid file like it should, so that it can be killed when you eject your card.

That\'s all I remember for now.  If I get time, I\'ll put together a quick little patch script to apply all these changes automatically (and prompt for wep settings, etc).

tji

  • Newbie
  • *
  • Posts: 6
    • View Profile
    • http://
HowTo make WEP work on OZ 3.3.5
« Reply #6 on: April 06, 2004, 03:50:01 pm »
I prefer using the command line iwconfig (actually shell scripts using iwconfig) to set the WEP key, rather than in wireless.opts.   My Z is always moving, so the network config is often changing.  If I move from home to work, I need to set a new WEP key.  If I\'m on the road, I turn WEP off completely.    The shell scripts can automate this process a bit (but it still sucks).

I hope the wifi support is improved in the SL-6000, which comes with integrated wifi.   With my Powerbook, when I connect to a new network, it remembers the settings and WEP key, and when it sees that SSID (and MAC address?) in the future, it can automatically connect with no user interaction needed.

superbondbond

  • Newbie
  • *
  • Posts: 27
    • View Profile
    • http://
HowTo make WEP work on OZ 3.3.5
« Reply #7 on: April 06, 2004, 04:25:20 pm »
I was using the pcmcia scripts for the longest time, but then I decided to go back to the Debian native network scripts. I stumbled acros a little page that shows how to edit the /etc/network/interfaces to create profiles for all the networks I connect to. Once that was working , with the help of Opie-sh, I have an on-screen icon that brings up a drop-down menu to select from, and *viola*, instant connectivity. It\'s been working perfectly for me. (WEP included)

here\'s a link where I got started.
http://lists.debian.org/debian-powerpc/200...8/msg00505.html