Author Topic: Aerlink card not working in Cacko ROM 1.21  (Read 1526 times)

Ian

  • Newbie
  • *
  • Posts: 29
    • View Profile
Aerlink card not working in Cacko ROM 1.21
« on: April 23, 2004, 02:17:20 pm »
I\'ve been using my Aerlink (SDG Systems) phone card modem thingy to connect to a Sony Ericsson T610 with Cacko 1.20 on my C860; it worked fine.

After upgrading to Cacko 1.21 (with and without the hotfix) I found that I can\'t use it any more. It says \"CF card type serial device is busy\". Can anyone help with this?

I have confirmed the settings and hardware using an SL-6000; it\'s definitely the new ROM which is responsible.

Thanks, Ian.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Aerlink card not working in Cacko ROM 1.21
« Reply #1 on: April 28, 2004, 06:55:26 am »
Quote
I\'ve been using my Aerlink (SDG Systems) phone card modem thingy to connect to a Sony Ericsson T610 with Cacko 1.20 on my C860; it worked fine.

After upgrading to Cacko 1.21 (with and without the hotfix) I found that I can\'t use it any more. It says \"CF card type serial device is busy\". Can anyone help with this?

I have confirmed the settings and hardware using an SL-6000; it\'s definitely the new ROM which is responsible.

Thanks, Ian.

Might be a serial_cs driver. Try to replace it with the one available for download at this site.

http://www.zaurususergroup.com/modules.php...q=getit&lid=183

cs

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • http://
Aerlink card not working in Cacko ROM 1.21
« Reply #2 on: May 02, 2004, 04:09:51 pm »
Hello!

I had a similar problem with Cacko ROM 1.21 / 1.21a on SL-C750 with a Pretec CompactModem 56k CF modem card
and solved it by removing the following line in \"/etc/pcmcia/serial\":

UART_CONF=\"/etc/bluetooth/uar\"

It seems the default is set for Bluetooth adapters.

Hope it helps,
Christian

Ian

  • Newbie
  • *
  • Posts: 29
    • View Profile
Aerlink card not working in Cacko ROM 1.21
« Reply #3 on: May 17, 2004, 11:15:50 pm »
Quote
Might be a serial_cs driver. Try to replace it with the one available for download at this site.


Thanks for the suggestion, Maslovsky... I looked at that but it looked too complicated for me, sorry. I have only a small amount of tie for hacking my Zaurus. I do appreciate your reply (and also the Cacko ROM, which is outstanding). Thanks.

Quote
I had a similar problem with Cacko ROM 1.21 / 1.21a on SL-C750 with a Pretec CompactModem 56k CF modem card  
and solved it by removing the following line in \"/etc/pcmcia/serial\":  


Hey... That is just about within my threshold. It looks like that fixed it - I will double check tomorrow. After commenting that line out, it gets as far as dialing the modem on the T610. Unfortunately there is no signal where I am but it looks very promising. Thank you very much, I was about to throw the phone into the junk drawer (I only bought it for that project, not really for talking).

I am very impressed, especially considering that was your first post :-). I only hope I can be as helpful to other people.

Regards,   Ian.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Aerlink card not working in Cacko ROM 1.21
« Reply #4 on: June 03, 2004, 06:30:27 am »
BTW, the \"Serial device busy\" issue should be fixed in Hotfix B, which will be released today.