Author Topic: Gemini screen line and not boot  (Read 1948 times)

Lele

  • Newbie
  • *
  • Posts: 1
    • View Profile
Gemini screen line and not boot
« on: April 15, 2019, 06:42:50 am »
Hello,

i have gemini x27 since july 2018

I use continuous my gemini all day

From 2 days ago is died. Please send me solution
« Last Edit: April 15, 2019, 08:20:43 am by Lele »

gidds

  • Sr. Member
  • ****
  • Posts: 291
    • View Profile
    • http://
Gemini screen line and not boot
« Reply #1 on: April 17, 2019, 04:53:26 pm »
It's probably best to contact Planet Computers directly:

(In case it's not clear, this forum is not connected to Planet; we're just a group of users like you.  For hardware problems like this, I'm afraid there's probably nothing we here can suggest, and certainly nothing we can do to help.)
[blockquote]Andy/[/blockquote]
Psion 5mx –> Gemini (–> Cosmo)

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1085
    • View Profile
Gemini screen line and not boot
« Reply #2 on: April 18, 2019, 08:40:35 am »
You have probably already done so, but just in case: have you tried to reflash it?

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!

M@rtin

  • Newbie
  • *
  • Posts: 1
    • View Profile
Gemini screen line and not boot
« Reply #3 on: April 30, 2019, 04:25:05 am »
I have the exact same issue, I contacted Planet Computers about the issue, and this was their response.

Quote
Thanks for your message. While the issue you’re facing might seem concerning at first, this is a known result of software corruption and is relatively easy to resolve.

1. Please begin by flashing your device with the Android-only setup as instructed at http://support.planetcom.co.uk/index.php/A..._Flashing_Guide. You can get the device to flash mode by holding Esc + the silver side button even if you’re seeing the screen in question. The device will then flash as normal.

2. Once flashed, you will still see the lines. Please wait until the device’s battery dies on the lines screen.

3. Once the battery is entirely empty, connect the original power plug included in the Gemini’s box to the Gemini for around 30 seconds. After 30 seconds, you will be able to power the device on as normal.

Please let me know how this goes.

I have tried to fix the issue using these steps, but haven't had any success. At a guess, despite leaving the device to run flat, there is still some residual charge left causing the issue to persist.
I've contacted Planet again to ask if there is another method of draining the battery or disconnecting it to reset the device, so I will let you know what the outcome of that is.

teh.sean

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • http://
Gemini screen line and not boot
« Reply #4 on: October 12, 2019, 02:00:43 pm »
I'm in a similar boat with a Gemini PDA that I rarely use. Went to try out a new distro and I get the same scrolling display as you have.

Did you have any luck resolving this issue?

Quote from: M@rtin
I have the exact same issue, I contacted Planet Computers about the issue, and this was their response.

Quote
Thanks for your message. While the issue you’re facing might seem concerning at first, this is a known result of software corruption and is relatively easy to resolve.

1. Please begin by flashing your device with the Android-only setup as instructed at http://support.planetcom.co.uk/index.php/A..._Flashing_Guide. You can get the device to flash mode by holding Esc + the silver side button even if you’re seeing the screen in question. The device will then flash as normal.

2. Once flashed, you will still see the lines. Please wait until the device’s battery dies on the lines screen.

3. Once the battery is entirely empty, connect the original power plug included in the Gemini’s box to the Gemini for around 30 seconds. After 30 seconds, you will be able to power the device on as normal.

Please let me know how this goes.

I have tried to fix the issue using these steps, but haven't had any success. At a guess, despite leaving the device to run flat, there is still some residual charge left causing the issue to persist.
I've contacted Planet again to ask if there is another method of draining the battery or disconnecting it to reset the device, so I will let you know what the outcome of that is.

idc

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Gemini screen line and not boot
« Reply #5 on: October 24, 2019, 07:34:22 pm »
Just wanted to let anyone interested know that I had this problem. Planet advised me to reflash. I did so, but reluctant to wipe everything I'd set up, I only reflashed some of the partitions: preloader, recovery, md1img, md1dsp, md1arm7, md3img, scp1, scp2, lk, lk2, logo, tee1, tee2, and boot3 (my android boot partition). It looks as though that has worked, though I'm waiting for the unit to charge a little before restarting it and checking that I've not lost any data. It started rebooting successfully into Sailfish but then shut down 'cos of lack of power before I could do those checks.

stdlogicvector

  • Newbie
  • *
  • Posts: 4
    • View Profile
Gemini screen line and not boot
« Reply #6 on: December 17, 2019, 05:21:06 am »
Hi, I'm having the same problem and just posted that to the "Gemini PDA - General Discussion" forum yesterday. (And now I see this post here...tought I'd looked everywhere...) At least I'm not the only one with this problem.

I also tried all sorts of reflashing, but nothing changed. The method with letting the battery run dead I haven't heard before. I'm gonna try that tonight.

@idc: Did the partial reflashing solve the problem for you? If yes, can you give more details?

idc

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Gemini screen line and not boot
« Reply #7 on: December 17, 2019, 09:14:27 am »
yes. it definitely worked (and the letting the battery run dead was an essential part) and I am back to using my Gemini with Sailfish without having lost data. One warning, my Android partition which had been on the 7.1 Android booted, but claimed that my data partition was encrypted and asked me to put in my password. It then rejected this and (if I've remembered correctly) said the partition was corrupted. As I definitely hadn't encrypted my data partition, I assume (my current hypothesis until someone suggests a better one) is that what actually happened is that I mistakenly flashed the latest Android 8 and that perhaps defaults to encryption and it therefore couldn't read the non-encrypted data partition. As I don't really use Android I've just left it and not booted into Android. Sailfish does what I need. I'm assuming that if I line up the correct Android 7.1 and reflash that, it should then be able to read the data partition. I just haven't found time to do that. Someone may be able to advise, but I suspect I shouldn't have flashed the boot3 partition, which was my Android partition. If I've remembered correctly the corruption was probably in the preloader, and you might want to try just reflashing that first ...
Good luck.

stdlogicvector

  • Newbie
  • *
  • Posts: 4
    • View Profile
Gemini screen line and not boot
« Reply #8 on: December 18, 2019, 09:00:15 am »
How long did it take for the battery to die completely?

My Gemini has run for several hours yesterday showing the graphics error, then went dark and started vibrating in short bursts in irregular intervals. It wouldn't show the splash screen anymore, regardless of how long/often I pressed the Esc/On-key.

This had stopped this morning and when I connected it to the carger, the battery animation showed up on the screen and then vanished in the same graphics error as the splash screen did before. Now its back to black screen and irregular bursts of vibration.

I'm going to give it a few more hours to die and then try again...

mithrandir

  • Full Member
  • ***
  • Posts: 180
    • View Profile
    • http://www.mygnu.de
Gemini screen line and not boot
« Reply #9 on: December 18, 2019, 02:38:07 pm »
Quote from: stdlogicvector
How long did it take for the battery to die completely?

My Gemini has run for several hours yesterday showing the graphics error, then went dark and started vibrating in short bursts in irregular intervals. It wouldn't show the splash screen anymore, regardless of how long/often I pressed the Esc/On-key.

This had stopped this morning and when I connected it to the carger, the battery animation showed up on the screen and then vanished in the same graphics error as the splash screen did before. Now its back to black screen and irregular bursts of vibration.

I'm going to give it a few more hours to die and then try again...

You could remove the back cover. Then unscrew the back plastic side cover on he cable side and remove the cover. Afterwards unscrew and remove the small metal clip holding the battery plug. Then pull the plug. Then it is quite fast.

...and more healthy for the battery.
« Last Edit: December 18, 2019, 02:38:45 pm by mithrandir »

stdlogicvector

  • Newbie
  • *
  • Posts: 4
    • View Profile
Gemini screen line and not boot
« Reply #10 on: December 18, 2019, 07:10:21 pm »
Oh man... could've come up with that myself  Thanks for the hint!

Just did that and it seems to have worked. The charging light came back on, which it didn't do before and the charging animation worked to. Unfortunately, the battery already shows 0%  I hope I didn't do too much damage by discharging it too much this one time.

I'll let it charge over night and see if it boots tomorrow.

Thank you very much for your help

idc

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Gemini screen line and not boot
« Reply #11 on: August 19, 2020, 03:54:00 am »
I've had a couple more instances of this, each time the phone cutting out in the middle of a call. In these cases though, running the battery right down (over a couple of days) and then applying power has been sufficient to get the phone to reboot. No need to reflash it at all. I suspect disconnecting the battery would have done, but I was away from home in both cases and therefore didn't have access to the mini screwdriver necessary to get to the battery connection. I might have to take to carrying this with me as a matter of habit when going away.

I am wondering whether replacing the battery might stop me having this problem. But it is odd that the cut out seems to occur even when the battery is close to fully charged.